You are not logged in.

#1 2012-10-04 17:51:22

mellowmaroon
Member
Registered: 2012-04-20
Posts: 68

[SOLVED] Netcfg.service not starting with systemd

I have net-auto-wireless.service enabled and working, but when I try to start netcfg.service, it gives the error:

Job for netcfg.service failed. See 'systemctl status netcfg.service' and 'journalctl' for details.

"systemctl status netcfg.service" gives me:

netcfg.service - Netcfg multi-profile daemon
	  Loaded: loaded (/usr/lib/systemd/system/netcfg.service; enabled)
	  Active: failed (Result: exit-code) since Thu, 04 Oct 2012 13:43:05 -0400; 5min ago
	Main PID: 1510 (code=exited, status=1/FAILURE)
	  CGroup: name=systemd:/system/netcfg.service

Oct 04 13:43:05 arch systemd[1]: Starting Netcfg multi-profile daemon...
Oct 04 13:43:05 arch netcfg-daemon[1510]: No recorded netcfg state to restore
Oct 04 13:43:05 arch systemd[1]: Failed to start Netcfg multi-profile daemon.

And the output of "journalctl" is:

Oct 04 13:43:05 arch netcfg-daemon[1510]: No recorded netcfg state to restore
Oct 04 13:43:05 arch systemd[1]: netcfg.service: main process exited, code=...=1
Oct 04 13:43:05 arch systemd[1]: Unit netcfg.service entered failed state.

Am I missing something in setting it up?  I followed the netcfg wiki as closely as I could.

Last edited by mellowmaroon (2012-10-04 18:46:16)

Offline

#2 2012-10-04 18:23:16

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,837

Re: [SOLVED] Netcfg.service not starting with systemd

netcfg.service requires an array of profile names in /etc/conf.d/netcfg NETWORKS=(...) - have you set that up?

Also, I'm curious - if you're already using net-auto-wireless.service, why do you want netcfg.service?

Offline

#3 2012-10-04 18:45:47

mellowmaroon
Member
Registered: 2012-04-20
Posts: 68

Re: [SOLVED] Netcfg.service not starting with systemd

Good call, I changed it from "last", to the profile I use in /etc/network.d that net-auto-wireless autoconnects to.  It failed for a different reason after changing the NETWORKS in /etc/conf.d/netcfg, because net-auto-wireless was still running.
But it works now, thanks for the help! smile

I wanted to use netcfg instead of net-auto-wireless because I was unable to find a suitable way to connect to available networks that is non-graphical, and I felt like giving netcfg a try and seeing if it's any easier than running "systemctl restart net-auto-wireless.service" every time I want to reconnect.

Although my question for this thread is solved, is there any way to have netcfg autoconnect to profiles once I am within range?

Offline

#4 2012-10-04 18:49:22

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,059

Re: [SOLVED] Netcfg.service not starting with systemd

mellowmaroon wrote:

if it's any easier than running "systemctl restart net-auto-wireless.service" every time I want to reconnect.

aliases

alias reconn='sudo systemctl restart net-auto-wireless.service'

Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#5 2012-10-04 18:57:14

mellowmaroon
Member
Registered: 2012-04-20
Posts: 68

Re: [SOLVED] Netcfg.service not starting with systemd

Thats actually a better idea, I'm going to do that rather than use netcfg.

My other reason for trying out netcfg, I forgot to mention, was to see if it affected its included "wifi-menu" program.  While I use net-auto-wireless, it has never worked in connecting.

Anyway, thanks for the advice!

Offline

#6 2012-10-04 19:03:54

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,837

Re: [SOLVED] Netcfg.service not starting with systemd

mellowmaroon wrote:

is there any way to have netcfg autoconnect to profiles once I am within range?

I thought net-auto-wireless was meant to do exactly that:

netcfg wiki page wrote:

net-auto-wireless allows users to automatically connect to wireless networks with proper roaming support.

Are you sure you set it up correctly?

Offline

#7 2012-10-04 19:27:02

mellowmaroon
Member
Registered: 2012-04-20
Posts: 68

Re: [SOLVED] Netcfg.service not starting with systemd

The way net-auto-wireless has worked for me since having rc.conf was that it would establish a connection at boot.  If I put my laptop to sleep and reopened it at my friend's house, it doesn't attempt to establish a connection even though I have a profile in /etc/network.d for the wifi.

Using netcfg had no effect on getting "wifi-menu" to work, so I will just use net-auto-wireless. However, when I moved my wireless profile out of /etc/network.d (to test if wifi-menu would work), stopped netcfg, started net-auto-wireless, and moved my profile back in, it did not reconnect me until I restarted the daemon.  This isn't exactly the same circumstance, but having it read from existing profiles automatically is essentially what I really want.

Offline

#8 2012-10-04 20:00:26

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,837

Re: [SOLVED] Netcfg.service not starting with systemd

mellowmaroon wrote:

The way net-auto-wireless has worked for me since having rc.conf was that it would establish a connection at boot.  If I put my laptop to sleep and reopened it at my friend's house, it doesn't attempt to establish a connection even though I have a profile in /etc/network.d for the wifi.

This is known, related bug report here: https://bugs.archlinux.org/task/31037 , might be helpful.

Offline

#9 2012-11-02 12:55:02

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,470
Website

Re: [SOLVED] Netcfg.service not starting with systemd

Sorry to bring this back up, but I have a problem with Netcfg as well. According to the Wiki I can use NETWORKS=(last) with net-profiles (using systemctl enable netcfg) to have the last used connection reconnected at boot.

However, this does not work. Upon skimming through journalctl, I came across this:

netcfg-daemon[277]: No recorded netcfg state to restore

Am I doing something wrong, or is this a bug in Netcfg?


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Offline

Board footer

Powered by FluxBB