You are not logged in.

#1 2012-10-06 22:06:34

saty
Member
Registered: 2012-10-06
Posts: 18

[SOLVED] xorg on tty8 instead of the usual tty7

It freaked me a little before I realized this is the case.

Here is /etc/inittab I have:

#
# /etc/inittab
#

#  Runlevels:
#    0    Halt
#    1(S)       Single-user
#    2    Not used
#    3    Multi-user
#    4    Not used
#    5    X11
#    6    Reboot

## Only one of the following two lines can be uncommented!
# Boot to console
#id:3:initdefault:
# Boot to X11
id:5:initdefault:

rc::sysinit:/etc/rc.sysinit
rs:S1:wait:/etc/rc.single
rm:2345:wait:/etc/rc.multi
rh:06:wait:/etc/rc.shutdown
su:S:wait:/sbin/sulogin -p

# -8 options fixes umlauts problem on login
c1:2345:respawn:/sbin/agetty -8 -s 38400 tty1 linux
c2:2345:respawn:/sbin/agetty -8 -s 38400 tty2 linux
c3:2345:respawn:/sbin/agetty -8 -s 38400 tty3 linux
c4:2345:respawn:/sbin/agetty -8 -s 38400 tty4 linux
c5:2345:respawn:/sbin/agetty -8 -s 38400 tty5 linux
c6:2345:respawn:/sbin/agetty -8 -s 38400 tty6 linux

# Serial Virtual Console for KVM and others VMs
#s0:2345:respawn:/sbin/agetty -8 -s 9600 ttyS0 linux

# Hypervisor Virtual Console for Xen and KVM
#h0:2345:respawn:/sbin/agetty -8 -s 38400 hvc0 linux

ca::ctrlaltdel:/sbin/shutdown -t3 -r now                                                                                                                            
                                                                                                                                                                    
# Example lines for starting a login manager                                                                                                                        
#x:5:respawn:/usr/bin/xdm -nodaemon                                                                                                                                 
#x:5:respawn:/usr/sbin/gdm -nodaemon                                                                                                                                
x:5:respawn:/usr/bin/kdm -nodaemon                                                                                                                                  
#x:5:respawn:/usr/bin/slim >/dev/null 2>&1                                                                                                                          
                                                                                                                                                                    
#added                                                                                                                                                              
xt:5:wait:/usr/bin/chvt 7                                                                                                                                           
                                                                                                                                                                    
# End of file 

Is this normal behavior? When I switch to tty7 I'm not greeted by the login prompt I get on the other consoles. The only modification I've made to this inittab is at the end. I don't know exactly the effect of it but per the wiki, it just changes to tty7 and prevents the "console login prompt" to show in the beginning.

In case it matters I'm using nvidia proprietary driver and the /etc/X11/xorg.conf I use is the default one generated by nvidia-xconfig:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 304.51  (buildmeister@swio-display-x86-rhel47-08.nvidia.com)  Tue Sep 18 18:26:36 PDT 2012

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Thanks for the help.

Last edited by saty (2012-10-06 22:47:04)

Offline

#2 2012-10-06 22:21:27

karol
Archivist
Registered: 2009-05-06
Posts: 25,422

Re: [SOLVED] xorg on tty8 instead of the usual tty7

The addition makes tty7 occupied, if you prefer to keep X on tty7, change

#added                                                                                                                                                              
xt:5:wait:/usr/bin/chvt 7    

to e.g.

#added                                                                                                                                                              
xt:5:wait:/usr/bin/chvt 9    

and reboot.

Offline

#3 2012-10-06 22:31:32

saty
Member
Registered: 2012-10-06
Posts: 18

Re: [SOLVED] xorg on tty8 instead of the usual tty7

Thank you. It's perfect now. I suspected it might be something like that, but thought it will be mentioned in the wiki so I decided to spare myself the reboot.
I definitely will check more things before posting next time.

Offline

#4 2012-10-06 22:33:13

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] xorg on tty8 instead of the usual tty7

If you feel as though it should be mentioned in the wiki, change it.  That is how that information gets there you know.  There are no super experts who spend their days writing wiki pages.  It is us little people who solve our crap after some frusturation, and are willing to share our learned knowledge.

Offline

#5 2012-10-06 22:39:57

saty
Member
Registered: 2012-10-06
Posts: 18

Re: [SOLVED] xorg on tty8 instead of the usual tty7

WonderWoofy wrote:

If you feel as though it should be mentioned in the wiki, change it.  That is how that information gets there you know.  There are no super experts who spend their days writing wiki pages.  It is us little people who solve our crap after some frusturation, and are willing to share our learned knowledge.

You're right here. After a year or so of using linux I still can't quite get used to the fact that people actually do it. My first impressions from the forum have been great.

Last edited by saty (2012-10-06 22:40:42)

Offline

#6 2012-10-06 22:43:23

karol
Archivist
Registered: 2009-05-06
Posts: 25,422

Re: [SOLVED] xorg on tty8 instead of the usual tty7

If it's working, please remember to mark the thread as solved https://bbs.archlinux.org/viewtopic.php?id=130309

Offline

Board footer

Powered by FluxBB