You are not logged in.

#1 2012-10-08 03:07:49

limescout
Member
Registered: 2012-05-20
Posts: 24

[SOLVED] Can't connect to Facebook

For the past couple months, neither of my web browsers (Epiphany or Chromium) can get anywhere past the newsfeed on facebook.com.  If I click on a link at the news feed, it loads for a couple of minutes, then (chromium) shows me a message:

Error 324 (net::ERR_EMPTY_RESPONSE): The server closed the connection without sending any data.

I've tried using a different account and purging the cache, ala https://bbs.archlinux.org/viewtopic.php?id=131070 but to no avail.  Strangely enough, Facebook works perfectly fine in all of my VMs.  Any ideas?

Last edited by limescout (2012-10-09 22:14:09)

Offline

#2 2012-10-08 03:20:16

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] Can't connect to Facebook

Maybe you should just stop using facebook smile

Sorry I couldn't help myself...

Offline

#3 2012-10-08 04:18:49

limescout
Member
Registered: 2012-05-20
Posts: 24

Re: [SOLVED] Can't connect to Facebook

WonderWoofy wrote:

Maybe you should just stop using facebook smile

Sorry I couldn't help myself...

Haha, I would have already if it wasn't so useful tongue
I find it strange that it's just this one webpage.  Doesn't seem to happen to anything else.  I can ping facebook fine.

Offline

#4 2012-10-08 14:06:45

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 686

Re: [SOLVED] Can't connect to Facebook

limescout wrote:
WonderWoofy wrote:

Maybe you should just stop using facebook smile

Sorry I couldn't help myself...

Haha, I would have already if it wasn't so useful tongue
I find it strange that it's just this one webpage.  Doesn't seem to happen to anything else.  I can ping facebook fine.

There is a lot more to Facebook slow connection problems than just seeing if you can ping them - I monitor http://downrightnow.com/facebook which tells you whether there is a general problem getting the Facebook servers to respond to login and user requests to do a whole slew of things once logged in - very frequently they have severe slowness to respond even when pinging seems fine!  My guess is that their servers simply can't deal with the load a lot of the time.  They are building new server farms (for example one in FInland but it won't be brought into service for another year or so at least) - so in the meantime we get periods when more users are trying to use Facebook than they can handle - but there is no-one I can find to talk to about it or any official server status page to look at!

Good luck.


Mike C

Online

#5 2012-10-08 20:53:27

limescout
Member
Registered: 2012-05-20
Posts: 24

Re: [SOLVED] Can't connect to Facebook

mcloaked wrote:
limescout wrote:
WonderWoofy wrote:

Maybe you should just stop using facebook smile

Sorry I couldn't help myself...

Haha, I would have already if it wasn't so useful tongue
I find it strange that it's just this one webpage.  Doesn't seem to happen to anything else.  I can ping facebook fine.

There is a lot more to Facebook slow connection problems than just seeing if you can ping them - I monitor http://downrightnow.com/facebook which tells you whether there is a general problem getting the Facebook servers to respond to login and user requests to do a whole slew of things once logged in - very frequently they have severe slowness to respond even when pinging seems fine!  My guess is that their servers simply can't deal with the load a lot of the time.  They are building new server farms (for example one in FInland but it won't be brought into service for another year or so at least) - so in the meantime we get periods when more users are trying to use Facebook than they can handle - but there is no-one I can find to talk to about it or any official server status page to look at!

Good luck.

Hmm, very cool site.  I'll keep that one bookmarked.  I'm pretty sure it has to do with me though: native browsers don't work but VMs do (at the same time).  Also, my android device using wifi on the same network works fine.

Offline

#6 2012-10-09 11:52:35

rasertux
Member
From: Florianópolis, Brazil
Registered: 2012-03-03
Posts: 40

Re: [SOLVED] Can't connect to Facebook

I had this same problem and resolved put the mtu in 1400

Offline

#7 2012-10-09 19:36:06

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 686

Re: [SOLVED] Can't connect to Facebook

rasertux wrote:

I had this same problem and resolved put the mtu in 1400

It could be fortuitous and just coincided with Facebook coming back alive again?


Mike C

Online

#8 2012-10-09 22:13:42

limescout
Member
Registered: 2012-05-20
Posts: 24

Re: [SOLVED] Can't connect to Facebook

rasertux wrote:

I had this same problem and resolved put the mtu in 1400

It worked!  Thanks.  Had to restart before it took effect.  It also seems to have decreased the loading time on the archlinux site as well.  I'd love to know why this works, any hypothesis?

Offline

#9 2012-10-09 23:05:01

WorMzy
Forum Moderator
From: England
Registered: 2010-06-16
Posts: 4,875

Re: [SOLVED] Can't connect to Facebook

https://en.wikipedia.org/wiki/Maximum_transmission_unit wrote:

Large packets are also problematic in the presence of communications errors. Corruption of a single bit in a packet requires that the entire packet be retransmitted. At a given bit error rate, larger packets are more likely to be corrupted. Retransmissions of larger packets takes longer.

Perhaps?


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 Ti // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Offline

Board footer

Powered by FluxBB