You are not logged in.

#26 2012-10-11 21:01:01

nomorewindows
Member
Registered: 2010-04-03
Posts: 3,003

Re: PXE : can't boot (initramfs ?) [solved]

I used an older version of the guide that I have in my head to do it, but I have become proficient in being able to do these PXE clients with Arch.  It's just basically recompiling the kernel with the nfs module and the net hook and then setting up the dhcp, tftp and nfs and that's all there is to it.  This is KISS  as it gets for PXE.  I have found it more convenient to use PXE for machines that will do it, to either fix problems in place of a LiveCD, or new installation even.  I don't have to make a separate "CD" for an installation and another for everyday tasks.

Take your kernel files and run them through qemu:
qemu-system-x86_64 -kernel /srv/tftp/diskless/vmlinuz-linux -initrd /srv/tftp/diskless/initramfs-linux.img

Last edited by nomorewindows (2012-10-11 21:04:12)


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#27 2012-10-11 21:42:49

brain0
Developer
From: Aachen - Germany
Registered: 2005-01-03
Posts: 1,382

Re: PXE : can't boot (initramfs ?) [solved]

tuxtard wrote:

Here's the shot of the error screen:

http://s10.postimage.org/njsn7hpd3/IMG_ … 142526.jpg

It seems you receive a broken initramfs. What tftp server do you use?

Offline

#28 2012-10-12 11:05:18

tuxtard
Member
Registered: 2012-10-11
Posts: 30

Re: PXE : can't boot (initramfs ?) [solved]

nomorewindows wrote:

I used an older version of the guide that I have in my head to do it, but I have become proficient in being able to do these PXE clients with Arch.  It's just basically recompiling the kernel with the nfs module and the net hook and then setting up the dhcp, tftp and nfs and that's all there is to it.  This is KISS  as it gets for PXE.  I have found it more convenient to use PXE for machines that will do it, to either fix problems in place of a LiveCD, or new installation even.  I don't have to make a separate "CD" for an installation and another for everyday tasks.

Take your kernel files and run them through qemu:
qemu-system-x86_64 -kernel /srv/tftp/diskless/vmlinuz-linux -initrd /srv/tftp/diskless/initramfs-linux.img

I was able to boot the kernel into recovery shell with qemu. It seems that the image itself isn't corrupted, but that there is some kind of a problem with tftp configuration and/or tftp server. Here's my tftp setup, taken from the Network boot guide:

service tftp
{
    per_source = 11
    socket_type = dgram
    protocol = udp
    user = root
    server = /usr/sbin/tftpd
    server_args = /diskless/boot
    wait = yes
    cps = 100 2
}

/etc/conf.d/tftpd:
TFTPD_ARGS="-l -s /diskless"

@Brain0
I am using default tftp-hpa with xinetd.

Offline

#29 2012-10-12 13:20:21

brain0
Developer
From: Aachen - Germany
Registered: 2005-01-03
Posts: 1,382

Re: PXE : can't boot (initramfs ?) [solved]

tuxtard wrote:

service tftp
{
    per_source = 11
    socket_type = dgram
    protocol = udp
    user = root
    server = /usr/sbin/tftpd
    server_args = /diskless/boot
    wait = yes
    cps = 100 2
}

/etc/conf.d/tftpd:
TFTPD_ARGS="-l -s /diskless"

@Brain0
I am using default tftp-hpa with xinetd.

That is not tftp-hpa, but iputils/tftpd, which is sort of broken. tftp-hpa is in /usr/sbin/in.tftpd, and there is no xinetd file for it currently (only rc.d script and systemd socket-activated unit).

Offline

#30 2012-10-12 13:43:38

nomorewindows
Member
Registered: 2010-04-03
Posts: 3,003

Re: PXE : can't boot (initramfs ?) [solved]

Your tftp is pointing to /diskless not /srv/tftp/diskless where the rest of it should be.
Then your xinetd is pulling the boot file from /diskless/boot.  With the implementation I'm guiding you towards this is redundant.
I thought xinetd was a redhat thing from about 10 years ago, but alas, it's back.  Not that it was bad, but it had more options than inetd.  Inetd's job was to open a new socket when a new request was made to one of the ports below 1024 was accessed remotely. 
I'm not even using the xinetd part for it, because the way they have it configured in xinetd is just standard, and it's introducing an error condition.
Please use the tftp-hpa, which I was using the previous guide that wasn't using xinetd or iputils/tftpd.  The old guide said to use tftp-hpa.


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#31 2012-10-12 14:53:03

tuxtard
Member
Registered: 2012-10-11
Posts: 30

Re: PXE : can't boot (initramfs ?) [solved]

Well guys, that was IT! When I switched to tftp-hpa I was able to boot normally. Now we all know that we should stay clear of xinetd and use regular tftp-hpa. That was the only problem in the Network boot guide I was following. Thank you all so much on your help!

Offline

#32 2012-10-12 15:21:49

nomorewindows
Member
Registered: 2010-04-03
Posts: 3,003

Re: PXE : can't boot (initramfs ?) [solved]

tuxtard wrote:

Well guys, that was IT! When I switched to tftp-hpa I was able to boot normally. Now we all know that we should stay clear of xinetd and use regular tftp-hpa. That was the only problem in the Network boot guide I was following. Thank you all so much on your help!

Congratulations!  Edit the first post and add [solved] to the title.  Note to self: That wasn't OP, but OP would probably be happy with solution.
Xinetd was new when it first came out, but it's considered more or less ancient now.
I don't know who added the idea to use xinetd when rewriting the wiki, but it definitely doesn't belong there.  They must've migrated from another distro when they rewrote or something.  It'll probably work for some other distro (can't imagine which one) and is a reference for that purpose, but otherwise it is useless for Arch purposes.

Last edited by nomorewindows (2012-10-12 20:27:11)


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#33 2012-10-12 16:36:05

ealrann
Member
Registered: 2012-03-22
Posts: 9

Re: PXE : can't boot (initramfs ?) [solved]

Thank you smile

I have update the first post.

Last edited by ealrann (2012-10-12 16:36:26)

Offline

Board footer

Powered by FluxBB