You are not logged in.

#1 2012-10-11 23:25:30

Webmaniac2
Member
Registered: 2009-12-24
Posts: 27

libc.so.6: version `GLIBC_2.16' not found

Hey everyone,

I haven't used my Arch system for some months now, thus I had to go through the updating marathon with all these issues.

I've read threads on the forums, guides and asked google for help. I think that I'm close to the finish line. But now I get this error message when using pacman:

pacman: /lib/libc.so.6: version `GLIBC_2.16' not found (required by /lib/libarchive.so.12)

I probably messed something up. sad
In this thread someone had a similar problem and was able to solve it, but he had to struggle with "libcurl.so.4" instead of "libarchive.so.12". So his "workaround" for the curl package is to no avail for me. How can I find out what package is affected by "libarchive.so.12"? And can I use a similar workaround?

Any help is greatly appreciated!

best regards
Webmaniac

Offline

#2 2012-10-12 22:36:38

alexanderthegre
Member
Registered: 2012-07-29
Posts: 66

Re: libc.so.6: version `GLIBC_2.16' not found

I got that message when moving a 64-bit-capable install to 64-bit. Reinstalling all of the packages seemed to fix it. (maybe just reinstalling glibc & related packages would work, I have no idea, just thought this might be relevant.

Offline

#3 2012-10-15 12:12:50

Webmaniac2
Member
Registered: 2009-12-24
Posts: 27

Re: libc.so.6: version `GLIBC_2.16' not found

The problem is, that I can't use pacman, so I can't (re)install any packages at all.
Even "pacman --help" gives me the error mentioned in my first post.

Offline

#4 2012-10-15 12:23:43

Pierre
Developer
From: Bonn
Registered: 2004-07-05
Posts: 1,950
Website

Re: libc.so.6: version `GLIBC_2.16' not found

Try using pacstrap from the install medium.

Online

#5 2012-10-16 12:03:35

Webmaniac2
Member
Registered: 2009-12-24
Posts: 27

Re: libc.so.6: version `GLIBC_2.16' not found

I've installed Arch on a Raid0. When I try to enable the raid ("dmraid -ay") with the live cd, I get:

[...]stripe:Couldn't parse stripe destination
RAID set "isw_..._Volume0" was not detected
ERROR: device "isw_..._Volume0" could not be found'

Can't fix it.
Is there any way that I can use pacstrap from an existing Ubuntu install? I could enable my raid with Ubuntu and then use pacstrap to fix my arch install, couldn't I?

Offline

Board footer

Powered by FluxBB