You are not logged in.

#1 2012-10-10 07:48:10

andybz
Member
Registered: 2012-10-10
Posts: 4

Booting 2012.10.06 ISO in EFI drops me to EFI Shell

I wanted to rebuild my Arch box using EFI only, but when I boot the ISO all I see is:

  Press ESC in X seconds to skip startup.nsh or any other key to continue.

then

  2.0 Shell >

Whether I skip it startup.nsh or not, I get the same result.
I've cruised all the EFI documentation, and I was expecting to see gummiboot or at least something that would start the Arch ISO.

I thought maybe it was motherboard, but I get the same thing through Virtualbox and using both the ISO as a CD, or writing it to a USB disk.

Any help appreciated.

Offline

#2 2012-10-10 09:25:50

the.ridikulus.rat
Member
From: Indiana, USA
Registered: 2011-10-04
Posts: 765

Re: Booting 2012.10.06 ISO in EFI drops me to EFI Shell

You must have renamed some older iso by mistake. The newer iso does not use UEFI Shell, instead it uses gummiboot and by default directly boots the kernel, so technically you shouldn't see any menu unless you press space bar during the timeout which i think is 3 or 5 seconds. Another user has confirmed that the iso boots using gummiboot at https://bbs.archlinux.org/viewtopic.php?id=150277 .

Offline

#3 2012-10-10 14:03:03

ataraxia
Member
From: Pittsburgh
Registered: 2007-05-06
Posts: 1,537

Re: Booting 2012.10.06 ISO in EFI drops me to EFI Shell

I've found that I do get an EFI shell on the current ISO if I'm on a 32-bit EFI. That isn't surprising to me as the ISO must be using a 64-bit gummiboot.

Offline

#4 2012-10-10 21:51:49

andybz
Member
Registered: 2012-10-10
Posts: 4

Re: Booting 2012.10.06 ISO in EFI drops me to EFI Shell

Can't explain it, but I can confirm with ataraxia that trying it on a 32-bit Virtualbox VM, I brings up the shell. 64-bit VM in Virtualbox worked, so I went back to my hardware.

I managed to get around it using a rEFInd CD with the Arch install ISO written on to my USB stick. The archiso boot menu was detected by rEFInd and worked right away, with gummiboot appearing.

Offline

#5 2012-10-19 18:20:57

moneytoo
Member
From: Czech Republic
Registered: 2012-04-04
Posts: 20

Re: Booting 2012.10.06 ISO in EFI drops me to EFI Shell

I experience the exactly same issue when booting on Asus P8Z77-V PRO/THUNDERBOLT in UEFI mode from DVD.

Offline

#6 2012-10-27 14:48:46

Chuck Arch Linux
Member
Registered: 2011-06-23
Posts: 61

Re: Booting 2012.10.06 ISO in EFI drops me to EFI Shell

Same behavior for me...I just type exit on the shell and the arch iso as boot after that and I manage to install arch linux normally.

Last edited by Chuck Arch Linux (2012-10-28 14:23:00)

Offline

#7 2012-10-29 10:38:11

qinohe
Member
From: A Dutch location..)
Registered: 2012-06-20
Posts: 649

Re: Booting 2012.10.06 ISO in EFI drops me to EFI Shell

Exiting the EFI shell also means not installing Arch with EFI bootloader.
When in shell type 'startup' you're install should start now;)


-I can give you a ladder, but you need to climb it yourself-

Offline

Board footer

Powered by FluxBB