You are not logged in.

#1 2012-10-28 18:43:24

Kotrfa
Member
Registered: 2012-10-25
Posts: 146

[SOLVED]/etc/vconsole.conf doesn't react to any change

Hi,

I'm new in Arch Linux, so sorry if I'm missreading something.

I try to change my font and keymap using this manual: https://wiki.archlinux.org/index.php/KEYMAP

So i edit /etc/vconsole.conf like this:

KEYMAP=cz-lat2
FONT=Lat2-Terminus16

but nothing change, even after reboot. "kbd" is installed.

Btw. when I run "setfont Lat2-Terminus16" the font is changed (but just this session).

Thanks

Last edited by Kotrfa (2012-11-06 16:22:41)

Offline

#2 2012-10-28 19:09:06

vik_k
Member
From: Pune, India
Registered: 2009-07-12
Posts: 227
Website

Re: [SOLVED]/etc/vconsole.conf doesn't react to any change

If you are saying "setfont Lat2-Terminus16" works, then try giving the whole font name i.e. Lat2-Terminus16 in vconsole.conf file and put it in quotes also.
Hope it should work. I, myself use full font name and use it within quotes.


"First learn computer science and all the theory. Next develop a programming style. Then forget all that and just hack." ~ George Carrette

Offline

#3 2012-10-28 19:16:05

Kotrfa
Member
Registered: 2012-10-25
Posts: 146

Re: [SOLVED]/etc/vconsole.conf doesn't react to any change

Sorry, it is badly written. I have there "Lat2-Terminus16". Edited.

So, still isnt solved


Edit2: Even Lat2-Terminus16 doesnt work. And layout doesnt work to.

Last edited by Kotrfa (2012-10-28 19:17:45)

Offline

#4 2012-10-28 19:16:37

loafer
Member
From: the pub
Registered: 2009-04-14
Posts: 1,691

Re: [SOLVED]/etc/vconsole.conf doesn't react to any change

FONT=Lat2-Terminus16

Entering it in the above format should work.

edit:  There is also this thread:

https://bbs.archlinux.org/viewtopic.php?pid=1180285

Last edited by loafer (2012-10-28 19:22:36)


All men have stood for freedom...
For freedom is the man that will turn the world upside down.
Gerrard Winstanley.

Offline

#5 2012-10-29 12:20:32

Kotrfa
Member
Registered: 2012-10-25
Posts: 146

Re: [SOLVED]/etc/vconsole.conf doesn't react to any change

It doesnt work in any form.

I tried to add i915 to my mkinicpio to modules, but when I run:

[dan@localhost ~]$ sudo  mkinitcpio -p linux
[sudo] password for root: 
==> Building image from preset: 'default'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 3.6.3-1-ARCH
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
findmnt: /etc/fstab: parse error at line 7
  -> Running build hook: [pata]
  -> Running build hook: [scsi]
  -> Running build hook: [sata]
  -> Running build hook: [filesystems]
  -> Running build hook: [usbinput]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip initcpio image: /boot/initramfs-linux.img
bsdcpio: Failed to set default locale
==> Image generation successful
==> Building image from preset: 'fallback'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
==> Starting build: 3.6.3-1-ARCH
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [pata]
  -> Running build hook: [scsi]
  -> Running build hook: [sata]
  -> Running build hook: [filesystems]
  -> Running build hook: [usbinput]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip initcpio image: /boot/initramfs-linux-fallback.img
bsdcpio: Failed to set default locale
==> Image generation successful

There are messages about failing to set locale.

Btw. here is my locale and locale -a output:

[dan@localhost ~]$ locale -a
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_COLLATE to default locale: No such file or directory
C
POSIX
cs_CZ.utf8
en_GB.utf8
[dan@localhost ~]$ locale   
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_US.utf8
LC_CTYPE="en_US.utf8"
LC_NUMERIC="en_US.utf8"
LC_TIME="en_US.utf8"
LC_COLLATE="en_US.utf8"
LC_MONETARY="en_US.utf8"
LC_MESSAGES="en_US.utf8"
LC_PAPER="en_US.utf8"
LC_NAME="en_US.utf8"
LC_ADDRESS="en_US.utf8"
LC_TELEPHONE="en_US.utf8"
LC_MEASUREMENT="en_US.utf8"
LC_IDENTIFICATION="en_US.utf8"
LC_ALL=

Edit: When I try to change my keyboard layout in gnome creating /etc/X11/xorg.conf.d/10-keyboard.conf with:

Section "InputClass"
	Identifier	"Keyboard Defaults"
	MatchIsKeyboard "yes"
	Option		"XbkLayout" "cz"
EndSection

it doesn't work.

And when I try to use: "setxkbmap cz", it change my keyboard to czech, but it doesn't work in terminal (when i type "+ěščřtřžýáí" i get "+???????".

Last edited by Kotrfa (2012-10-29 12:33:51)

Offline

#6 2012-10-29 12:48:12

loafer
Member
From: the pub
Registered: 2009-04-14
Posts: 1,691

Re: [SOLVED]/etc/vconsole.conf doesn't react to any change

You need to fix the locale problem.  Have you uncommented your desired locale in locale.gen and then run locale-gen?


All men have stood for freedom...
For freedom is the man that will turn the world upside down.
Gerrard Winstanley.

Offline

#7 2012-10-29 13:19:37

Kotrfa
Member
Registered: 2012-10-25
Posts: 146

Re: [SOLVED]/etc/vconsole.conf doesn't react to any change

Yes, I have uncommented "cs_CZ.UTF-8 UTF-8".

[dan@localhost ~]$ sudo locale-gen
Generating locales...
  cs_CZ.UTF-8... done
  en_GB.UTF-8... done
Generation complete.

It worked and works fine, but keymap nor font dont change even after reboot.

Edited

Last edited by Kotrfa (2012-10-29 13:28:58)

Offline

#8 2012-10-29 13:22:38

bernarcher
Forum Fellow
From: Germany
Registered: 2009-02-17
Posts: 2,271

Re: [SOLVED]/etc/vconsole.conf doesn't react to any change

Don't forget to mark this thread [SOLVED] then, Kotrfa.


To know or not to know ...
... the questions remain forever.

Offline

#9 2012-10-29 13:27:36

Kotrfa
Member
Registered: 2012-10-25
Posts: 146

Re: [SOLVED]/etc/vconsole.conf doesn't react to any change

Oh, sorry, but it isnt solved yet big_smile .

Probably my english skills...

I tried to say that locale-gen works fine. But my problem isnt solved.

Offline

#10 2012-11-05 10:56:56

Doctor Colossus
Member
Registered: 2012-08-26
Posts: 16

Re: [SOLVED]/etc/vconsole.conf doesn't react to any change

Nope, your English is fine enough (except you oughtn't use no [sic] double negatives).

Same problem here, with the same font.

setfont Lat2-Terminus16

works for me.

setfont

with no arguments restores the terminal back to some generic font (how to figure out what it's using as the default?). But

FONT=Lat2-Terminus16

in /etc/vconsole.conf has no effect. This font was working for me previously with SysVinit and

CONSOLEFONT="Lat2-Terminus16"

in rc.conf.

I also tried with quotes:

FONT="Lat2-Terminus16"

with quotes. And the full path:

FONT=/usr/share/kbd/consolefonts/Lat2-Terminus16.psfu.gz

No improvements.

My full vconsole.conf is now:

KEYMAP=dvorak-pl
FONT=Lat2-Terminus16
FONT_MAP=8859-2

* dvorak-pl is my custom keymap and it's still working fine

Please help us if you can! [-: It's the only decent console font (I'm aware of) with support for Polish and Czech characters.

Last edited by Doctor Colossus (2012-11-05 12:38:07)

Offline

#11 2012-11-05 11:01:19

Doctor Colossus
Member
Registered: 2012-08-26
Posts: 16

Re: [SOLVED]/etc/vconsole.conf doesn't react to any change

[merged with the previous post]

Last edited by Doctor Colossus (2012-11-05 12:38:33)

Offline

#12 2012-11-05 12:17:54

Doctor Colossus
Member
Registered: 2012-08-26
Posts: 16

Re: [SOLVED]/etc/vconsole.conf doesn't react to any change

OK, here is something to try:

Tom Gunderson wrote:

The problem is (I think), that your font is set before your graphics driver has been loaded, and once the graphics driver has been loaded the settings are lost. Essentially what needs to happen is that
systemd-vconsole-setup.service must be run after the graphics driver has been loaded.

Three ways to do this:
1) put your graphics driver in MODULES in mkinitcpio.conf.
2) put your graphics driver in /etc/modules-load.d/graphics.conf and order systemd-vconsole-setup.service After systemd-modules-load.service.
3) order systemd-vconsole-setup.service After and Wants systemd-udev-settle.service.

Option 2 probably is the best as it has the least impact on boot speed (I guess).

Will report back after I've read up and tried these solutions.

Offline

#13 2012-11-05 12:35:58

Doctor Colossus
Member
Registered: 2012-08-26
Posts: 16

Re: [SOLVED]/etc/vconsole.conf doesn't react to any change

Nice -- that did the trick for me.

I guess if you want to use option 2, he is talking about this.

But I didn't want to learn all the ins and outs of systemd today; I just wanted to get it up and running and have everything working like it did before with SysVinit.  So I chose option 1 out of laziness.  I added my video driver to the modules in /etc/mkinitcpio.conf and rebuilt the initramfs.  And now my tty's are once again using a readable font -- huzzah!

Offline

#14 2012-11-05 13:06:45

loafer
Member
From: the pub
Registered: 2009-04-14
Posts: 1,691

Re: [SOLVED]/etc/vconsole.conf doesn't react to any change

Which video card and driver?  The OP tried this and it didn't work for him with i915.


All men have stood for freedom...
For freedom is the man that will turn the world upside down.
Gerrard Winstanley.

Offline

#15 2012-11-05 14:44:57

unifiedlinux
Member
Registered: 2012-11-03
Posts: 20

Re: [SOLVED]/etc/vconsole.conf doesn't react to any change

So your keyboard layout isn't loaded from "/etc/vconsole.conf" and by default you have the english "qwerty" layout, right ? What happens if you do "loadkeys cz-lat2" (or whatever you mentionned in your vconsole.conf) ? And what happens when you put KEYMAP=cz in your /etc/vconsole.conf ? Because for a french keyboard i just set "fr", no need for additional stuff like "lat2".

EDIT: owned by the TAB key and posted before actually finishing writing this.

Last edited by unifiedlinux (2012-11-05 14:46:02)

Offline

#16 2012-11-05 18:36:01

tomegun
Developer
From: France
Registered: 2010-05-28
Posts: 661

Re: [SOLVED]/etc/vconsole.conf doesn't react to any change

Try calling /usr/lib/systemd/systemd-vconsole-setup manually to see if that works. Should narrow it down.

Offline

#17 2012-11-05 19:34:35

tobsen
Member
Registered: 2011-10-13
Posts: 36

Re: [SOLVED]/etc/vconsole.conf doesn't react to any change

I had the same problem with my installation. Putting i915 in mkinitcpio's MODULES solved the problem.

Offline

#18 2012-11-06 16:22:23

Kotrfa
Member
Registered: 2012-10-25
Posts: 146

Re: [SOLVED]/etc/vconsole.conf doesn't react to any change

Yes, it helped. Solved

Offline

#19 2012-11-06 23:30:07

Doctor Colossus
Member
Registered: 2012-08-26
Posts: 16

Re: [SOLVED]/etc/vconsole.conf doesn't react to any change

@Kotrfa: Great. So all you had to do was run mkinitcpio again after fixing your locale problem, right?

@loafer: Same driver here -- i915.

Offline

#20 2013-01-20 22:55:26

dancer69
Banned
Registered: 2011-08-05
Posts: 66

Re: [SOLVED]/etc/vconsole.conf doesn't react to any change

This seems that doesn't work for me. I've tried first the 2nd method:
I made a file graphics.conf in /etc/modules.d and I put inside the just the name of my card's module which is radeon
and then I opened the file systemd-vconsole-setup.service in /usr/lib/systemd/system and I added the systemd-modules-load.service at the end in After section.
It didn't make any difference.
So I tried and 1st method, put radeon on Modules and rebuilt initramfs. No errors but still no impovement.
both loadkeys and setfont(in which use exactly the same font as on vconsole.conf) work fine, but before run them manually I cannot change keyboard layout, and greek characters displayed as ieroglyphics.
Any idea?

Offline

Board footer

Powered by FluxBB