You are not logged in.

#1 2012-10-25 17:51:43

nathanb
Member
From: New Zealand
Registered: 2011-11-28
Posts: 66
Website

[Solved] Updating extra repos doesn't work over wireless (too slow)

I have a weird problem...when I'm on wireless, the core repository updates fine but then the extra repository doesn't update.

[root@nathanb-micro ~]# pacman -Syu
:: Synchronizing package databases...
 core                     107.2 KiB  2.15M/s 00:00 [######################] 100%
error: failed retrieving file 'extra.db' from mirrors.kernel.org : Operation too slow. Less than 1024 bytes/sec transferred the last 10 seconds
error: failed retrieving file 'extra.db' from mirror.us.leaseweb.net : Operation too slow. Less than 1024 bytes/sec transferred the last 10 seconds
error: failed retrieving file 'extra.db' from mirrors.gigenet.com : Operation too slow. Less than 1024 bytes/sec transferred the last 10 seconds
error: failed retrieving file 'extra.db' from mirrors.xmission.com : Operation too slow. Less than 1024 bytes/sec transferred the last 10 seconds
error: failed retrieving file 'extra.db' from archlinux.limun.org : Operation too slow. Less than 1024 bytes/sec transferred the last 10 seconds
error: failed retrieving file 'extra.db' from mirror.rit.edu : Operation too slow. Less than 1024 bytes/sec transferred the last 10 seconds
error: failed retrieving file 'extra.db' from ftp.tuxdroid.org : Operation too slow. Less than 1024 bytes/sec transferred the last 10 seconds
error: failed retrieving file 'extra.db' from cake.lib.fit.edu : Operation too slow. Less than 1024 bytes/sec transferred the last 10 seconds
error: failed retrieving file 'extra.db' from mirrors.liquidweb.com : Operation too slow. Less than 1024 bytes/sec transferred the last 10 seconds
error: failed retrieving file 'extra.db' from mirror.datacenter.by : Operation too slow. Less than 1024 bytes/sec transferred the last 10 seconds
^Cxtra                      4.0 KiB  1357B/s 17:49 [----------------------]   0%
Interrupt signal received

Any ideas?

Last edited by nathanb (2012-10-31 19:54:27)

Offline

#2 2012-10-25 17:54:14

karol
Archivist
Registered: 2009-05-06
Posts: 25,432

Re: [Solved] Updating extra repos doesn't work over wireless (too slow)

Have you tried using

man pacman.conf wrote:

       XferCommand = /path/to/command %u
           If set, an external program will be used to download all
           remote files. All instances of %u will be replaced with
           the download URL. If present, instances of %o will be
           replaced with the local filename, plus a “.part”
           extension, which allows programs like wget to do file
           resumes properly.

           This option is useful for users who experience problems
           with built-in http/ftp support, or need the more advanced
           proxy support that comes with utilities like wget.

Also, try using other mirrors: https://bbs.archlinux.org/viewtopic.php?id=142891

Last edited by karol (2012-10-25 17:56:01)

Offline

#3 2012-10-25 23:24:19

Jristz
Member
From: America/Santiago
Registered: 2011-06-11
Posts: 924

Re: [Solved] Updating extra repos doesn't work over wireless (too slow)

Try an alternative download manager in XferCommand but remmember not allow change server at download time or you db may be corrupted and pacman not check it at this time (only check packages not databases)

second have patience

tree use the mostest fast and updated repos ever in you mirrorlist


Well, I suppose that this is somekind of signature, no?

Offline

#4 2012-10-31 19:54:06

nathanb
Member
From: New Zealand
Registered: 2011-11-28
Posts: 66
Website

Re: [Solved] Updating extra repos doesn't work over wireless (too slow)

It appears that I was seeing another case of the problem reported here.

I played with the mirror list and removed all unnecessary mirrors, and things appear to be working now.

Offline

Board footer

Powered by FluxBB