You are not logged in.

#26 2012-10-31 14:24:30

rkwurth
Member
Registered: 2012-10-31
Posts: 18

Re: [SOLVED] GDM crashes after the new update

@benob: Hey, glad to hear it.

Offline

#27 2012-10-31 14:49:28

sweetthdevil
Member
Registered: 2009-10-20
Posts: 329

Re: [SOLVED] GDM crashes after the new update

Right, I am now back on my desktop. The issue was that I wasn't using systemd

Adding "init=/usr/lib/systemd/systemd" to grub resolve the issue!

Many thanks for your assistance and sorry for not following the news sad

Offline

#28 2012-10-31 15:06:36

rkwurth
Member
Registered: 2012-10-31
Posts: 18

Re: [SOLVED] GDM crashes after the new update

You're welcome, glad to have been of assistance. Considering the infrequency of front page updates, it's safe to assume they're there for a reason. smile

Offline

#29 2012-10-31 22:29:51

Jack_CM
Member
Registered: 2012-02-10
Posts: 35

Re: [SOLVED] GDM crashes after the new update

I've got this issue as well, but none of the suggested solutions worked

Offline

#30 2012-11-01 00:19:05

themusicalduck
Member
Registered: 2011-07-04
Posts: 82

Re: [SOLVED] GDM crashes after the new update

I'm having problems logging into Gnome. GDM will work but once I log into Gnome I get the "Something has gone wrong" screen.

I've followed all the suggestions on this thread but have had no luck.

Offline

#31 2012-11-01 00:51:33

rezzo
Member
From: Santiago, Chile
Registered: 2006-04-08
Posts: 22
Website

Re: [SOLVED] GDM crashes after the new update

Same here, no luck.

Offline

#32 2012-11-01 01:12:02

rkwurth
Member
Registered: 2012-10-31
Posts: 18

Re: [SOLVED] GDM crashes after the new update

Urrbody's using systemd, correct? Can you get to gnome via startx, and if not, what's the output from running startx?

Last edited by rkwurth (2012-11-01 01:18:56)

Offline

#33 2012-11-01 01:32:27

misterpah
Member
Registered: 2012-04-04
Posts: 2

Re: [SOLVED] GDM crashes after the new update

mine were solved last night (1:00 AM GMT+8)
i think it's because of the recent update :

extra/gnome-shell 3.6.1-2

if you have completed the pure systemd installation (https://wiki.archlinux.org/index.php/Systemd) , just do a full update.

pacman -Syu

thanks for the help

Offline

#34 2012-11-01 01:39:23

themusicalduck
Member
Registered: 2011-07-04
Posts: 82

Re: [SOLVED] GDM crashes after the new update

rkwurth wrote:

Urrbody's using systemd, correct? Can you get to gnome via startx, and if not, what's the output from running startx?

startx > logfile.txt gave me this:

GNOME_KEYRING_CONTROL=/run/user/1000/keyring-TZlId1
SSH_AUTH_SOCK=/run/user/1000/keyring-TZlId1/ssh
GNOME_KEYRING_PID=3366
GNOME_KEYRING_CONTROL=/run/user/1000/keyring-TZlId1
SSH_AUTH_SOCK=/run/user/1000/keyring-TZlId1/ssh
GNOME_KEYRING_CONTROL=/run/user/1000/keyring-TZlId1
SSH_AUTH_SOCK=/run/user/1000/keyring-TZlId1/ssh
GNOME_KEYRING_CONTROL=/run/user/1000/keyring-TZlId1
SSH_AUTH_SOCK=/run/user/1000/keyring-TZlId1/ssh
GPG_AGENT_INFO=/run/user/1000/keyring-TZlId1/gpg:0:1
Initializing tracker-store...
Starting log:
  File:'/home/theo/.local/share/tracker/tracker-store.log'
Initializing tracker-miner-fs...
Starting log:
  File:'/home/theo/.local/share/tracker/tracker-miner-fs.log'
Initializing nautilus-open-terminal extension
Initializing nautilus-dropbox 1.4.0
Another instance of Dropbox (1808) is running!

Received signal:1->'Hangup'

Received signal:1->'Hangup'

Gnome will start, but the "Something has gone wrong" screen will appear and I have to click Log out. I am using systemd.

Last edited by themusicalduck (2012-11-01 01:39:48)

Offline

#35 2012-11-01 02:36:56

startover
Banned
Registered: 2011-01-24
Posts: 27

Re: [SOLVED] GDM crashes after the new update

i confirm having not configured systemd was the problem. in my case the problem was resolved by running

systemctl enable gdm

and then adding

init=/usr/lib/systemd/systemd

to the grub. thanks to the posts which helped out.

Offline

#36 2012-11-01 03:30:14

wancheng
Member
From: china
Registered: 2012-10-17
Posts: 2

Re: [SOLVED] GDM crashes after the new update

cat /boot/grub/menu.lst

# each is implicitly numbered from 0 in the order of appearance below
#
# TIP: If you want a 1024x768 framebuffer, add "vga=773" to your kernel line.
#
#-*

# (0) Arch Linux
title  Arch Linux
root   (hd0,2)
kernel /vmlinuz-linux root=/dev/sda7 ro
initrd /initramfs-linux.img

# (1) Arch Linux
title  Arch Linux Fallback
root   (hd0,2)
kernel /vmlinuz-linux root=/dev/sda7 ro
initrd /initramfs-linux-fallback.img

# (2) Windows
title Windows
rootnoverify (hd0,0)
makeactive
chainloader +1

edit
kernel /vmlinuz-linux root=/dev/sda7 ro
to:
kernel /vmlinuz-linux root=/dev/sda7 init=/usr/lib/systemd/systemd ro

reboot
fixed it

Offline

#37 2012-11-01 07:00:14

sreejiraj
Member
Registered: 2010-01-26
Posts: 5

Re: [SOLVED] GDM crashes after the new update

Can confirm my issue - GDM said 'oops. something went wrong..' after upgrading to 3.6 and never allowed me to log in - was fixed by adding "init=/usr/lib/systemd/systemd" to kernel's boot parameters in Grub. Thanks to Sweetthdevil and others.

Offline

#38 2012-11-01 11:13:57

Jack_CM
Member
Registered: 2012-02-10
Posts: 35

Re: [SOLVED] GDM crashes after the new update

I think that another thread should be open, as this has been marked as Solved

Offline

#39 2012-11-04 23:36:34

BinaryMan
Member
Registered: 2011-07-19
Posts: 14

Re: [SOLVED] GDM crashes after the new update

benob wrote:

Workaround: I was not able to fix gdm, but using slim as a display manager seems to work. Here are the steps I followed:

Assuming you use systemd as described in the wiki. If your session freeses, add the parameter "1" to your kernel command line in grub, this leads you to a bare bones recovery console in which you can disable gdm with

systemctl disable gdm.service

Then boot normally to a console login prompt. Install xorg-xinit and slim:

pacman -S xorg-xinit slim

Enable the slim service:

systemctl enable slim.service

Edit your .xinitrc (as described in the wiki) to make sure it runs gnome:

exec gnome-session

And finally start slim:

systemctl start slim.service

This is exactly what I experienced and this workaround worked pretty nice. Though, I was unable to install xorg-init.

Offline

Board footer

Powered by FluxBB