You are not logged in.

#1 2012-11-01 10:22:50

Registered: 2010-12-15
Posts: 21

X does not start since last update (gnome 3.6)


the last big update to Gnome 3.6 shot my system completely.

- I can not start X. GDM is started successfully but when the system wants to switch to the graphical interface, nothing happens. If i start X manually, the error message is "no screens found".
- No network anymore, because no interfaces are found (normally eth0 and wlan0)
- It seems like the graphic card driver (nvidia-bumblebee) is not working either. The command line is on a very low resolution.
- The following services fail to load during the boot process:
   - bluetooth.service
   - dhcpcd@eth0.service
   - systemd-modules-load.service

I already used a pure systemd installation before updating to Gnome 3.6. I do not have a rc.conf and I use the boot parameter 'init=/usr/lib/systemd/systemd'.

Also, I tried different proposals from but they didn't work though.

My laptop: Thinkpad W520

Any ideas? I spent already a lot of time but could not figure out any solution.,




#2 2012-11-01 14:38:54

Registered: 2012-10-01
Posts: 50

Re: X does not start since last update (gnome 3.6)

Search your logs and find out why systemd-modules-load.service is failing.  It's most likely the source of your other issues.


#3 2012-11-03 17:50:28

Registered: 2011-04-15
Posts: 147

Re: X does not start since last update (gnome 3.6)

The upgrade to Gnome 3.6 and systemd has been very annoying.... But the benefits of systemd will outweigh our initial struggles once our bugs are fixed... Especially for those of us with multi-core processors.

Last edited by amadar (2012-11-03 17:50:40)


Board footer

Powered by FluxBB