You are not logged in.

#4526 2012-11-01 21:20:51

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,299
Website

Re: The AMD/ATI Bar & Grill

HariSeldon wrote:

Hi Vi0l0,
I've a Dell Inspiron 15R SE (with a 7730M hybrid muxless switch and intel hd4000).
With ubuntu 12.04 proprietary catalyst works just fine, but in arch there's no way to make it work.
Trying to install your package, at the next reboot kdm doesn't start, and system hangs up.
At the end of boot process, when I should login in,  It says something like "restaring x too many times" on the black screen, and the sistem hangs up. No tty works.

Any suggestion?

Tnx,
HS

Have you tried -pxp package(s)? We've been talking about it on two last pages

Last edited by Vi0L0 (2012-11-01 21:21:35)

Offline

#4527 2012-11-02 09:26:10

libgradev
Member
Registered: 2012-02-23
Posts: 16

Re: The AMD/ATI Bar & Grill

Native Apps - 12.11b

Work fine but aren't as fluid as they were under 12.8. Tried Oil Rush (getting some noticable brief pauses), Heaven Bench, Google Earth.

DisplayPort connections are still buggy - one screen came back corrupted after a blank (once) - but easier to fix with a monitor off/on. Previously resolving this required a restart of X!

Offline

#4528 2012-11-02 09:45:28

HariSeldon
Member
Registered: 2012-04-30
Posts: 13

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:
HariSeldon wrote:

Hi Vi0l0,
I've a Dell Inspiron 15R SE (with a 7730M hybrid muxless switch and intel hd4000).
With ubuntu 12.04 proprietary catalyst works just fine, but in arch there's no way to make it work.
Trying to install your package, at the next reboot kdm doesn't start, and system hangs up.
At the end of boot process, when I should login in,  It says something like "restaring x too many times" on the black screen, and the sistem hangs up. No tty works.

Any suggestion?

Tnx,
HS

Have you tried -pxp package(s)? We've been talking about it on two last pages


Tnx Vi0l0 for your support.

I've tried with the catalyst-total-pxp package on arch.

Today I'm doing a new arch installation from scratch (I've messed up some thing with systemd transition) and i'll try to re-install from zero.

If you've some suggestion on some installation details, please tell me smile

Thanks in advance,

HS

P.S.:

If I can help as tester, just tell me .

Offline

#4529 2012-11-02 13:29:27

PLANTROON
Member
From: Slovakia
Registered: 2012-08-08
Posts: 61

Re: The AMD/ATI Bar & Grill

I have a question about hd234k graphics cards. Will they ever get support for Xorg 1.13 and Windows 8?
Also, why can't a driver named catalyst-hd234k be in the official community repo? It would be awesome...

Offline

#4530 2012-11-02 15:03:48

libgradev
Member
Registered: 2012-02-23
Posts: 16

Re: The AMD/ATI Bar & Grill

PLANTROON wrote:

I have a question about hd234k graphics cards. Will they ever get support for Xorg 1.13 and Windows 8?

Under Catalyst - goodness knows. TBH those users would probably be better off simply buying a new card.

Offline

#4531 2012-11-02 15:24:11

PLANTROON
Member
From: Slovakia
Registered: 2012-08-08
Posts: 61

Re: The AMD/ATI Bar & Grill

libgradev wrote:
PLANTROON wrote:

I have a question about hd234k graphics cards. Will they ever get support for Xorg 1.13 and Windows 8?

Under Catalyst - goodness knows. TBH those users would probably be better off simply buying a new card.

I live in Slovakia and I am so poor ... buying a new card is not a solution for me big_smile Hopefuly I will buy a PC with nVidia graphics next time...

Offline

#4532 2012-11-02 15:59:22

HariSeldon
Member
Registered: 2012-04-30
Posts: 13

Re: The AMD/ATI Bar & Grill

I will not come back to xorg 1.12 just for amd blobware.
Thanks for your hard work Vi0l0.

I Think i'll wait to see how is evolving the bumblebee amd project to use the open driver instead.
Just for reference :
https://github.com/Bumblebee-Project/Bu … /issues/52

Last edited by HariSeldon (2012-11-02 15:59:59)

Offline

#4533 2012-11-02 17:11:19

siavashserver
Member
From: Tehran, Iran
Registered: 2011-02-11
Posts: 73

Re: The AMD/ATI Bar & Grill

PLANTROON wrote:

I have a question about hd234k graphics cards. Will they ever get support for Xorg 1.13 and Windows 8?

Support should be added by AMD in a century or two, but this could be sooner. However I don't care about it, never made any noticeable difference for me. And about Windows 8, there is an official driver which only supports WDDM 1.1 here : AMD Catalyst™ Driver for the Radeon™ HD 4000, HD 3000 and HD 2000 Series on Windows® 8

Offline

#4534 2012-11-02 17:17:55

PLANTROON
Member
From: Slovakia
Registered: 2012-08-08
Posts: 61

Re: The AMD/ATI Bar & Grill

siavashserver wrote:
PLANTROON wrote:

I have a question about hd234k graphics cards. Will they ever get support for Xorg 1.13 and Windows 8?

Support should be added by AMD in a century or two, but this could be sooner. However I don't care about it, never made any noticeable difference for me. And about Windows 8, there is an official driver which only supports WDDM 1.1 here : AMD Catalyst™ Driver for the Radeon™ HD 4000, HD 3000 and HD 2000 Series on Windows® 8

Thank you for the link, it was really helpful.Of course I am not gonna use Windows 8 on this machine for a long time but I just wanted to know if I can play Battlefield 3 with the soldiers appearing properly on Windows 8 Enterprise Trial big_smile (I ran into the dark and they appeared behind me... really, they got there from nowhere...strange haha... )

Offline

#4535 2012-11-03 07:39:04

Anon11
Member
Registered: 2012-05-20
Posts: 33

Re: The AMD/ATI Bar & Grill

Hello,

On catalyst 12.9 / 12.11 i get segmentation error on every shutdown / restart.
12.8 works fine and i m using that now.

Seg fault happens when running script /etc/rc.shutdown line 127 when it runs
  poweroff -d -f -h -i / reboot -d -f -i
Nothing in logs as drives are mounted readonly by now.

Trace was like this
    pci_msi_shutdown
    device_shutdown
    kernel_restart_prepare
    kernel_restart
    sys_reboot
    mntput_no_expire
    mntput
    fput
    filip_close
    system_call_fastpath

and last error was
INIT : No more process left in this runlevel.

Steps :
1 After catalyst upgrade and deleting /etc/ati/amdpscdb , initially , there is no issue.
2 Then i go to catalyst center and select integrated card and reboot ( i have HP laptop with 6755g2 ). Still no issue.
3 Now even if i restart few times it works ok.
   BUT after a day or two , without any change in CCC , i start getting Segmentation error ( on reboot /shutdown).
4 Also, after catalyst upgrade if i delete amdpscdb , reboot , set integrated card AND also set vsync to ON ,
    i get seg fault on reboot immediately.


Problem goes away if i delete amdpscdb in init 1 (and then select card and reboot), but then reappears after some time like in step 3.
IF i copy amdpscdb from step 2 which was working , i still get seg fault.
So deleting amdpscdb does something else too which causes the problem to go away for a while.

Anyone has faced such an issue ? any idea?

Last edited by Anon11 (2012-11-03 07:41:51)

Offline

#4536 2012-11-04 01:23:39

PhilipWitte
Member
Registered: 2012-02-03
Posts: 45

Re: The AMD/ATI Bar & Grill

Has anyone successfully gotten GDM 3.6.1 to start with a system using Xorg 1.11 (or below) and Catalyst 12.6 (or below) from the unofficial xorg111/hd234k repos?

I ask because the /var/log/gdm/:0.log output is identical to the output from running the command "$ X -seat" and is as follows:

Unrecognized option: -seat
use: X [:<display>] [option]
-a #                   default pointer acceleration (factor)
-ac                    disable access control restrictions
-audit int             set audit trail level
-auth file             select authorization file
-br                    create root window with black background
+bs                    enable any backing store support
-bs                    disable any backing store support
-c                     turns off key-click
c #                    key-click volume (0-100)
-cc int                default color visual class
-nocursor              disable the cursor
-core                  generate core dump on fatal error
-dpi int               screen resolution in dots per inch
-dpms                  disables VESA DPMS monitor control
-deferglyphs [none|all|16] defer loading of [no|all|16-bit] glyphs
-f #                   bell base (0-100)
-fc string             cursor font
-fn string             default font name
-fp string             default font path
-help                  prints message with these options
-I                     ignore all remaining arguments
-ld int                limit data space to N Kb
-lf int                limit number of open files to N
-ls int                limit stack space to N Kb
-nolock                disable the locking mechanism
-nolisten string       don't listen on protocol
-noreset               don't reset after last client exists
-background [none]     create root window with no background
-reset                 reset after last client exists
-p #                   screen-saver pattern duration (minutes)
-pn                    accept failure to listen on all ports
-nopn                  reject failure to listen on all ports
-r                     turns off auto-repeat
r                      turns on auto-repeat 
-render [default|mono|gray|color] set render color alloc policy
-retro                 start with classic stipple and cursor
-s #                   screen-saver timeout (minutes)
-t #                   default pointer threshold (pixels/t)
-terminate             terminate at server reset
-to #                  connection time out
-tst                   disable testing extensions
ttyxx                  server started from init on /dev/ttyxx
v                      video blanking for screen-saver
-v                     screen-saver without video blanking
-wm                    WhenMapped default backing-store
-wr                    create root window with white background
-maxbigreqsize         set maximal bigrequest size 
+xinerama              Enable XINERAMA extension
-xinerama              Disable XINERAMA extension
-dumbSched             Disable smart scheduling, enable old behavior
-schedInterval int     Set scheduler interval in msec
-sigstop               Enable SIGSTOP based startup
+extension name        Enable extension
-extension name        Disable extension
-query host-name       contact named host for XDMCP
-broadcast             broadcast for XDMCP
-multicast [addr [hops]] IPv6 multicast for XDMCP
-indirect host-name    contact named host for indirect XDMCP
-port port-num         UDP port number to send messages to
-from local-address    specify the local address to connect from
-once                  Terminate server after one session
-class display-class   specify display class to send in manage
-cookie xdm-auth-bits  specify the magic cookie for XDMCP
-displayID display-id  manufacturer display ID for request
[+-]accessx [ timeout [ timeout_mask [ feedback [ options_mask] ] ] ]
                       enable/disable accessx key sequences
-ardelay               set XKB autorepeat delay
-arinterval            set XKB autorepeat interval


Device Dependent Usage
-config file           specify a configuration file, relative to the
                       xorg.conf search path, only root can use absolute
-configdir dir         specify a configuration directory, relative to the
                       xorg.conf.d search path, only root can use absolute
-verbose [n]           verbose startup messages
-logverbose [n]        verbose log messages
-quiet                 minimal startup messages
-pixmap24              use 24bpp pixmaps for depth 24
-pixmap32              use 32bpp pixmaps for depth 24
-fbbpp n               set bpp for the framebuffer. Default: 8
-depth n               set colour depth. Default: 8
-gamma f               set gamma value (0.1 < f < 10.0) Default: 1.0
-rgamma f              set gamma value for red phase
-ggamma f              set gamma value for green phase
-bgamma f              set gamma value for blue phase
-weight nnn            set RGB weighting at 16 bpp.  Default: 565
-layout name           specify the ServerLayout section name
-screen name           specify the Screen section name
-keyboard name         specify the core keyboard InputDevice name
-pointer name          specify the core pointer InputDevice name
-nosilk                disable Silken Mouse
-flipPixels            swap default black/white Pixel values
-disableVidMode        disable mode adjustments with xvidtune
-allowNonLocalXvidtune allow xvidtune to be run as a non-local client
-allowMouseOpenFail    start server even if the mouse can't be initialized
-ignoreABI             make module ABI mismatches non-fatal
-isolateDevice bus_id  restrict device resets to bus_id (PCI only)
-version               show the server version
-showDefaultModulePath show the server default module path
-showDefaultLibPath    show the server default library path
vtXX                   use the specified VT number
-keeptty               don't detach controlling tty (for debugging only)
-novtswitch            don't immediately switch to new VT
-sharevts              share VTs with another X server


Fatal server error:
Unrecognized option: -seat


Please consult the The X.Org Foundation support 
	 at [url]http://wiki.x.org[/url]
 for help.

Basically, I did a clean install of Arch Linux (latest ArchISO) on my Ati Radeon HD 4870 machine, and installed Gnome-Shell 3.6. I've been running Gnome-Shell 3.4 with the xog111/hd234k packages for some time before without error, but decided to redo everything (for grub2/systemd). Before I wiped my system though, I did upgrade to Gnome-Shell 3.6, and GDM did start, however it failed before the login-prompt was shown giving an "Unknown Error" message (or something to that effect). Now, however, GDM doesn't start at all, sighting Xorg errors as the cause. I can still get into Gnome-Shell with "startx", and everything works great once I'm in.

I'm wondering if Xorg above version 1.11 supports a "-seat" option, and GDM trying to start X that way, and thus failing.... though I'm confused as to why it began to run on my previous system, and why it doesn't at all on my system now.

Can anyone confirm this?

I made a post two days ago with additional details/logs about my situation: https://bbs.archlinux.org/viewtopic.php?id=151998


EDIT - I found evidence:

http://git.gnome.org/browse/gdm/tree/da … ver.c#n383

Well it does look like, with systemd, GDM is trying to pass "-seat" when starting X... I'll being hacking away at this to see if I can't come up with a work around for my system, but I'd still appreciate a confirmation on weather others have run into this. I find it hard to believe I'm the first to experience GDM failing due to an outdated Xorg server... is there some other Catalyst/Xorg options I'm unaware of? Last I checked, for HD 4xxx cards and below, Xorg 1.11 and Catalyst 12.6 where the latest server/drivers you can use.


EDIT - I've reported upstream:

https://bugzilla.gnome.org/show_bug.cgi?id=687542

Last edited by PhilipWitte (2012-11-04 02:42:13)

Offline

#4537 2012-11-04 09:53:58

soundman
Member
From: Istanbul, Turkey
Registered: 2010-06-05
Posts: 17

Re: The AMD/ATI Bar & Grill

@PhilipWitte,

why do you use Xorg 1.11?

I have a HD4890 card and running Gnome-Shell 3.6.1 with the xorg112/hd234k packages.

Wiki says: "The Legacy driver does not support Xorg 1.13 for now."

Offline

#4538 2012-11-04 16:08:11

PhilipWitte
Member
Registered: 2012-02-03
Posts: 45

Re: The AMD/ATI Bar & Grill

soundman wrote:

@PhilipWitte,

why do you use Xorg 1.11?

I have a HD4890 card and running Gnome-Shell 3.6.1 with the xorg112/hd234k packages.

Wiki says: "The Legacy driver does not support Xorg 1.13 for now."

Okay, awesome, thanks for the tip. Like I said, I was under the impression Xorg 1.11 was the newest version of X you could use with Catalyst 12.6 (i know, i know... should have re-read the wiki). I'll try upgrading and see if that fixes the problem. If so I'll modify my GDM bug-report.


EDIT - Confirmed, upgrading to Xorg 1.12 fixed the problem, thanks! smile

Last edited by PhilipWitte (2012-11-04 19:58:33)

Offline

#4539 2012-11-05 09:19:39

akspecs
Member
Registered: 2012-02-11
Posts: 169

Re: The AMD/ATI Bar & Grill

So, I'm curious what desktop environments people use with their ATI cards.  I've been using Gnome and it looks pretty but it's not practical at all by any means.  In previous versions of Gnome and Catalyst random freezing would occur and if I typed in my password too quickly into gdm the desktop environment would freeze up.

Yes, I will admit newer versions of Gnome and Catalyst seem to play nicer with one another as time progresses.  Regardless, I haven't enjoyed it much.  I want to combine work and play effectively.

So it short here's what I want to know:

Who effectively plays games with the radeon cards?  What card?

Can you alt+tab out of the game or do you run it in windowed mode?

What desktop environment do you use?

I have a HD 6870 card, and I can run certain games pretty okay via wine.  I run them in a windowed mode because my entire system would freeze up if I had ever tried to alt tab out of them in gnome.  I've never tried another DE on this system so I don't know but I am willing to make a transition if people have had good results.  I can't tell if this is a ATI thing or a Gnome thing.

Offline

#4540 2012-11-05 18:21:15

Roken
Member
From: UK
Registered: 2012-01-16
Posts: 649

Re: The AMD/ATI Bar & Grill

I'm using a HD6670 (was a 4670 until last week) on xfce without issue. I only really play TrackMania, but it ran fine with both cards. There is an issue alt-tabbing out of  FS here, too, though it doesn't cause a freeze. It lookslike a freeze, but I think it's simply that the card is holding the last frame in teh buffer indefinately. Switching to a VT (ctrl-alt-F1) and back again gets my desktop back with the game windowed, though it seems to have forgotten what it was supposed to be doing by this point and just presents an empty black window. Nevertheless, it's an easy recovery from a misbehaving game if I need to.


[img=Speedtest]http://www.speedtest.net/my-result/5145583518[/img]

Nvidia GTX 670 2Gb, AMD Phenom II X4 (965BE) @ 3.6 Ghz (Overclocked) 8GB RAM
Linux user #545703

Offline

#4541 2012-11-05 21:42:10

akspecs
Member
Registered: 2012-02-11
Posts: 169

Re: The AMD/ATI Bar & Grill

You see, when I switch to a console - or try to - it gives me the impression of freezing and whatever was going on X if left on the screen.  This has been my experience with Gnome and Radeon ever since I had it.  I'm just about done lol.

I've never had problems with an old laptop that runs XFCE with Nvidia graphics.  I've always been able to switch to the console, and that system has actually NEVER frozen up.  Not once.  It's an old Dell Latitude D630 with 3GB 667Mhz ram, 2.5Ghz Core2Duo processor and Nvidia 135m graphics.  I don't play anything intense on it, but even the low level games that I play fine on that system (and alt tab out of as expected) work fine while even though I get a higher avg frame rate with the catalyst graphics, I will occasionally freeze, and even switching x consoles does not work.

I'm just about done with gnome and I'm about to switch to XFCE for all of my systems.  I'd try MATE but I've actually liked XFCE better.

Offline

#4542 2012-11-06 05:29:21

New1
Member
Registered: 2012-10-29
Posts: 1

Re: The AMD/ATI Bar & Grill

Hello,
I have a Dell-Vostro 3450 and it has 2 graphic cards integrated.
1. Intel 3000
2. Ati Radon HD 6600M 

I can't install the ATI drivers.
I tried to install the xf86-video-ati and also the lib32-ati-dri, but still no success.   

I'm on gnome (3.6.1) GUI, 64 bit.
The driver status is: Unknown.

How can I install the ATI driver, or how can I know which Driver is installed right now on the system?
Is there an application for that?  (like everest on windows for example)

Thank you.

Offline

#4543 2012-11-06 06:00:16

zoqaeski
Member
From: /earth/australia/.
Registered: 2009-09-30
Posts: 124

Re: The AMD/ATI Bar & Grill

Anon11 wrote:

Hello,

On catalyst 12.9 / 12.11 i get segmentation error on every shutdown / restart.
12.8 works fine and i m using that now.

Seg fault happens when running script /etc/rc.shutdown line 127 when it runs
  poweroff -d -f -h -i / reboot -d -f -i
Nothing in logs as drives are mounted readonly by now.

Trace was like this
    pci_msi_shutdown
    device_shutdown
    kernel_restart_prepare
    kernel_restart
    sys_reboot
    mntput_no_expire
    mntput
    fput
    filip_close
    system_call_fastpath

and last error was
INIT : No more process left in this runlevel.

Steps :
1 After catalyst upgrade and deleting /etc/ati/amdpscdb , initially , there is no issue.
2 Then i go to catalyst center and select integrated card and reboot ( i have HP laptop with 6755g2 ). Still no issue.
3 Now even if i restart few times it works ok.
   BUT after a day or two , without any change in CCC , i start getting Segmentation error ( on reboot /shutdown).
4 Also, after catalyst upgrade if i delete amdpscdb , reboot , set integrated card AND also set vsync to ON ,
    i get seg fault on reboot immediately.


Problem goes away if i delete amdpscdb in init 1 (and then select card and reboot), but then reappears after some time like in step 3.
IF i copy amdpscdb from step 2 which was working , i still get seg fault.
So deleting amdpscdb does something else too which causes the problem to go away for a while.

Anyone has faced such an issue ? any idea?

YES! This is exactly what happens to me. Though I must admit I hadn't tried removing `/etc/ati/amdpscdb`, I just get consistent kernel panics on shutdown with any driver >12.8

Offline

#4544 2012-11-06 15:04:52

Anon11
Member
Registered: 2012-05-20
Posts: 33

Re: The AMD/ATI Bar & Grill

Well i updated catalyst, xorg and  kernel to latest and got seg fault now after couple of days.
This time i didn't immediately get any error on changing vsync so was hoping it will work ...

Is  http://ati.cchtml.com/ the right place to report this ? Ill try to add a bug there tomorrow.

Offline

#4545 2012-11-06 19:54:25

Mulokun
Member
Registered: 2012-11-06
Posts: 8

Re: The AMD/ATI Bar & Grill

Hi. I have a problem with catalyst on my laptop, when I run X I have a black screen.
If you want more details, here

I have try many things but nothing work.
Thanks
(Sorry for my english, I'm french wink )

Last edited by Mulokun (2012-11-06 19:54:52)

Offline

#4546 2012-11-07 01:10:19

Squiddles
Member
Registered: 2011-05-31
Posts: 73

Re: The AMD/ATI Bar & Grill

I ran into an issue yesterday that I haven't run into since I ran Ubuntu early in 2011. The screen does THIS on very rare occasion. I was just browsing the web when this happened.

I'm up to date with everything on the system, except xorg-server. I'm on 1.11.4-2. I recall there was some issue with using 1.12 so I stayed on 1.11 using the xorg111 repo. I never kept up on that so I left it. I do notice that 1.14 is compatible now though. Any reason to move to 1.14? I do have to say that I feel my current installed xorg-server is unrelated to the corrupted graphics since it's happened before.

Offline

#4547 2012-11-07 07:53:35

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 671

Re: The AMD/ATI Bar & Grill

I recently switched one of my systems to systemd, so I replaced the good old catalyst-daemon with catalyst-hook. I noticed that it builds the fglrx module for both the standard and the fallback kernel images. Is this really necessary? wouldn't it be sufficient to add the fglrx mkinitcpio hook inly to the standard image building?

BTW, systemd is a mess on Arch. Since the switch to it, udisks refuses to mount ntfs partitions as unprivileged user and laptop-mode-tools is not correctly initialized at startup so I have to manually restart it after boot or after recovery from suspension. Everything was fine before with sysvinit... I'll stick with it on my last system until something gets seriously broken...

Offline

#4548 2012-11-07 09:30:24

DeepThought
Member
Registered: 2010-12-15
Posts: 8

Re: The AMD/ATI Bar & Grill

I'll just share some of my experiences/findings/workarounds, since I believe that they might be able to help someone out:

- First of all, when I changed from legacy GRUB to GRUB2, I forgot to make sure nomodeset was added. This caused some funky problems when switching between X and console, as well as when I was trying to shut down my computer.

- I play a lot of games, both native and using Wine, and from my experience Alt-Tab works just fine under certain circumstances. If I don't use a compositor (xcompmgr in my case) there is no problem. However, whenever a compositor is active the focus switches from the game to whatever window I chose, but I can't see it since the last frame from the game will be on top (or maybe if the game keeps updating frames on top, I can't remember at the moment). I think Gnome 3 is using a compositor by default, is it not? Hence, it's bound to give some problems. I should point out, thou, that Alt-Tab while gaming and using a compositor actually DID work in one of the later releases of the Catalyst driver (maybe if it was 12.8 or 12.9) but was broken again.

- If I try to watch fullscreen flash videos on Youtube/Vimeo/whatever, it doesn't work unless I use a compositor.


Not sure if any of the above might be of interest to anyone, but I hope it will help someone to troubleshoot. I should probably say that I'm using Slim+Openbox.

Offline

#4549 2012-11-07 16:20:51

joanmanel
Member
Registered: 2012-11-06
Posts: 98

Re: The AMD/ATI Bar & Grill

I just installed catalyst from vi0l0s repo. Pxp. The installation was ok, the aticonfig was Ok. When i tried to run startx, it said no intel driver. So I installed the intel drivers, now it is complaining for some other reasons:

this is my log: http://ix.io/3kO

Offline

#4550 2012-11-07 21:06:41

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,299
Website

Re: The AMD/ATI Bar & Grill

I'm really busy, but here's some kind of a draft about powerXpress, could be usefull:
https://wiki.archlinux.org/index.php/AM … ss_support

Offline

Board footer

Powered by FluxBB