You are not logged in.

#1 2012-11-03 06:47:51

mfaridi
Member
Registered: 2010-12-15
Posts: 191

after run pacman -syu and reboot Gnome 3 can not start

yesterday I run this command

 pacman -syu 

and my system start download over 500 MB and I go to shop , after I come back , I see everything downloaded and I shutdown my system and go to my friend home . after come back I turn on my system and I see my system start , but Gnome3 can not start and my system go to command line and can not go to graphical mode and I can not enter my pass and username . before this I use GDM for login . last Gnome was Gnome3.4 but new Gnome is 3.6 , I think GDM has big problem and can not start , how I can solve this problem ?

Offline

#2 2012-11-03 08:16:13

Fluxis
Member
Registered: 2012-04-12
Posts: 5

Re: after run pacman -syu and reboot Gnome 3 can not start

I am also having the same problem. After upgrading I get a general gdm message saying an error has occurred (Black screen with a message and sad face in the center). I have searched through the log files and not found any specific error message. I downgraded a few packages I thought might be causing the problem gdm, gnome-shell, gnome-desktop, gsettings and a few other gnome related packages that had changed from version 3.4 to 3.6 but still nothing.

This morning I went through the upgraded packages a little more systematically and downgraded some more. I can now log into my system and autostart programs start but there is no shell. Luckily one of them is chromium where I'm typing this message now, as right now this is my only computer sad

The packages I downgraded this morning were clutter, clutter-gst, clutter-gtk, glib2, at-spi2-core, atk, dconf, at-spi2-atk, cairo, pango, polkit, colord, libtasn1, gnutils, and glib-networking.

Offline

#3 2012-11-03 08:20:43

googol-1
Member
Registered: 2012-10-21
Posts: 22

Re: after run pacman -syu and reboot Gnome 3 can not start

Offline

#4 2012-11-03 08:22:14

Fluxis
Member
Registered: 2012-04-12
Posts: 5

Re: after run pacman -syu and reboot Gnome 3 can not start

Offline

#5 2012-11-03 22:50:58

mfaridi
Member
Registered: 2010-12-15
Posts: 191

Re: after run pacman -syu and reboot Gnome 3 can not start

thanks all guys after read these posts :
https://bbs.archlinux.org/viewtopic.php?id=151776
https://bbs.archlinux.org/viewtopic.php?pid=1185583

https://www.archlinux.org/news/consolek … by-logind/
https://wiki.archlinux.org/index.php/Systemd

and put these lines

init=/usr/lib/systemd/systemd

in these files

 /boot/grub/menu.lst

and reboot 
my problem solve and GDM start
after reboot boot process is change and OK option move to left of monitor and I do not see red line when system start boot
right now my

 /boot/grub/menu.lst

is this

# Config file for GRUB - The GNU GRand Unified Bootloader
# /boot/grub/menu.lst

# DEVICE NAME CONVERSIONS 
#
#  Linux           Grub
# -------------------------
#  /dev/fd0        (fd0)
#  /dev/sda        (hd0)
#  /dev/sdb2       (hd1,1)
#  /dev/sda3       (hd0,2)
#

#  FRAMEBUFFER RESOLUTION SETTINGS
#     +-------------------------------------------------+
#          | 640x480    800x600    1024x768   1280x1024
#      ----+--------------------------------------------
#      256 | 0x301=769  0x303=771  0x305=773   0x307=775
#      32K | 0x310=784  0x313=787  0x316=790   0x319=793
#      64K | 0x311=785  0x314=788  0x317=791   0x31A=794
#      16M | 0x312=786  0x315=789  0x318=792   0x31B=795
#     +-------------------------------------------------+
#  for more details and different resolutions see
#  http://wiki.archlinux.org/index.php/GRUB#Framebuffer_Resolution 

# general configuration:
timeout   5
default   0
color light-blue/black light-cyan/blue

# boot sections follow
# each is implicitly numbered from 0 in the order of appearance below
#
# TIP: If you want a 1024x768 framebuffer, add "vga=773" to your kernel line.
#
#-*

# (0) Arch Linux
title  Arch Linux
root   (hd0,0)
kernel /vmlinuz26 root=/dev/disk/by-uuid/1b861675-ae37-4f04-acdd-42da522772ae init=/usr/lib/systemd/systemd ro
initrd /kernel26.img

# (1) Arch Linux
title  Arch Linux Fallback
root   (hd0,0)
kernel /vmlinuz26 root=/dev/disk/by-uuid/1b861675-ae37-4f04-acdd-42da522772ae  init=/usr/lib/systemd/systemd ro
initrd /kernel26-fallback.img

# (2) Windows
#title Windows
#rootnoverify (hd0,0)
#makeactive
#chainloader +1

Do I need put or change some line in other config files for better performance ? is these new line enough for systemd work better ?

Offline

#6 2012-11-04 06:22:00

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: after run pacman -syu and reboot Gnome 3 can not start

If you install systemd-sysvcompat, the "init=/usr/lib/systemd/systemd" won't be necessary anymore to boot with systemd.

Offline

#7 2012-11-04 21:39:52

mfaridi
Member
Registered: 2010-12-15
Posts: 191

Re: after run pacman -syu and reboot Gnome 3 can not start

Snowman wrote:

If you install systemd-sysvcompat, the "init=/usr/lib/systemd/systemd" won't be necessary anymore to boot with systemd.

thanks
which one is important systemde or  systemd-sysvcompat ?
after run systemd my system boot faster

Offline

#8 2012-11-05 00:01:46

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: after run pacman -syu and reboot Gnome 3 can not start

mfaridi wrote:
Snowman wrote:

If you install systemd-sysvcompat, the "init=/usr/lib/systemd/systemd" won't be necessary anymore to boot with systemd.

thanks
which one is important systemde or  systemd-sysvcompat ?
after run systemd my system boot faster

I'm not sure I understand your question. Obviously, you need to have systemd installed. The systemd-sysvcompat package is part of the base group  so it is recommended to have it installed. It is just a bunch of symlinks to make your life easier using systemd.

$ pacman -Ql systemd-sysvcompat |grep sbin
systemd-sysvcompat /sbin/
systemd-sysvcompat /sbin/halt
systemd-sysvcompat /sbin/init
systemd-sysvcompat /sbin/poweroff
systemd-sysvcompat /sbin/reboot
systemd-sysvcompat /sbin/runlevel
systemd-sysvcompat /sbin/shutdown
systemd-sysvcompat /sbin/telinit

For example, the  /sbin/init is a symlink to /usr/lib/systemd/systemd so specifying a init= on the kernel command line is not necessary. It will boot with systemd by default.

Offline

Board footer

Powered by FluxBB