You are not logged in.

#1 2012-11-01 09:12:19

mibadt
Member
Registered: 2009-09-25
Posts: 377

Arch systemctl enable errors

Hi,
I'm on a fully updated Arch_x86-64/KDE initially installed without systemd.
I've have several problems which I suspect to be related to a partial transfer to systemd.

1. During the last full system update, I've got the following error:

(gconftool-2:2709): GConf-WARNING **: Client failed to connect to the D-BUS daemon:

2. What's more,  suddenly Arch won't auto-mount anymore and external HD which it did flawlessly before.

3. Although enabled (see below) , systemd journal doesn't seem to work.

4. I lost (power) susprend and hibernate options from KDE's menu

5. When trying to enable several daemons (per systemd's wiki recommendations), i get the following error:

systemctl enable syslog-ng
Operation failed: Invalid argument
[root@Miki_Arch etc]# systemctl enable dbus
Operation failed: Invalid argument
[root@Miki_Arch etc]# systemctl enable cupsd
Operation failed: Invalid argument

I have prepared the new configurations files and enabled the journal- see terminal output:

# ls /etc
ConsoleKit            cron.daily    ggz.modules       iproute2        lvm              nsswitch.conf  printcap           rsyncd.conf        sudoers.d
ODBCDataSources       cron.deny     gimp              iptables        machine-id       ntp.conf       profile            sane.d             sysctl.conf
UPower                cron.hourly   group             irman.conf      mail.rc          odbc.ini       profile.d          securetty          sysctl.d
X11                   cron.monthly  group-            issue           makepkg.conf     odbcinst.ini   protocols          security           syslog-ng
adjtime               cron.weekly   group.bak         java-7-openjdk  man_db.conf      openal         protocols.pacnew   sensors3.conf      systemd
adobe                 crypttab      group.pacnew      kde             mdadm.conf       openldap       pulse              services           tmpfiles.d
anacrontab            cups          grub.d            krb5.conf       mime.types       os-release     rc.conf            services.pacnew    trusted-key.key
arch-release          cupshelpers   gshadow           ksysguarddrc    mke2fs.conf      pacman.conf    rc.conf.pacnew     shadow             udev
asound.conf           dbus-1        gshadow-          ld.so.cache     mkinitcpio.conf  pacman.d       rc.d               shadow-            updatedb.conf
at-spi2               default       gshadow.bak       ld.so.conf      mkinitcpio.d     pam.d          rc.local           shadow.bak         vconsole.conf
avahi                 depmod.d      gshadow.pacnew    ld.so.conf.d    modprobe.d       pango          rc.local.shutdown  shadow.pacnew      vdpau_wrapper.cfg
bash.bash_logout      dhcpcd.conf   gssapi_mech.conf  libao.conf      modules-load.d   partimaged     rc.multi           shells             wgetrc
bash.bashrc           drirc         gtk-2.0           libnl           mono             passwd         rc.shutdown        skel               wpa_supplicant
binfmt.d              environment   gtk-3.0           libreoffice     motd             passwd-        rc.single          slp.conf           xdg
ca-certificates       fonts         healthd.conf      lirc            mplayer          passwd.bak     rc.sysinit         slp.reg            xinetd.d
ca-certificates.conf  fstab         host.conf         locale.conf     mtab             passwd.pacnew  rc_keymaps         slp.spi            xml
chromium              fstab.orig    hostname          locale.gen      mtools.conf      pcmcia         rc_maps.cfg        slsh.rc
clive                 fuse.conf     hosts             localtime       mysql            pkcs11         request-key.conf   speech-dispatcher
colord.conf           gai.conf      hotplug           login.defs      nanorc           pm             request-key.d      ssh
conf.d                gconf         inittab           logrotate.conf  netconfig        polkit-1       resolv.conf        ssl
cron.d                gemrc         inputrc           logrotate.d     nscd.conf        ppp            rpc                sudoers

[root@Miki_Arch etc]# ls /etc/systemd
journald.conf  logind.conf  ntp-units.d  system  system.conf  user  user.conf

[root@Miki_Arch etc]# cat /etc/systemd/journald.conf
#  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.
#
# See journald.conf(5) for details

[Journal]
Storage=auto

#.. rest of lines commented


my rc.conf looks as follws:

# cat /etc/rc.conf
#
# /etc/rc.conf - Main Configuration for Arch Linux
#
# See 'man 5 rc.conf' for more details
#

# LOCALIZATION
# ------------
#HARDWARECLOCK="localtime"
#TIMEZONE="Asia/Jerusalem"
#KEYMAP="us"
CONSOLEFONT=
CONSOLEMAP=
#LOCALE="en_US.utf8"
DAEMON_LOCALE="yes"
USECOLOR="yes"

# HARDWARE
# --------
#MODULES=(microcode)
USEDMRAID="no"
USEBTRFS="no"
USELVM="no"

# NETWORKING
# ----------
#HOSTNAME=Miki_Arch

interface=eth1
address=
netmask=
broadcast=
gateway=

NETWORK_PERSIST="no"

# DAEMONS
# -------
#
DAEMONS=(syslog-ng dbus network lp cupsd hwclock ntpd crond)


Please advise.
Thanks


Best regards,
Michael Badt

Offline

#2 2012-11-01 09:22:39

LyCC
Member
Registered: 2012-09-05
Posts: 88

Re: Arch systemctl enable errors

Hi,

systemctl enable syslog-ng
Operation failed: Invalid argument
[root@Miki_Arch etc]# systemctl enable dbus
Operation failed: Invalid argument
[root@Miki_Arch etc]# systemctl enable cupsd
Operation failed: Invalid argument

it's not dbus, its dbus.service, here is the list of daemons:
https://wiki.archlinux.org/index.php/Daemons_List

Enjoy.

Offline

#3 2012-11-01 10:02:54

mibadt
Member
Registered: 2009-09-25
Posts: 377

Re: Arch systemctl enable errors

Thanks,
although my problems still not solved-see below.
Anybody else?

Thanks

# systemctl enable dbus.service
The unit files have no [Install] section. They are not meant to be enabled using systemctl.
[root@Miki_Arch miki]# cat /etc/rc.conf^C
[root@Miki_Arch miki]# systemctl enable syslog-ng.service
ln -s '/usr/lib/systemd/system/syslog-ng.service' '/etc/systemd/system/syslog.service'
ln -s '/usr/lib/systemd/system/syslog-ng.service' '/etc/systemd/system/multi-user.target.wants/syslog-ng.service'
[root@Miki_Arch miki]# systemctl enable cupsd.service
Operation failed: No such file or directory
[root@Miki_Arch miki]# systemctl enable cups.service
ln -s '/usr/lib/systemd/system/cups.service' '/etc/systemd/system/printer.target.wants/cups.service'
ln -s '/usr/lib/systemd/system/cups.socket' '/etc/systemd/system/sockets.target.wants/cups.socket'
ln -s '/usr/lib/systemd/system/cups.path' '/etc/systemd/system/multi-user.target.wants/cups.path'

Best regards,
Michael Badt

Offline

#4 2012-11-01 10:29:42

adee
Member
From: The Moon
Registered: 2009-11-10
Posts: 107

Re: Arch systemctl enable errors

You shouldn't touch dbus.service. It's automatically taken care by systemd.

Offline

#5 2012-11-02 16:56:58

LyCC
Member
Registered: 2012-09-05
Posts: 88

Re: Arch systemctl enable errors

If you hit systemctl without any param (just as you posted in your first post), then scroll down (press down key) you should see something like this:

dbus.service                                                 loaded active running       D-Bus System Message Bus

Make sure you scrolled all the way down in the list, it looks like you only got till the letter "c".

Last edited by LyCC (2012-11-03 08:25:13)

Offline

#6 2012-11-02 18:56:48

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,079

Re: Arch systemctl enable errors

mibadt, please use [ code ] tags as opposed to [ quote ] tags in your first post.


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#7 2012-11-08 03:41:49

rvc
Member
From: India
Registered: 2012-09-09
Posts: 42
Website

Re: Arch systemctl enable errors

being a newbie for Arch... i too wished i ll migrate to systemd...
after following the wiki HOWTO and the relative posts on the forum, i get the following errors...

[root@arch rvc]# timedatectl set-timezone Asia/Kolkata
Failed to issue method call: Launch helper exited with unknown return code 1

i wish a step by step how to for migrating to systemd whould be helpful. now i cant set the time zone ! (earlier i could atleast manually set the time but not now !)

thanks in advance...


Associated with
VEDGOO.COM
For Wallpapers, Articles, Blogs, Media and much more...
To Browse Arch Specific Wallpapers, feel free to follow this LINK

Offline

#8 2012-11-08 03:46:41

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Arch systemctl enable errors

rvc, have you read the wiki page on systemd?

Offline

#9 2012-11-08 04:44:39

rvc
Member
From: India
Registered: 2012-09-09
Posts: 42
Website

Re: Arch systemctl enable errors

WonderWoofy wrote:

rvc, have you read the wiki page on systemd?

yes.. i did and within my limitations i did follow.
still i am not sure if arch is booting with systemd or otherwise...


Associated with
VEDGOO.COM
For Wallpapers, Articles, Blogs, Media and much more...
To Browse Arch Specific Wallpapers, feel free to follow this LINK

Offline

#10 2012-11-08 04:53:10

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Arch systemctl enable errors

cat /proc/1/comm

Offline

#11 2012-11-08 07:33:02

rvc
Member
From: India
Registered: 2012-09-09
Posts: 42
Website

Re: Arch systemctl enable errors

WonderWoofy wrote:
cat /proc/1/comm

this returned with init.
just a doubt.
i was asked to add the line init=/usr/lib/systemd/systemd to the kernel parameters.

i added this line in the syslinux.cfg (i use syslinux) so the arch part looks like this

LABEL arch
        MENU LABEL Arch Linux
        LINUX ../vmlinuz-linux
        APPEND root=/dev/sda5 ro
        INITRD ../initramfs-linux.img
        init=/usr/lib/systemd/systemd

is the way correct ?


Associated with
VEDGOO.COM
For Wallpapers, Articles, Blogs, Media and much more...
To Browse Arch Specific Wallpapers, feel free to follow this LINK

Offline

#12 2012-11-08 15:26:20

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,422

Re: Arch systemctl enable errors

probably not, try putting it on the APPEND line so it will look like this :

APPEND roo=/dev/sda5 ro init=/usr/lib/systemd/systemd

Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#13 2012-11-08 15:39:38

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Arch systemctl enable errors

The command I had you run (cat /proc/1/comm) is simply dumping the name of pid 1 into your stdout.  So when it retunrs init, it means you are definitely not running systemd.  The Lone_Wolf is right.  You need to append that init= line to the APPEND line in syslinux.cfg.  You could also simply install systemd-sysvcompat, and then /bin/init will be a symlink to /usr/lib/systemd/systemd, and then you won't have to worry about any kernel parameters.

Offline

#14 2012-11-08 17:23:22

rvc
Member
From: India
Registered: 2012-09-09
Posts: 42
Website

Re: Arch systemctl enable errors

Lone_Wolf wrote:

probably not, try putting it on the APPEND line so it will look like this :

APPEND roo=/dev/sda5 ro init=/usr/lib/systemd/systemd

thanks champ... i got it running with systemd !


Associated with
VEDGOO.COM
For Wallpapers, Articles, Blogs, Media and much more...
To Browse Arch Specific Wallpapers, feel free to follow this LINK

Offline

#15 2012-11-08 17:27:35

rvc
Member
From: India
Registered: 2012-09-09
Posts: 42
Website

Re: Arch systemctl enable errors

WonderWoofy wrote:

The command I had you run (cat /proc/1/comm) is simply dumping the name of pid 1 into your stdout.  So when it retunrs init, it means you are definitely not running systemd.  The Lone_Wolf is right.  You need to append that init= line to the APPEND line in syslinux.cfg.  You could also simply install systemd-sysvcompat, and then /bin/init will be a symlink to /usr/lib/systemd/systemd, and then you won't have to worry about any kernel parameters.

got it champ... Arch rocks...
just removed the initscripts... i ll be going for a reboot to check if things are fine ! just another question...
i had the net-profiles start up on boot (work and home profiles) i entered the command systemctl enable netcfg@PROFILENAME.service but somehow it didnt start up... any clue ?


Associated with
VEDGOO.COM
For Wallpapers, Articles, Blogs, Media and much more...
To Browse Arch Specific Wallpapers, feel free to follow this LINK

Offline

#16 2012-11-08 17:44:14

rvc
Member
From: India
Registered: 2012-09-09
Posts: 42
Website

Re: Arch systemctl enable errors

i had edited the syslinux.cfg with the init= and i also installed systemd-sysvcompat.
do i have to remove one of them ?
i can remove the init=/usr/lib/systemd/systemd OR systemd-sysvcompat... which one is preferred ?


Associated with
VEDGOO.COM
For Wallpapers, Articles, Blogs, Media and much more...
To Browse Arch Specific Wallpapers, feel free to follow this LINK

Offline

#17 2012-11-08 18:03:11

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 5,554

Re: Arch systemctl enable errors

systemd-sysvcompat eliminates the need for init=/usr/lib/systemd/systemd, but you don't need to remove it. You can if you want though.


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 Ti // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Online

#18 2012-11-12 18:00:42

rvc
Member
From: India
Registered: 2012-09-09
Posts: 42
Website

Re: Arch systemctl enable errors

WorMzy wrote:

systemd-sysvcompat eliminates the need for init=/usr/lib/systemd/systemd, but you don't need to remove it. You can if you want though.


thank you champ... and sorry for my late reply...
i ve removed the init=..... but just out of curiosity, how will it be if i removed systemd-sysvcompat and added the lines in the syslinux.cfg ? any other dep problems might arise are they both mean to do the same job ?


Associated with
VEDGOO.COM
For Wallpapers, Articles, Blogs, Media and much more...
To Browse Arch Specific Wallpapers, feel free to follow this LINK

Offline

#19 2012-11-12 18:31:36

teateawhy
Member
From: GER
Registered: 2012-03-05
Posts: 1,060
Website

Re: Arch systemctl enable errors

rvc wrote:

just out of curiosity, how will it be if i removed systemd-sysvcompat and added the lines in the syslinux.cfg ? any other dep problems might arise are they both mean to do the same job ?

Do not remove it, if you did install it again. The reason behind it is it provides more files than only the init symlink. Never remove packages from the base group if you are not absolutely sure what you are doing. You can see the package is part of the base group with "pacman -Qi" and you can see what it provides with "pacman -Ql package" .
Also check "pacman -Qg base" , so you will not ask if you can remove one of those packages in the future...

pacman -Ql systemd-sysvcompat
systemd-sysvcompat /sbin/
systemd-sysvcompat /sbin/halt
systemd-sysvcompat /sbin/init
systemd-sysvcompat /sbin/poweroff
systemd-sysvcompat /sbin/reboot
systemd-sysvcompat /sbin/runlevel
systemd-sysvcompat /sbin/shutdown
systemd-sysvcompat /sbin/telinit

Last edited by teateawhy (2012-11-12 18:32:59)

Offline

Board footer

Powered by FluxBB