You are not logged in.

#1 2012-10-20 18:56:41

kjell
Member
From: Norway
Registered: 2012-03-26
Posts: 97

error after latest nvidia update...missing libpangox?

Latest nvidia update  (304.60-1):

$ nvidia-settings

"nvidia-settings: error while loading shared libraries: libpangox-1.0.so.0: cannot open shared object file: No such file or directory"

Closest thing is libpango, libpangoxft....

Offline

#2 2012-10-20 18:58:24

karol
Archivist
Registered: 2009-05-06
Posts: 25,432

Re: error after latest nvidia update...missing libpangox?

Offline

#3 2012-10-20 19:07:23

kjell
Member
From: Norway
Registered: 2012-03-26
Posts: 97

Re: error after latest nvidia update...missing libpangox?

Offline

#4 2012-10-31 19:07:40

codenomad
Member
Registered: 2012-10-31
Posts: 1

Re: error after latest nvidia update...missing libpangox?

Quick fix, try this:

sudo ln -s /usr/lib/libpango-1.0.so.0.3200.1 /usr/lib/libpangox-1.0.so.0

Offline

#5 2012-10-31 19:10:04

Gusar
Member
Registered: 2009-08-25
Posts: 3,472

Re: error after latest nvidia update...missing libpangox?

codenomad wrote:

Quick fix, try this:

*facepalm*. Don't do that. EVER!

The third comment on that bug is the only correct solution, install the package the comment mentions. Well, there's another solution, compile nvidia-settings yourself from source, but the solution in that comment is much simpler.

Last edited by Gusar (2012-10-31 19:12:33)

Offline

#6 2012-10-31 20:44:36

Kilzool
Member
From: Ireland
Registered: 2010-08-04
Posts: 228

Re: error after latest nvidia update...missing libpangox?

I got this error too, and just installed

pangox-compat 0.0.2-1

Offline

#7 2012-11-08 11:34:15

biltong
Member
From: South Africa
Registered: 2011-09-01
Posts: 116

Re: error after latest nvidia update...missing libpangox?

According to the bug report it was fixed, pangox-compat is now an optdepend but I don't get how that makes any sense because nvidia-settings requires that lib to do anything at all. I know nvidia-settings isn't the only thing in nvidia-utils but still, it seems a little counter intuitive to me.

Offline

#8 2012-11-08 12:48:27

Gusar
Member
Registered: 2009-08-25
Posts: 3,472

Re: error after latest nvidia update...missing libpangox?

nvidia-settings also requires gtk to do anything at all, and yet gtk has always been under optdepends. Only this makes sense - nvidia-settings is optional.

Offline

#9 2012-11-08 13:11:55

brebs
Member
Registered: 2007-04-03
Posts: 3,456

Re: error after latest nvidia update...missing libpangox?

I don't know why you can't just *recompile*, and have the dep on "pangox" automatically fix itself:

$ ldd /usr/bin/nvidia-settings | grep pango
	libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0xb6efb000)
	libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0xb6eef000)
	libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0xb6d7a000)

Edit: This is with nvidia 304.64 (also worked with 304.60) and pango 1.32.1

Last edited by brebs (2012-11-08 13:14:36)

Offline

#10 2012-11-08 20:28:11

biltong
Member
From: South Africa
Registered: 2011-09-01
Posts: 116

Re: error after latest nvidia update...missing libpangox?

Gusar wrote:

nvidia-settings also requires gtk to do anything at all, and yet gtk has always been under optdepends. Only this makes sense - nvidia-settings is optional.

That's true, I hadn't thought about that.

Offline

#11 2012-11-17 07:27:03

tdebruyn
Member
Registered: 2010-09-16
Posts: 8

Re: error after latest nvidia update...missing libpangox?

Gusar wrote:

nvidia-settings also requires gtk to do anything at all, and yet gtk has always been under optdepends. Only this makes sense - nvidia-settings is optional.

I don't understand this.  With this logic, when a package is optdepends of any other package, automatically all its dependencies should be optdepends?
For example, "python2" is in the optdepends list of "alsa-lib", does it mean that the 8 packages that "python2" depends should be put in "optdepends", this doesn't make sense.

Tom

Offline

#12 2012-11-17 09:20:20

Gusar
Member
Registered: 2009-08-25
Posts: 3,472

Re: error after latest nvidia update...missing libpangox?

tdebruyn wrote:

I don't understand this.  With this logic, when a package is optdepends of any other package, automatically all its dependencies should be optdepends?

Err, no, how did you get to that conclusion? pangox-compat is *not* a dependency of gtk. That's why both gtk and pangox-compat need to be listed here.

Offline

#13 2012-11-17 09:29:25

brebs
Member
Registered: 2007-04-03
Posts: 3,456

Re: error after latest nvidia update...missing libpangox?

Or recompile nvidia-settings. Here's a snippet of how I do it (in a totally different distro), from nvidia's nvidia-settings sourcecode:

  if module_installed "gtk+-2" ; then
    # Build nvidia-settings from source
    cd nvidia-settings-$VERSION &&

    # xf86vmode.h has been removed in xf86vidmodeproto 2.3
    if [[ ! -e /usr/include/X11/extensions/xf86vmode.h ]] ; then
      sed -i -e "s:#include <X11/extensions/xf86vmode.h>:#include <X11/extensions/xf86vmproto.h>:" src/libXNVCtrlAttributes/NvCtrlAttributes{,VidMode,Glx}.c
    fi &&

    make clean &&
    make -C src/libXNVCtrl &&
    make || exit 1

module_installed is distro-specific - of course, it's checking whether gtk+-2 is available, FYI.

Edit: Corrected sourcecode file

Last edited by brebs (2012-11-17 23:32:30)

Offline

#14 2014-05-16 12:02:58

beta
Member
Registered: 2014-05-16
Posts: 1

Re: error after latest nvidia update...missing libpangox?

http://www.wedaa.com/eric/software/CHAN … ra.core.19

Last edited by beta (2014-05-16 12:04:03)

Offline

#15 2014-05-16 13:00:06

fsckd
Forum Moderator
Registered: 2009-06-15
Posts: 3,575

Re: error after latest nvidia update...missing libpangox?

Welcome to the forums beta. Linking to someone's Fedora install notes without any explanation is not particularly helpful. Furthermore, if you read the thread you'll see people already mention pangox-compat as a solution.

Please take the time to read our forum rules, for this case Forum Etquette: Old Threads / Necro-Bumping. Closing.


aur S & M :: forum rules :: Community Ethos
Resources for Women, POC, LGBT*, and allies

Offline

Board footer

Powered by FluxBB