You are not logged in.

#1 2002-12-29 09:30:31

rasat
Forum Fellow
From: Finland, working in Romania
Registered: 2002-12-27
Posts: 2,176
Website

Apache -->timeout

Hi,

Apache server is running, syntax is ok,  but I am getting the following error:

An error occured while loading http://localhost/:
Timeout on server
Connection was to localhost at port 80

Offline

#2 2002-12-29 11:34:39

jlvsimoes
Member
From: portugal
Registered: 2002-12-23
Posts: 392
Website

Re: Apache -->timeout

you did httpd ?
try http://127.0.0.1
firewall ?
in /etc/hosts are you realy localhost ?!


-----BEGIN GEEK CODE BLOCK-----
Version: 3.1
GU/ d- s: a- C L U P+ L+++ E--- W+
N 0+ K- W-- !O !M V-- PS+ PE- V++ PGP T 5 Z+ R* TV+ B+
DI-- D- G-- e-- h! r++ z+ z*
------END GEEK CODE BLOCK------

Offline

#3 2002-12-30 03:22:10

rasat
Forum Fellow
From: Finland, working in Romania
Registered: 2002-12-27
Posts: 2,176
Website

Re: Apache -->timeout

I am not getting it to work. Here is my major configs in httpd.conf
ServerType standalone
ServerRoot "/usr"
LockFile /var/run/httpd.lock
PidFile /var/run/httpd.pid
ScoreBoardFile /var/run/httpd.scoreboard

Timeout 300
KeepAlive On
MaxKeepAliveRequests 100
KeepAliveTimeout 15

MinSpareServers 5
MaxSpareServers 10
StartServers 5
MaxClients 150
MaxRequestsPerChild 0

User nobody
Group nobody

ServerAdmin root@localhost
ServerName localhost
DocumentRoot "/home/httpd/html"
On my RedHat machine I have similar config (different folders) and it works fine.

Offline

#4 2002-12-30 10:10:07

Arielext
Member
From: Amersfoort, the Netherlands
Registered: 2002-08-12
Posts: 362
Website

Re: Apache -->timeout

does "nobody" has rights to access /home/httpd/html ?
Make sure that /home/httpd/html (the directory) has all the executable flags set. and that all files/folders beneath /home/httpd/html can be read by all users


apt-get install arch

Offline

#5 2002-12-30 15:57:05

rasat
Forum Fellow
From: Finland, working in Romania
Registered: 2002-12-27
Posts: 2,176
Website

Re: Apache -->timeout

Arielext wrote:

does "nobody" has rights to access /home/httpd/html ?
Make sure that /home/httpd/html (the directory) has all the executable flags set. and that all files/folders beneath /home/httpd/html can be read by all users

I tried what you suggested but doesn't work. What apache version do you use? Would it be a problem with apache-1.3.27-3? What I do, I will install another tar ball.

Offline

#6 2002-12-30 17:05:14

Arielext
Member
From: Amersfoort, the Netherlands
Registered: 2002-08-12
Posts: 362
Website

Re: Apache -->timeout

I'm using the apache in [current].
Only difference is that I've used my real IP and not the loopback.


apt-get install arch

Offline

#7 2002-12-30 20:11:00

rasat
Forum Fellow
From: Finland, working in Romania
Registered: 2002-12-27
Posts: 2,176
Website

Re: Apache -->timeout

I found the problem. It was in my /etc/rc.conf file.

These three lines were tagged. I simply untag them:
# lo="lo 127.0.0.1"
# eth0="eth0 192.168.0.2 netmask 255.255.255.0 broadcast 192.168.0.255"
# INTERFACES=(lo eth0)

I tagged because I am not using them when running my ADSL (with router). I have add two lines in /etc/rc.local file:
cardmgr -f
dhcpcd eth0

How do I config rc.conf instead of using rc.local (I am new ADSL user)?

Offline

#8 2002-12-30 21:01:29

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: Apache -->timeout

i belive it tells you right in the file how to set it for dhcp. (the rc.conf file that is)


AKA uknowme

I am not your friend

Offline

#9 2002-12-31 13:08:14

Arielext
Member
From: Amersfoort, the Netherlands
Registered: 2002-08-12
Posts: 362
Website

Re: Apache -->timeout

rasat wrote:

# lo="lo 127.0.0.1"
# eth0="eth0 192.168.0.2 netmask 255.255.255.0 broadcast 192.168.0.255"
# INTERFACES=(lo eth0)

How do I config rc.conf instead of using rc.local (I am new ADSL user)?

in rc.conf:

eth0="dhcp"

be sure to start everything you need to get your ADSL running before starting the netwrok deamon. I place my stuff in rc.sysinit


apt-get install arch

Offline

#10 2003-02-06 12:08:36

rasat
Forum Fellow
From: Finland, working in Romania
Registered: 2002-12-27
Posts: 2,176
Website

Re: Apache -->timeout

rasat wrote:

How do I config rc.conf instead of using rc.local (ADSL with router)?

For the records, my final setting looks like this:
/etc/rc.conf

 lo="lo 127.0.0.1"
eth0="dhcp"
INTERFACES=(lo)

/etc/rc.local

cardmgr -f
dhcpcd eth0

The "INTERFACES=(lo)" is for Apache (localhost).

Offline

Board footer

Powered by FluxBB