You are not logged in.

#1 2012-11-18 10:46:09

chx
Member
Registered: 2011-05-28
Posts: 83

Mouse pointer grab

I am up-to-date, I am using KDE, have Konsole and Konversation and Google Chrome running and something from time to time grabs my mouse: the pointer moves but clicks dont register. There are various ideas on how to break this but I have no numeric keypad and assigning keycode 135 = XF86ClearGrab in Xmodmap didnt help. Also tried XF86UnGrab . Might not fire, might not work, who knows.

Offline

#2 2012-11-18 11:21:41

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: Mouse pointer grab

Is this a laptop?

Because it could be an issue with the trackpad (taping it is the equivalent of a click). Smells like PEBKAC to me.

Last edited by DSpider (2012-11-18 11:23:23)


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#3 2012-11-18 11:52:18

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,368
Website

Re: Mouse pointer grab

If you do, in fact, believe that some process is inappropriately grabbing the mouse events, then you should probably tell us what processes are running at the times when this happens.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#4 2012-11-19 03:17:52

chx
Member
Registered: 2011-05-28
Posts: 83

Re: Mouse pointer grab

Actually clicks do register... it seems that sometimes the mouse is not aware of which window is in focus, and sends clicks to somewhere else. For example, I switch to another app and the click is sent to Chrome. Or, Konsole -- I just had to logout and log back in again because clicks were doing nothing but double clicks anywhere were starting new tabs. Very intriguing bug.

And I have a laptop, yes, it has a trackpoint and a trackpad and I disabled the trackpad since to no avail. This, however, seem to happen only with my Evoluent VM 4 mouse. I have reconfigured the buttons to Option "ButtonMapping" "1 3 0 4 5 0 0 0 2 0 0 12 13 14" which seems to help a lot, now it happens a lot, lot less. I *think* that the mouse sends some event to X which makes it go nuts.

Offline

#5 2012-12-12 18:06:13

chx
Member
Registered: 2011-05-28
Posts: 83

Re: Mouse pointer grab

I have mapped the Menu key to XF86LogGrabInfo and when this occured then plasma-desktop was grabbing the mouse, then I did kquitapp plasma-desktop ; plasma-desktop which moved the grab to konsole, exiting that moved the grab to the next program...eventually I just logged out which alas destroyed the log. I will research more on how to break them and next time I see this I will copy the log and post here.

Also, mouse gestures -- pressing button 3 and dragging the mouse -- seems to trigger this. X loses the button 3 release event?

Last edited by chx (2012-12-12 18:14:25)

Offline

#6 2012-12-14 03:19:50

chx
Member
Registered: 2011-05-28
Posts: 83

Re: Mouse pointer grab

Two instances:

285265.365] Active grab 0x4200000 (core) on device 'Virtual core pointer' (2):
[285265.365]       client pid 21657 kdeinit4: konsole [kdeinit] -session 10e5d3ab7200013553349450 
[285265.365]       at 285158360 (from passive grab) (implicit) (device thawed, state 1)
[285265.365]         core event mask 0x62e07f
[285265.365]       passive grab type 4, detail 0x0, activating key 0
[285265.365]       owner-events false, kb 1 ptr 1, confine 0, cursor 0x0
[285265.365] (II) End list of active device grabs
[297685.310] Active grab 0x5200000 (core) on device 'Virtual core pointer' (2):
[297685.310]       client pid 25164 /opt/google/chrome/chrom 
[297685.310]       at 297514999 (from passive grab) (implicit) (device thawed, state 1)
[297685.310]         core event mask 0x63807f
[297685.310]       passive grab type 4, detail 0x0, activating key 0
[297685.310]       owner-events false, kb 1 ptr 1, confine 0, cursor 0x0
[297685.310] (II) End list of active device grabs

Offline

#7 2012-12-14 11:47:06

gdkags
Member
Registered: 2010-10-12
Posts: 10

Re: Mouse pointer grab

I have the same problem, too.

I guess, there are several unresolved problem reports here in the forums.
This is my old one: [wmii/i3] weird focus issues w/ tiling window managers
Then there is that one: Key event focus problem with AwesomeWM+evince 3.0(want confirmation)
and I guess there might be some others. Which will blame different causes.
There are several post over at stackexchange and the web.

I experienced this on my old setup, it is so annoying that I gave up on linux completely for a year or so. Now I thought I could try something else because "cinnamon wm" seemed to hit the spot exactly for what I wanted.

Now here I am having the same problem, again.
I am so frustrated, that I do not use archlinux for work anymore.
If there is anything I can do to help, I'd be happy to do so, because I want to use archlinux so badly.

With i3wm I could escape the false grab by changing screens, with cinnamon it is somewhat more fiddly. I have to change to another empty workspace via keyboard (because mouse will not work), right click on the empty desktop and get to see the context menu for for the focus grabbed window. Then exit and close the context menu by clicking besides it, and most of the time, I can use my mouse again until I click another window.

With Firefox I can access tabs within the focused window, but the window decoration is inaccessible until I exit the grab again. I tried using qt programs, because I thought this might be a gtk problem, but with okular, there is the same problem. I did not have the problem with my tiling wms because they do not decorate the windows.

Offline

#8 2013-02-19 03:25:01

chx
Member
Registered: 2011-05-28
Posts: 83

Re: Mouse pointer grab

Note that while the problem occurs from time to time, running

xdotool mouseup 3

releases the grab.

Offline

#9 2013-02-19 09:44:20

Pitmairen
Member
Registered: 2007-08-02
Posts: 35

Re: Mouse pointer grab

I have the same problem. (https://bbs.archlinux.org/viewtopic.php?id=153359)

It's very annoying, i will try the xdotool command next time it happens.


Edit:
Finally, Thank you! smile
Using "xdotool mouseup 3" makes the mouse work again. This problem was driving me mad.

I figured out how to reproduce the problem. Simply right click and hold it down and then left click while still holding down the right button.

Edit2:
Simply just holding down the right mouse button 1-2 seconds will make the mouse stop working. No need to left click.

Edit3:
This seems to happen because of some custom mouse gestures i have created  that are using the right mouse button as a trigger. (Shortcuts and Gestures in KDE system settings)

Last edited by Pitmairen (2013-02-19 11:14:44)

Offline

Board footer

Powered by FluxBB