You are not logged in.

#1 2012-11-21 01:15:01

Blender
Member
Registered: 2011-05-11
Posts: 36

AMD 7970 support

I got a Sapphire 7970 a few days ago and have been struggling to get it to work properly on my Arch install. The proprietary drivers seem to have less problems than the open source ones, but both share some really annoying ones:

  • Everything is laggy. Integrated Intel HD 4000 runs much faster.

  • Gstreamer doesn't work

  • The mouse cursor disappears when I type and when I scroll. I haven't found any solutions.

  • Chromium has some strange tab font bug: 1whCa.png

Both the xf86-video-ati and the catalyst drivers have problems, but only the catalyst driver keep the fan speed at a tolerable level.

So my question is, how do I get this card to work on Arch? I only use it for gaming on Windows, so if it's impossible to get it to work properly, how would I switch to Intel integrated graphics only when booting into Arch?

I never knew the AMD drivers were this bad for Linux.

Any and all help is greatly appreciated.

Offline

#2 2012-11-21 10:45:39

89c51
Member
Registered: 2012-06-05
Posts: 670

Re: AMD 7970 support

Your card is SI right??

The radeonsi driver is not ready yet afaik but its coming.

Offline

#3 2012-11-24 09:31:10

whaler
Member
From: Oslo, Norway
Registered: 2008-03-25
Posts: 317

Re: AMD 7970 support

I have similar, and several more, problems with ASUS Radeon HD 7870. Tried downgrading to xf86-video-ati-1:6.14.6-2-x86_64.pkg.tar.xz as I noticed quite a few users experience problems with version 1:7.0.0-1, but that only resulted in a black GUI (KDE). I have not tried the catalyst driver.

What is "SI"?

Edit: Ah, I presume you mean Southern Island cards. Seems it will be a looong wait:

http://www.phoronix.com/scan.php?page=n … px=MTE0OTY

Last edited by whaler (2012-11-24 11:35:54)

Offline

#4 2012-11-25 22:18:05

prkane
Member
Registered: 2012-11-11
Posts: 3

Re: AMD 7970 support

I am experiencing similar problems with the my setup. I have 2 AMD 7800 cards in Crossfire, and I have 2 monitors plugged into the DVI ports and the HDMI connected to an AV receiver. I am using gnome 3 and xf86-video-ati, and while the display works, there is extremely high CPU usage when moving windows around or even moving the mouse. I am surprised by this, because I am running an intel 3770K... Also, I cannot get the HDMI audio out to work so I can play music on the receiver, and when I try to install the catalyst, gnome goes into fallback mode everytime. Am I also doing something wrong?

Offline

#5 2012-11-26 15:57:52

wwgfd
Member
From: UK
Registered: 2012-10-11
Posts: 32

Re: AMD 7970 support

Thanks @whaler for the link, great overview of the current situation regarding the development of the linux ATi/AMD drivers

I'm also having a few problems with my HIS HD7870 (yes this is a Southern Islands / SI chipset)

I wonder if the slow response times even on the desktop is (to quote the Phoronix article) because "There isn't even 2D acceleration support yet..."


What would Gordon Freeman do?

Offline

#6 2014-11-04 19:20:30

wagner-felix
Member
Registered: 2013-03-26
Posts: 11

Re: AMD 7970 support

Hello,

I also have a PowerColor Radeon HD 7970 OC. Recently I tried the open source driver again. If it works it works great however after a time the card got really hot and then the monitor turns black and you cannot get graphics back again without restarting.
I have 2 monitors, power save was set to balanced. Anyone have any suggestions?

Sincerely
wagner-felix

Offline

#7 2014-11-04 22:19:49

fukawi2
Forum Moderator
From: .vic.au
Registered: 2007-09-28
Posts: 5,304
Website

Re: AMD 7970 support

@wagner-felix Please let the dead rest in peace: https://wiki.archlinux.org/index.php/Fo … Bumping.22

Closing.

Offline

Board footer

Powered by FluxBB