You are not logged in.

#1 2012-12-01 10:10:46

mfaridi
Member
Registered: 2010-12-15
Posts: 191

The legacy network settings format is deprecated. See rc.conf(5) for

today when I run this comman d

/etc/rc.d/network restart

I see this message

The legacy network settings format is deprecated. See rc.conf(5) for details. 
:: Stopping network                                                      [DONE] 
 The legacy network settings format is deprecated. See rc.conf(5) for details. 
:: Starting network                                                      [DONE] 

this is my rc.conf

#
# /etc/rc.conf - Main Configuration for Arch Linux
#

# -----------------------------------------------------------------------
# LOCALIZATION
# -----------------------------------------------------------------------
#
# LOCALE: available languages can be listed with the 'locale -a' command
# HARDWARECLOCK: set to "UTC" or "localtime", any other value will result
#   in the hardware clock being left untouched (useful for virtualization)
# TIMEZONE: timezones are found in /usr/share/zoneinfo
# KEYMAP: keymaps are found in /usr/share/kbd/keymaps
# CONSOLEFONT: found in /usr/share/kbd/consolefonts (only needed for non-US)
# CONSOLEMAP: found in /usr/share/kbd/consoletrans
# USECOLOR: use ANSI color sequences in startup messages
#
LOCALE="en_US.UTF-8"
HARDWARECLOCK="UTC"
TIMEZONE="Asia/Tehran"
KEYMAP="us"
CONSOLEFONT=
CONSOLEMAP=
USECOLOR="yes"

# -----------------------------------------------------------------------
# HARDWARE
# -----------------------------------------------------------------------
#
# MOD_AUTOLOAD: Allow autoloading of modules at boot and when needed
# MOD_BLACKLIST: Prevent udev from loading these modules
# MODULES: Modules to load at boot-up. Prefix with a ! to blacklist.
#
# NOTE: Use of 'MOD_BLACKLIST' is deprecated. Please use ! in the MODULES array.
#
MOD_AUTOLOAD="yes"
#MOD_BLACKLIST=() #deprecated
MODULES=(vboxdrv fuse)

# Scan for LVM volume groups at startup, required if you use LVM
USELVM="no"

# -----------------------------------------------------------------------
# NETWORKING
# -----------------------------------------------------------------------
#
# HOSTNAME: Hostname of machine. Should also be put in /etc/hosts
#
HOSTNAME="mfaridiarch"

# Use 'ifconfig -a' or 'ls /sys/class/net/' to see all available interfaces.
#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
#   - prefix an entry in INTERFACES with a ! to disable it
#   - no hyphens in your interface names - Bash doesn't like it
# 
# DHCP:     Set your interface to "dhcp" (eth0="dhcp")
# Wireless: See network profiles below
#

#Static IP example
#eth0="eth0 192.168.1.2  netmask 255.255.255.0 broadcast 192.168.1.1"
eth0="dhcp"
INTERFACES=(eth0)

# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   - prefix an entry in ROUTES with a ! to disable it
#
#gateway="default gw 192.168.0.1"
ROUTES=(!gateway)
 
# Enable these network profiles at boot-up.  These are only useful
# if you happen to need multiple network configurations (ie, laptop users)
#   - set to 'menu' to present a menu during boot-up (dialog package required)
#   - prefix an entry with a ! to disable it
#
# Network profiles are found in /etc/network.d
#
# This now requires the netcfg package
#
NETWORKS=(main)

# -----------------------------------------------------------------------
# DAEMONS
# -----------------------------------------------------------------------
#
# Daemons to start at boot-up (in this order)
#   - prefix a daemon with a ! to disable it
#   - prefix a daemon with a @ to start it up in the background
#
DAEMONS=(syslog-ng dbus  sshd  network gdm   netfs crond @vnstat)

I see this error in red color

Last edited by mfaridi (2012-12-01 10:11:32)

Offline

#2 2012-12-01 10:44:17

Raynman
Member
Registered: 2011-10-22
Posts: 1,074

Re: The legacy network settings format is deprecated. See rc.conf(5) for

That rc.conf appears to be pretty old (most of the comments were removed and network configuration syntax changed). More recently most settings were moved to separate files to prepare for the switch to systemd (which happened almost two months ago) and the old way is now deprecated (the specific format of rc.conf, but also the whole initscripts system).

Apparently you haven't really kept up with the news on the frontpage. So you should see what you missed and move to systemd (which you can do in steps; start by using a more current configuration).

Edit: also, the error points you to the man page for rc.conf -- did you at least have a look at it?

Last edited by Raynman (2012-12-01 10:45:33)

Offline

#3 2012-12-01 14:46:39

tomegun
Developer
From: France
Registered: 2010-05-28
Posts: 661

Re: The legacy network settings format is deprecated. See rc.conf(5) for

Please check 'man rc.conf' for what options are supported.

Moreover, initscripts support (and rc.conf support) is going away soon. I therefore urge you to move to systemd (check the wiki).

Offline

#4 2012-12-07 16:35:00

mfaridi
Member
Registered: 2010-12-15
Posts: 191

Re: The legacy network settings format is deprecated. See rc.conf(5) for

whre I can fing good howto for move to systemd

Offline

#5 2012-12-07 16:43:04

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,407

Re: The legacy network settings format is deprecated. See rc.conf(5) for

mfaridi wrote:

whre I can fing good howto for move to systemd

That sentence  cannot be parsed in English.  I think you want this: https://wiki.archlinux.org/index.php/Systemd

Last edited by ewaller (2012-12-07 16:43:18)


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

Board footer

Powered by FluxBB