You are not logged in.

#1 2012-11-21 12:03:45

whoops
Member
Registered: 2009-03-19
Posts: 792

[Solved] Disable ANI / enable ath9k debugging / lag spikes?

Hi!

I seem to be affected by this bug:
https://bugzilla.kernel.org/show_bug.cgi?id=42092
( Lag spikes / network freezes every 30 seconds with ath9k / Atheros Communications Inc. AR5416 Wireless Network Adapter [AR5008 802.11(a)bgn] )

A workaround should be to disable ANI, but I don't seem to have that  system pointer file thingy for the ath9k debug option I need:
/sys/kernel/debug/ieee80211/phy?/ath9k/disable_ani

[root@xarch phy2]# ls /sys/kernel/debug/ieee80211/phy?/ -al
/sys/kernel/debug/ieee80211/phy2/:
total 0
drwxr-xr-x 2 root root 0 20. Nov 10:41 .
drwxr-xr-x 4 root root 0 20. Nov 10:40 ..

/sys/kernel/debug/ieee80211/phy3/:
total 0
drwxr-xr-x 2 root root 0 20. Nov 19:31 .
drwxr-xr-x 4 root root 0 20. Nov 10:40 ..
[root@xarch phy2]# 

So... 2 1 Questions:
1) Do I need "ANI" or can I just disable it until the bug is fixed? Unless what is triggering the bug is a ruined and uninhabited medieval Armenian city-site situated in the Turkish province of Kars, I can't seem to find any information on what this "ANI" is / does. Tried to read the ath9k code but its beyond me... is it just a fail-safe that keeps the card from using the wrong antennas or is it more important to improving signal? I don't get it T_T
2) How do I get the debugging option to disable ANI in my /sys? I tried to compile a custom kernel with debugging stuff activated and installed random ath9k stuff but I guess I did the wrong thing because nothing changed.*


Thanks!


*( I think I might have recompiled the kernel with "Atheros wireless debugging" option enabled and then I loaded the module with debug option "debug=0x00000200", but I'm not sure I did it right / changed anything at all. This all looks very confusing to me, I don't know how to check if what I did worked / which part didn't Recompiled the kernel a third time. Now the debug options are there. No idea what I did wrong before, maybe I didn't overwrite the .config properly)

edit: Since it was easier as expected to enable the debug option after all, I'll just test it for now and "report back" in a few days... still have no idea what ANI is, but so far, for the first 20 Minutes or so, there seems to be no problem with it being disabled and my bug stuff / latency spikes seem to be gone entirely.

Last edited by whoops (2012-11-21 20:31:37)

Offline

#2 2012-11-21 20:02:19

Strike0
Member
From: Germany
Registered: 2011-09-05
Posts: 1,277

Re: [Solved] Disable ANI / enable ath9k debugging / lag spikes?

(1) ath9k mailing list  wrote:

... If your WLAN device detects too much noise (or the noise detection is
buggy), then ANI (adaptive noise immunity) attenuates the incoming
signal. Again you get a bit deaf. But this time by purpose, so that
the reception part of the WLAN chip doesn't get overdriven and into
clipping mode. ..

So, you should be ok to disable it. It is meant to improve performance in situations with wifi interference. It has nothing to do with the antenna directly.

[1] http://comments.gmane.org/gmane.linux.d … devel/8840

Offline

#3 2012-11-21 20:31:24

whoops
Member
Registered: 2009-03-19
Posts: 792

Re: [Solved] Disable ANI / enable ath9k debugging / lag spikes?

Ooh, "adaptive noise immunity", thanks!
( I hate it when abbreviations are so short + common that googling is futile )

That doesn't sound too important. So far it seems to be working fine, too, so... solved.

Offline

#4 2012-12-01 18:48:25

browntown
Member
From: Salem, OR USA
Registered: 2012-11-20
Posts: 63

Re: [Solved] Disable ANI / enable ath9k debugging / lag spikes?

I dont show an ANI in my /sys/kernel/debug/ieee80211/phy0 folder either, can you repeat how you were able to disable it?  Was it just recompiling the kernel?  I just upgraded to 3.6.8-1 hoping for a fix in my ath9k super weak reception problems but no go.

Offline

#5 2012-12-01 19:04:45

whoops
Member
Registered: 2009-03-19
Posts: 792

Re: [Solved] Disable ANI / enable ath9k debugging / lag spikes?

I have no idea how this could improve reception (thought it only helped with mentioned bug that affects very few adapters), but in case you want to try anyway:

I just edited the kernels PKGBUILD to use menuconfig (if I remember right, I just had to comment out a line) and there I enabled

Device Drivers  --->
  [*] Network device support  --->
        Wireless LAN  --->
          <M>   Atheros Wireless Cards  --->
                [*] Atheros wireless debugging

... before recompiling, like described here: http://linuxwireless.org/en/users/Drivers/ath9k/debug
( The other steps were not needed )

Offline

Board footer

Powered by FluxBB