You are not logged in.

#1 2012-12-05 22:21:35

theking2
Member
Registered: 2009-03-04
Posts: 314

systemctl enable lvm-monitoring : Invalid argument

Hi!

When I issue the command " systemctl enable lvm-monitoring" I get "Operation failed: Invalid argument".

I have a really simple NAS system with lvm to handle the storage. Arch is sitting on a separate SSD. [https://wiki.archlinux.org/index.php/Systemctl] suggested this daemon.

Is the wiki wrong or is there something wrong with my setup?


archlinux on a Gigabyte C1037UN-EU, 16GiB
a Promise  PDC40718 based ZFS set
root on a Samsung SSD PB22-J
running LogitechMediaServer, Samba, MiniDLNA, TOR

Offline

#2 2012-12-05 22:41:09

tomegun
Developer
From: France
Registered: 2010-05-28
Posts: 661

Re: systemctl enable lvm-monitoring : Invalid argument

Works for me. Are you doing this from the install media, or have you already booted into Arch?

Offline

#3 2012-12-05 23:07:09

theking2
Member
Registered: 2009-03-04
Posts: 314

Re: systemctl enable lvm-monitoring : Invalid argument

tomegun wrote:

Works for me. Are you doing this from the install media, or have you already booted into Arch?

It's in arch on a existing installation dating back from 4 years.


archlinux on a Gigabyte C1037UN-EU, 16GiB
a Promise  PDC40718 based ZFS set
root on a Samsung SSD PB22-J
running LogitechMediaServer, Samba, MiniDLNA, TOR

Offline

#4 2012-12-05 23:16:27

googol-1
Member
Registered: 2012-10-21
Posts: 22

Re: systemctl enable lvm-monitoring : Invalid argument

What is the output from

pacman -Qs lvm2

and

pacman -Qk lvm2

and

cat /proc/1/comm

And why are you are you opening 5 topics to related problems (switching to systemd) at the seam time?
https://bbs.archlinux.org/viewtopic.php?id=154175
https://bbs.archlinux.org/viewtopic.php?id=154179
https://bbs.archlinux.org/viewtopic.php?id=154178
https://bbs.archlinux.org/viewtopic.php?id=154177

Last edited by googol-1 (2012-12-05 23:20:59)

Offline

#5 2012-12-05 23:48:14

theking2
Member
Registered: 2009-03-04
Posts: 314

Re: systemctl enable lvm-monitoring : Invalid argument

local/lvm2 2.02.98-1 (base)
    Logical Volume Manager 2 utilities
lvm2: 141 total files, 0 missing files
cat: /proc/l/comm: No such file or directory

respectively


archlinux on a Gigabyte C1037UN-EU, 16GiB
a Promise  PDC40718 based ZFS set
root on a Samsung SSD PB22-J
running LogitechMediaServer, Samba, MiniDLNA, TOR

Offline

#6 2012-12-05 23:52:15

googol-1
Member
Registered: 2012-10-21
Posts: 22

Re: systemctl enable lvm-monitoring : Invalid argument

cat /proc/1/comm

That is a one not a L.
But most likely you are not booting via systemd.

Offline

#7 2012-12-05 23:52:49

theking2
Member
Registered: 2009-03-04
Posts: 314

Re: systemctl enable lvm-monitoring : Invalid argument

Because they are only related to systemd but all distinct topics: documentation, wiki, LVM, etc. I just considered it fair not to mingle to many disjunctive topics in one thread but I'm open to suggestions. :-)


archlinux on a Gigabyte C1037UN-EU, 16GiB
a Promise  PDC40718 based ZFS set
root on a Samsung SSD PB22-J
running LogitechMediaServer, Samba, MiniDLNA, TOR

Offline

#8 2012-12-05 23:56:37

theking2
Member
Registered: 2009-03-04
Posts: 314

Re: systemctl enable lvm-monitoring : Invalid argument

cat /proc/1/comm
init

I couldn't successfully boot "via" systemd see one of the threads you mentioned.
hint: https://bbs.archlinux.org/viewtopic.php?id=154178

Last edited by theking2 (2012-12-05 23:58:01)


archlinux on a Gigabyte C1037UN-EU, 16GiB
a Promise  PDC40718 based ZFS set
root on a Samsung SSD PB22-J
running LogitechMediaServer, Samba, MiniDLNA, TOR

Offline

#9 2012-12-06 01:28:51

theking2
Member
Registered: 2009-03-04
Posts: 314

Re: systemctl enable lvm-monitoring : Invalid argument

radio silence. I have the distinct feeling I've offended someone.
And yes I'm not booting through systemd because I can't https://bbs.archlinux.org/viewtopic.php?id=154178

Last edited by theking2 (2012-12-06 01:31:38)


archlinux on a Gigabyte C1037UN-EU, 16GiB
a Promise  PDC40718 based ZFS set
root on a Samsung SSD PB22-J
running LogitechMediaServer, Samba, MiniDLNA, TOR

Offline

#10 2012-12-06 01:49:11

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,114
Website

Re: systemctl enable lvm-monitoring : Invalid argument

theking2 wrote:

radio silence. I have the distinct feeling I've offended someone.
And yes I'm not booting through systemd because I can't https://bbs.archlinux.org/viewtopic.php?id=154178

One can. You just haven't been reading what people have been posting.

I'm closing this as well: the topic is spurious - if you want to enable a service, boot with systemd.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

Board footer

Powered by FluxBB