You are not logged in.

#1 2012-12-07 22:05:59

mr337
Member
Registered: 2012-08-12
Posts: 15

Constant Wifi Disconnect After Moving To SystemD

Hi All,

I used netcfg for months with a WPA2 connection using the initscripts. I finally moved to systemD. I was getting dbus errors from systemD using systemctl so updated via pacman which fixed the errors. I did this within minutes apart so not for sure if a kernel update broke something - stupid move on my part.

Any how I followed the wiki guide for netcfg, within a few minutes and after a reboot was happily working away.  I configured the wifi like so:

systemctl enable netcfg@gloryhole

Then the wifi disconnecting started at random intervals but very quickly, what seems to be less than 3 minutes.

localhost kernel: [    9.331945] wlan0: authenticate with 90:a4:de:2f:1f:b9
localhost kernel: [    9.351603] wlan0: send auth to 90:a4:de:2f:1f:b9 (try 1/3)
localhost kernel: [    9.554574] wlan0: send auth to 90:a4:de:2f:1f:b9 (try 2/3)
localhost kernel: [    9.556136] wlan0: authenticated
localhost kernel: [    9.556291] rtl8192se 0000:1f:00.0: wlan0: disabling HT as WMM/QoS is not supported
localhost kernel: [    9.567893] wlan0: associate with 90:a4:de:2f:1f:b9 (try 1/3)
localhost kernel: [    9.569768] wlan0: RX AssocResp from 90:a4:de:2f:1f:b9 (capab=0x31 status=0 aid=3)
localhost kernel: [    9.570797] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
localhost kernel: [    9.570870] wlan0: associated
localhost kernel: [  326.279834] NVRM: GPU at 0000:02:00: GPU-23b184ce-812d-5661-9f43-2ee29ea56551
localhost kernel: [  383.804336] wlan0: deauthenticated from 90:a4:de:2f:1f:b9 (Reason: 2)
localhost kernel: [  383.820139] cfg80211: Calling CRDA for country: EC
localhost kernel: [  384.966159] wlan0: authenticate with 90:a4:de:2f:1f:b9
localhost kernel: [  384.985739] wlan0: send auth to 90:a4:de:2f:1f:b9 (try 1/3)
localhost kernel: [  384.987245] wlan0: authenticated
localhost kernel: [  384.987311] rtl8192se 0000:1f:00.0: wlan0: disabling HT as WMM/QoS is not supported
localhost kernel: [  384.998889] wlan0: associate with 90:a4:de:2f:1f:b9 (try 1/3)
localhost kernel: [  385.000853] wlan0: RX AssocResp from 90:a4:de:2f:1f:b9 (capab=0x31 status=0 aid=3)
localhost kernel: [  385.001928] wlan0: associated
localhost kernel: [  443.766995] wlan0: deauthenticated from 90:a4:de:2f:1f:b9 (Reason: 2)
localhost kernel: [  443.785044] cfg80211: Calling CRDA for country: US
localhost kernel: [  444.920930] wlan0: authenticate with 90:a4:de:2f:1f:b9
localhost kernel: [  444.940676] wlan0: send auth to 90:a4:de:2f:1f:b9 (try 1/3)
localhost kernel: [  444.942174] wlan0: authenticated
localhost kernel: [  444.942247] rtl8192se 0000:1f:00.0: wlan0: disabling HT as WMM/QoS is not supported
localhost kernel: [  444.953807] wlan0: associate with 90:a4:de:2f:1f:b9 (try 1/3)
localhost kernel: [  444.957208] wlan0: RX AssocResp from 90:a4:de:2f:1f:b9 (capab=0x31 status=0 aid=3)
localhost kernel: [  444.958280] wlan0: associated
localhost kernel: [  503.737604] wlan0: deauthenticated from 90:a4:de:2f:1f:b9 (Reason: 2)
localhost kernel: [  503.759940] cfg80211: Calling CRDA to update world regulatory domain
localhost kernel: [  504.899167] wlan0: authenticate with 90:a4:de:2f:1f:b9
localhost kernel: [  504.918917] wlan0: send auth to 90:a4:de:2f:1f:b9 (try 1/3)
localhost kernel: [  504.921386] wlan0: authenticated
localhost kernel: [  504.921458] rtl8192se 0000:1f:00.0: wlan0: disabling HT as WMM/QoS is not supported
localhost kernel: [  504.932053] wlan0: associate with 90:a4:de:2f:1f:b9 (try 1/3)
localhost kernel: [  504.933936] wlan0: RX AssocResp from 90:a4:de:2f:1f:b9 (capab=0x31 status=0 aid=3)
localhost kernel: [  504.935006] wlan0: associated
localhost kernel: [  517.536570] wlan0: deauthenticating from 90:a4:de:2f:1f:b9 by local choice (reason=3)
localhost kernel: [  517.569924] cfg80211: Calling CRDA for country: US

After reading some forums they recommended net-auto-wireless.

systemctl enable net-auto-wireless

Still no luck, another forum recommended removing netcfg and trying some thing else, since they had constant disconnects. I installed wicd and disabled services that could conflict with wicd.  Disconnect problem still exists sad

I verified hardware is OK, in windoze wifi card works great, pulled down many gigs with no problem testing. My laptop has native systemD install with wicd and works great so nothing with my AP.

My system info:

mr337@chronos ~ $ uname -a
Linux chronos 3.6.9-1-ARCH #1 SMP PREEMPT Tue Dec 4 08:04:10 CET 2012 x86_64 GNU/Linux

mr337@chronos ~ $ lspci | grep -i network
1f:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8191SEvB Wireless LAN Controller (rev 10)

If anyone can spot a trouble service

mr337@chronos ~ $ systemctl list-units
UNIT                        LOAD   ACTIVE SUB       DESCRIPTION
proc-sys...t_misc.automount loaded active running   Arbitrary Executable File Formats File System Automount Point
sys-devi...net-wlan0.device loaded active plugged   /sys/devices/pci0000:00/0000:00:04.0/0000:1f:00.0/net/wlan0
sys-devi...-net-eth0.device loaded active plugged   /sys/devices/pci0000:00/0000:00:06.0/0000:3f:00.0/net/eth0
sys-devi...-sda-sda1.device loaded active plugged   WDC_WD1001FALS-00J7B1
sys-devi...-sda-sda2.device loaded active plugged   WDC_WD1001FALS-00J7B1
sys-devi...-sda-sda3.device loaded active plugged   WDC_WD1001FALS-00J7B1
sys-devi...-sda-sda4.device loaded active plugged   WDC_WD1001FALS-00J7B1
sys-devi...-sda-sda5.device loaded active plugged   WDC_WD1001FALS-00J7B1
sys-devi...block-sda.device loaded active plugged   WDC_WD1001FALS-00J7B1
sys-devi...-sdb-sdb1.device loaded active plugged   WDC_WD2500AAKS-00UU3A0
sys-devi...-sdb-sdb2.device loaded active plugged   WDC_WD2500AAKS-00UU3A0
sys-devi...block-sdb.device loaded active plugged   WDC_WD2500AAKS-00UU3A0
sys-devi...block-sr0.device loaded active plugged   TSSTcorp_CDDVDW_TS-H653Q
sys-devi...und-card1.device loaded active plugged   Logitech_USB_Headset
sys-devi...und-card0.device loaded active plugged   /sys/devices/pci0000:00/0000:00:14.4/0000:07:04.0/sound/card0
sys-devi...tty-ttyS1.device loaded active plugged   /sys/devices/platform/serial8250/tty/ttyS1
sys-devi...tty-ttyS2.device loaded active plugged   /sys/devices/platform/serial8250/tty/ttyS2
sys-devi...tty-ttyS3.device loaded active plugged   /sys/devices/platform/serial8250/tty/ttyS3
sys-devi...tty-ttyS0.device loaded active plugged   /sys/devices/pnp0/00:07/tty/ttyS0
sys-subs...ices-eth0.device loaded active plugged   /sys/subsystem/net/devices/eth0
sys-subs...ces-wlan0.device loaded active plugged   /sys/subsystem/net/devices/wlan0
-.mount                     loaded active mounted   /
dev-hugepages.mount         loaded active mounted   Huge Pages File System
dev-mqueue.mount            loaded active mounted   POSIX Message Queue File System
home.mount                  loaded active mounted   /home
proc-sys...infmt_misc.mount loaded active mounted   Arbitrary Executable File Formats File System
sys-kernel-debug.mount      loaded active mounted   Debug File System
tmp.mount                   loaded active mounted   /tmp
cups.path                   loaded active running   CUPS Printer Service Spool
systemd-...ord-console.path loaded active waiting   Dispatch Password Requests to Console Directory Watch
systemd-...ssword-wall.path loaded active waiting   Forward Password Requests to Wall Directory Watch
colord.service              loaded active running   Manage, Install and Generate Color Profiles
cronie.service              loaded active running   Periodic Command Scheduler
cups.service                loaded active running   CUPS Printing Service
dbus.service                loaded active running   D-Bus System Message Bus
getty@tty1.service          loaded active running   Getty on tty1
ntpd.service                loaded active running   Network Time Service
rc-local.service            loaded active exited    /etc/rc.local Compatibility
sshd.service                loaded active running   OpenSSH Daemon
syslog-ng.service           loaded active running   System Logger Daemon
systemd-journald.service    loaded active running   Journal Service
systemd-logind.service      loaded active running   Login Service
systemd-...les-load.service loaded active exited    Load Kernel Modules
systemd-remount-fs.service  loaded active exited    Remount Root and Kernel File Systems
systemd-sysctl.service      loaded active exited    Apply Kernel Variables
systemd-...es-setup.service loaded active exited    Recreate Volatile Files and Directories
systemd-...-trigger.service loaded active exited    udev Coldplug all Devices
systemd-udevd.service       loaded active running   udev Kernel Device Manager
systemd-...sessions.service loaded active exited    Permit User Sessions
systemd-...le-setup.service loaded active exited    Setup Virtual Console
wicd.service                loaded active running   Wicd a wireless and wired network manager for Linux
cups.socket                 loaded active listening CUPS Printing Service Sockets
dbus.socket                 loaded active running   D-Bus System Message Bus Socket
syslog.socket               loaded active running   Syslog Socket
systemd-initctl.socket      loaded active listening /dev/initctl Compatibility Named Pipe
systemd-journald.socket     loaded active running   Journal Socket
systemd-shutdownd.socket    loaded active listening Delayed Shutdown Socket
systemd-...d-control.socket loaded active listening udev Control Socket
systemd-udevd-kernel.socket loaded active running   udev Kernel Socket
dev-sda2.swap               loaded active active    /dev/sda2
arch-daemons.target         loaded active active    Arch Daemons
basic.target                loaded active active    Basic System
cryptsetup.target           loaded active active    Encrypted Volumes
getty.target                loaded active active    Login Prompts
graphical.target            loaded active active    Graphical Interface
local-fs-pre.target         loaded active active    Local File Systems (Pre)
local-fs.target             loaded active active    Local File Systems
multi-user.target           loaded active active    Multi-User
remote-fs.target            loaded active active    Remote File Systems
sockets.target              loaded active active    Sockets
sound.target                loaded active active    Sound Card
swap.target                 loaded active active    Swap
sysinit.target              loaded active active    System Initialization
syslog.target               loaded active active    Syslog
systemd-...iles-clean.timer loaded active waiting   Daily Cleanup of Temporary Directories

Offline

#2 2012-12-08 01:08:31

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,675

Re: Constant Wifi Disconnect After Moving To SystemD

Nothing in rc.local or arch-daemons conflicts? (I'm not certain what the latter does...)

You don't have a network.target listed? That seems kind of weird... wicd, for example, wants that target...


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#3 2012-12-08 15:17:06

mr337
Member
Registered: 2012-08-12
Posts: 15

Re: Constant Wifi Disconnect After Moving To SystemD

rc.local is empty except for a few commented lines, arch-daemons is a unit file and not for sure what it does or what I am looking for.

I disabled the network.target as I thought it was part of the old network including network.service. So I re-enabled it but having problems stilling the network.service

mr337@chronos ~ $ sudo systemctl stop network.service
Warning: Unit file of network.service changed on disk, 'systemctl --system daemon-reload' recommended.

Now it shows up as failed

mr337@chronos ~ $ systemctl list-units
....
network.service                                           loaded failed failed    LEGACY unit for "network" rc script

Offline

#4 2012-12-09 03:49:40

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,675

Re: Constant Wifi Disconnect After Moving To SystemD

You shouldn't need to enable network.target explicitly - it should just work. And I don't think you should need to enable network.service either... I don't even have a network.service file. I guess you still have the old initscripts compatibility package installed?


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#5 2012-12-09 13:21:38

gigo
Member
Registered: 2012-12-09
Posts: 1

Re: Constant Wifi Disconnect After Moving To SystemD

Hi,
I ran over this thread searching for solution of the same problem. The only thing we have in common is the kernel version. I don't even use ARCH. I don't get these disconnects with older kernels, only with 3.6.9. Maybe it is a coincidence in your case and it does not have anything to do with SystemD. Can you try older kernel?

Last edited by gigo (2012-12-09 16:10:11)

Offline

#6 2012-12-11 00:23:03

mr337
Member
Registered: 2012-08-12
Posts: 15

Re: Constant Wifi Disconnect After Moving To SystemD

@cfr I did forget to remove the initscripts packages, done.

@gigo I did take your advice and reverted back to older kernel version, both of witch my wifi worked well.

linux-3.6.3-1-x86_64.pkg.tar.xz - Oct 22, 2012
linux-3.5.6-1-x86_64.pkg.tar.xz - Jul 30, 2012

Unfortantely, the problem still persits,

#Computer booted up and connecting to wifi with wicd
localhost kernel: [   38.379274] wlan0: send auth to 90:a4:de:2f:1f:b9 (try 3/3)
localhost kernel: [   38.582377] wlan0: authentication with 90:a4:de:2f:1f:b9 timed out
localhost kernel: [   46.777731] eth0: no IPv6 routers present
localhost kernel: [   50.011659] wlan0: authenticate with 90:a4:de:2f:1f:b9
localhost kernel: [   50.031414] wlan0: send auth to 90:a4:de:2f:1f:b9 (try 1/3)
localhost kernel: [   50.032967] wlan0: authenticated
localhost kernel: [   50.044559] wlan0: associate with 90:a4:de:2f:1f:b9 (try 1/3)
localhost kernel: [   50.046379] wlan0: RX AssocResp from 90:a4:de:2f:1f:b9 (capab=0x31 status=0 aid=4)
localhost kernel: [   50.047400] wlan0: associated
localhost kernel: [   50.048424] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
localhost kernel: [   60.830746] wlan0: no IPv6 routers present

#Was surfing internet till surfing stopped...


localhost kernel: [  116.445103] wlan0: deauthenticated from 90:a4:de:2f:1f:b9 (Reason: 2)
localhost kernel: [  116.459981] cfg80211: Calling CRDA for country: EC
localhost kernel: [  117.609227] wlan0: authenticate with 90:a4:de:2f:1f:b9
localhost kernel: [  117.628933] wlan0: send auth to 90:a4:de:2f:1f:b9 (try 1/3)
localhost kernel: [  117.831878] wlan0: send auth to 90:a4:de:2f:1f:b9 (try 2/3)
localhost kernel: [  117.833412] wlan0: authenticated
localhost kernel: [  117.845181] wlan0: associate with 90:a4:de:2f:1f:b9 (try 1/3)
localhost kernel: [  117.847118] wlan0: RX AssocResp from 90:a4:de:2f:1f:b9 (capab=0x31 status=0 aid=4)
localhost kernel: [  117.848137] wlan0: associated
localhost kernel: [  120.133028] wlan0: deauthenticating from 90:a4:de:2f:1f:b9 by local choice (reason=3)
localhost kernel: [  120.156582] cfg80211: Calling CRDA for country: US

#Wicd failing over to wired connection and starting it up

localhost kernel: [  120.321616] ADDRCONF(NETDEV_UP): wlan0: link is not ready
localhost kernel: [  120.442800] tg3 0000:3f:00.0: irq 43 for MSI/MSI-X
localhost kernel: [  120.486980] ADDRCONF(NETDEV_UP): eth0: link is not ready
localhost kernel: [  122.121719] tg3 0000:3f:00.0: eth0: Link is up at 100 Mbps, full duplex
localhost kernel: [  122.121726] tg3 0000:3f:00.0: eth0: Flow control is off for TX and off for RX
localhost kernel: [  122.122634] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
localhost kernel: [  125.157102] ADDRCONF(NETDEV_UP): wlan0: link is not ready
localhost kernel: [  125.324894] ADDRCONF(NETDEV_UP): wlan0: link is not ready
localhost kernel: [  125.427943] tg3 0000:3f:00.0: irq 43 for MSI/MSI-X
localhost kernel: [  125.472127] ADDRCONF(NETDEV_UP): eth0: link is not ready
localhost kernel: [  125.571137] tg3 0000:3f:00.0: irq 43 for MSI/MSI-X
localhost kernel: [  125.615294] ADDRCONF(NETDEV_UP): eth0: link is not ready
localhost kernel: [  127.145311] tg3 0000:3f:00.0: eth0: Link is up at 100 Mbps, full duplex
localhost kernel: [  127.145319] tg3 0000:3f:00.0: eth0: Flow control is off for TX and off for RX
localhost kernel: [  127.146262] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
localhost kernel: [  137.782458] eth0: no IPv6 routers present

I will have to look in the pacman logs and see if I can identify any related package and roll that back. I took a quick peek and didn't see anything, anyone have any ideas?

Offline

#7 2012-12-11 16:42:24

ackt1c
Member
From: Visalia, California
Registered: 2012-10-10
Posts: 215

Re: Constant Wifi Disconnect After Moving To SystemD

I do this,

systemctl enable dhcpcd@wlan0.service

always worked for me.

Offline

#8 2012-12-11 18:50:53

kwintruder
Member
Registered: 2009-03-18
Posts: 7

Re: Constant Wifi Disconnect After Moving To SystemD

hey, same prob here, the connection breaks are not so often, but are there and that sucks.
I use netcfg. I have set the dhcpd service on, so time will show.

Offline

#9 2012-12-11 19:25:52

kwintruder
Member
Registered: 2009-03-18
Posts: 7

Re: Constant Wifi Disconnect After Moving To SystemD

So, it's solved for me, dhcpd service is the key, I think, but a properly setting systemd is important though.

Offline

#10 2012-12-11 22:09:48

ackt1c
Member
From: Visalia, California
Registered: 2012-10-10
Posts: 215

Re: Constant Wifi Disconnect After Moving To SystemD

kwintruder wrote:

So, it's solved for me, dhcpd service is the key, I think, but a properly setting systemd is important though.

dhcpcd and netcfg have what to do with systemd? I think systemd just rationalizes the servies. Can you explain a little more on a proper systemd configuration?

Offline

#11 2012-12-11 23:14:48

mr337
Member
Registered: 2012-08-12
Posts: 15

Re: Constant Wifi Disconnect After Moving To SystemD

ackt1c wrote:

I do this,

systemctl enable dhcpcd@wlan0.service

always worked for me.

I am trying to figure out how this would fix the random dropping. Do you thinking there is a conflict some where because dhcpcd@wlan0.service wasn't enabled/running?

Before wicd test I had netcfg running for quite a while with no problems, and it uses dhcpcd by default too.

Hopefully tomorrow, when I get free time, I can revert back to netcfg and test your fix. Would be nice if that was the problem smile

Offline

#12 2012-12-12 18:24:09

ackt1c
Member
From: Visalia, California
Registered: 2012-10-10
Posts: 215

Re: Constant Wifi Disconnect After Moving To SystemD

I've had similiar problems, never understood them, but sometimes additional configurations conflict a simple service.
You might not need to use netcfg if you have no special circumstances.

Last edited by ackt1c (2012-12-12 18:25:48)

Offline

#13 2012-12-18 02:38:35

mr337
Member
Registered: 2012-08-12
Posts: 15

Re: Constant Wifi Disconnect After Moving To SystemD

So still being frustrated and tired of having a long cat5 cable across my house I decided to take another whack at this.

First thing first I disabled WPA2 on the AP and let it wide open, even though every other device was working. Was hoping to rule out wpa but instead it got worse.

I first tried netcfg, after removing everything I could find on wicd. The issue with netcfg is I could connect but couldn't surf. A little testing showed that there is a problem with the wifi link established. It won't allow much or any traffic to go through. Pings barely work, surfing was hit and miss.

I decided to just connect via cli, once again removed netcfg, wicd, removed any trace files, disabled related services and rebooted to remove previous entries.

mr337@chronos ~ $ sudo iwlist scan
eth0      Interface doesn't support scanning.

lo        Interface doesn't support scanning.

wlan0     Scan completed :
          Cell 01 - Address: 90:A4:DE:2F:1F:B9
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=56/70  Signal level=-54 dBm  
                    Encryption key:off
                    ESSID:"GloryHole"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
                    Mode:Master
                    Extra:tsf=000000005d6beed4
                    Extra: Last beacon: 33ms ago
                    IE: Unknown: 0009476C6F7279486F6C65
                    IE: Unknown: 010482848B96
                    IE: Unknown: 030101
                    IE: Unknown: 0706555320010B1B

mr337@chronos ~ $ sudo iwconfig wlan0 essid GloryHole
mr337@chronos ~ $ sudo dhcpcd wlan0
dhcpcd[2132]: version 5.6.3 starting
dhcpcd[2132]: wlan0: sending IPv6 Router Solicitation
dhcpcd[2132]: wlan0: broadcasting for a lease
dhcpcd[2132]: wlan0: offered 176.16.128.30 from 176.16.128.1
dhcpcd[2132]: wlan0: acknowledged 176.16.128.30 from 176.16.128.1
dhcpcd[2132]: wlan0: checking for 176.16.128.30
dhcpcd[2132]: wlan0: sending IPv6 Router Solicitation
dhcpcd[2132]: wlan0: leased 176.16.128.30 for 7200 seconds
dhcpcd[2132]: forked to background, child pid 2158
mr337@chronos ~ $ ping google.com
PING google.com (74.125.225.37) 56(84) bytes of data.
64 bytes from ord08s06-in-f5.1e100.net (74.125.225.37): icmp_seq=1 ttl=54 time=31.6 ms
64 bytes from ord08s06-in-f5.1e100.net (74.125.225.37): icmp_seq=2 ttl=54 time=28.9 ms
64 bytes from ord08s06-in-f5.1e100.net (74.125.225.37): icmp_seq=3 ttl=54 time=36.9 ms
64 bytes from ord08s06-in-f5.1e100.net (74.125.225.37): icmp_seq=4 ttl=54 time=34.1 ms
64 bytes from ord08s06-in-f5.1e100.net (74.125.225.37): icmp_seq=5 ttl=54 time=44.8 ms
64 bytes from ord08s06-in-f5.1e100.net (74.125.225.37): icmp_seq=6 ttl=54 time=52.1 ms
64 bytes from ord08s06-in-f5.1e100.net (74.125.225.37): icmp_seq=7 ttl=54 time=40.8 ms
64 bytes from ord08s06-in-f5.1e100.net (74.125.225.37): icmp_seq=8 ttl=54 time=41.6 ms
64 bytes from ord08s06-in-f5.1e100.net (74.125.225.37): icmp_seq=9 ttl=54 time=26.9 ms
64 bytes from ord08s06-in-f5.1e100.net (74.125.225.37): icmp_seq=11 ttl=54 time=32.1 ms
64 bytes from ord08s06-in-f5.1e100.net (74.125.225.37): icmp_seq=12 ttl=54 time=26.7 ms
64 bytes from ord08s06-in-f5.1e100.net (74.125.225.37): icmp_seq=14 ttl=54 time=34.0 ms
64 bytes from ord08s06-in-f5.1e100.net (74.125.225.37): icmp_seq=15 ttl=54 time=28.6 ms
64 bytes from ord08s06-in-f5.1e100.net (74.125.225.37): icmp_seq=16 ttl=54 time=27.9 ms
64 bytes from ord08s06-in-f5.1e100.net (74.125.225.37): icmp_seq=17 ttl=54 time=67.7 ms
64 bytes from ord08s06-in-f5.1e100.net (74.125.225.37): icmp_seq=18 ttl=54 time=52.6 ms
64 bytes from ord08s06-in-f5.1e100.net (74.125.225.37): icmp_seq=19 ttl=54 time=698 ms
64 bytes from ord08s06-in-f5.1e100.net (74.125.225.37): icmp_seq=20 ttl=54 time=720 ms
64 bytes from ord08s06-in-f5.1e100.net (74.125.225.37): icmp_seq=21 ttl=54 time=380 ms
64 bytes from ord08s06-in-f5.1e100.net (74.125.225.37): icmp_seq=22 ttl=54 time=383 ms
64 bytes from ord08s06-in-f5.1e100.net (74.125.225.37): icmp_seq=23 ttl=54 time=852 ms
64 bytes from ord08s06-in-f5.1e100.net (74.125.225.37): icmp_seq=24 ttl=54 time=986 ms

I was doing the pings while trying to do a quick speed test but that hung too

mr337@chronos ~ $ wget -O /dev/null http://cachefly.cachefly.net/10mb.test
--2012-12-17 14:20:11--  http://cachefly.cachefly.net/10mb.test
Resolving cachefly.cachefly.net (cachefly.cachefly.net)... 205.234.175.175
Connecting to cachefly.cachefly.net (cachefly.cachefly.net)|205.234.175.175|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 10485760 (10M) [application/octet-stream]
Saving to: ‘/dev/null’

13% [============>                                                                                     ] 1,405,172   --.-K/s  eta 20m 24s ^

Again I am getting these in the kernel.log

Dec 17 14:17:15 localhost kernel: [  569.314584] wlan0: authenticate with 90:a4:de:2f:1f:b9
Dec 17 14:17:15 localhost kernel: [  569.324640] wlan0: send auth to 90:a4:de:2f:1f:b9 (try 1/3)
Dec 17 14:17:15 localhost kernel: [  569.527632] wlan0: send auth to 90:a4:de:2f:1f:b9 (try 2/3)
Dec 17 14:17:16 localhost kernel: [  569.730752] wlan0: send auth to 90:a4:de:2f:1f:b9 (try 3/3)
Dec 17 14:17:16 localhost kernel: [  569.933897] wlan0: authentication with 90:a4:de:2f:1f:b9 timed out
Dec 17 14:18:42 localhost kernel: [  656.135945] wlan0: authenticate with 90:a4:de:2f:1f:b9
Dec 17 14:18:42 localhost kernel: [  656.145999] wlan0: send auth to 90:a4:de:2f:1f:b9 (try 1/3)
Dec 17 14:18:42 localhost kernel: [  656.150370] wlan0: authenticated
Dec 17 14:18:42 localhost kernel: [  656.150404] rtl8192se 0000:1f:00.0: wlan0: disabling HT as WMM/QoS is not supported
Dec 17 14:18:42 localhost kernel: [  656.162493] wlan0: associate with 90:a4:de:2f:1f:b9 (try 1/3)
Dec 17 14:18:42 localhost kernel: [  656.365624] wlan0: associate with 90:a4:de:2f:1f:b9 (try 2/3)
Dec 17 14:18:43 localhost kernel: [  656.568769] wlan0: associate with 90:a4:de:2f:1f:b9 (try 3/3)
Dec 17 14:18:43 localhost kernel: [  656.579139] wlan0: RX AssocResp from 90:a4:de:2f:1f:b9 (capab=0x21 status=0 aid=2)
Dec 17 14:18:43 localhost kernel: [  656.580162] wlan0: associated
Dec 17 14:18:43 localhost kernel: [  656.580196] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Dec 17 14:23:48 localhost kernel: [  962.118225] wlan0: deauthenticating from 90:a4:de:2f:1f:b9 by local choice (reason=3)
Dec 17 14:23:48 localhost kernel: [  962.141969] cfg80211: Calling CRDA for country: US

Interesting thing is I am getting a different deauthenticating reason, originally was 2. Deauthenticated reason=3 means "deauthenticated because sending STA is leaving (or has left) IBSS or ESS     The access point went offline, deauthenticating the client" or AP went offline, which it did not. (src: http://www.aboutcher.co.uk/2012/07/linu … on-codes/).

Keep in mind I run my house on the same wifi so if anything went down somebody always tracks me down to fix it. Also my ISP link is not the problem as I was downloading at the same time and not saturating my pipe.  At this point I think it is just easier to run a cable under the house and mount a jack. Ideas?

Offline

#14 2012-12-18 03:22:52

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Constant Wifi Disconnect After Moving To SystemD

I think it is probably the rtl8192se module.  I had the rtl8192ce module for the corresponding card, and it was terrible also.  I am surprised to see though that it worked well for you in kernels past.  Maybe you should enable graysky's repo-ck and try out one of his kernels.  The reason I suggest this is because his repo actually has 3.7.0 right now.  He usually stays pretty close if not in line with the main repo kernel, but lately has been in line with the testing repo.

Offline

Board footer

Powered by FluxBB