You are not logged in.

#1 2012-12-30 21:53:37

xcabal
Member
Registered: 2012-07-26
Posts: 33

[Solved]netcfg wep error

want to learn how to use netcgf,  so i configured a profile for my connection, which is wep then i ran netcfg with debug which gave me these results

sudo NETCFG_DEBUG="yes" netcfg Andy_Network
DEBUG: Loading profile Andy_Network
DEBUG: Configuring interface eth1
:: Andy_Network up                                                     [ BUSY ] DEBUG: status reported to profile_up as: 
DEBUG: Loading profile Andy_Network
DEBUG: Configuring interface eth1
DEBUG: wireless_up start_wpa eth1 /run/network/wpa.eth1/wpa.conf nl80211,wext 
 > Invalid SECURITY setting: WEP
DEBUG: wireless_up ifup
DEBUG: wireless_up wpa_check
DEBUG: wpa_cli -i eth1 -p /run/wpa_supplicant status
DEBUG: wpa_cli -i eth1 -p /run/wpa_supplicant status
DEBUG: wpa_cli -i eth1 -p /run/wpa_supplicant status
DEBUG: wpa_cli -i eth1 -p /run/wpa_supplicant status
DEBUG: wpa_cli -i eth1 -p /run/wpa_supplicant status
DEBUG: wpa_cli -i eth1 -p /run/wpa_supplicant status
DEBUG: wpa_cli -i eth1 -p /run/wpa_supplicant status
DEBUG: wpa_cli -i eth1 -p /run/wpa_supplicant status
DEBUG: wpa_cli -i eth1 -p /run/wpa_supplicant status
DEBUG: wpa_cli -i eth1 -p /run/wpa_supplicant status
DEBUG: wpa_cli -i eth1 -p /run/wpa_supplicant status
DEBUG: wpa_cli -i eth1 -p /run/wpa_supplicant status
DEBUG: wpa_cli -i eth1 -p /run/wpa_supplicant status

DEBUG: wpa_cli -i eth1 -p /run/wpa_supplicant terminate
 > WPA Authentication/Association Failed

if I use NetworkManager ihave no problems connecting so i double checked that the setting are right.
im on a macbook pro with the proprietary broadcom-wl driver installed.
anyone have any idea whats wrong and how to fix it.

Last edited by xcabal (2012-12-31 00:06:59)

Offline

#2 2012-12-30 21:57:23

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,693
Website

Re: [Solved]netcfg wep error

The first thing that is wrong is that you are using WEP.  Do you have any control or influence over this?  If so, you should consider switching to WPA/WPA2.

But that aside, if you need to connect to a WEP network, I don't think you should use wpa_supplicant.  I just checked, and apparently wpa_supplicant can be configured to connect to WEP, but it needs to be configured to do so.  Normally you'd just use iwconfig to connect to WEP networks.

I have no idea how these tools (iwconfig vs wpa_supplicant) are selected in netcfg though.

EDIT: for those who know netcfg, it'd probably be helpful if you posted the profile you created and are using.

Last edited by Trilby (2012-12-30 21:58:38)


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#3 2012-12-30 22:02:35

xcabal
Member
Registered: 2012-07-26
Posts: 33

Re: [Solved]netcfg wep error

i know i should be using wpa/2 but i have no control over the router, my landlord also knows that but one of the tenants has an old computer that doesn't work with wpa/2
here is the profile i made and use

CONNECTION="wireless"
DESCRIPTION=""
INTERFACE=eth1
HOSTNAME=z
IP="dhcp"
DHCP_TIMEOUT=10
ESSID="Andy_Network"
SECURITY="WEP"
KEY="6626811e486EABEE0867088A81"
SCAN="NO"
TIMEOUT=15

Offline

#4 2012-12-30 22:35:04

Gusar
Member
Registered: 2009-08-25
Posts: 3,431

Re: [Solved]netcfg wep error

Two things to try: One, write the key with all lowercase. Two, use a plain text password instead of a hex string, in this case prefix it with s: like so

KEY="s:passwd"

Offline

#5 2012-12-30 22:47:27

xcabal
Member
Registered: 2012-07-26
Posts: 33

Re: [Solved]netcfg wep error

i changed to lowercase no change same error, i cant change the password and i have to no other network to try a plain text

Offline

#6 2012-12-30 23:38:45

Gusar
Member
Registered: 2009-08-25
Posts: 3,431

Re: [Solved]netcfg wep error

You mean you don't know the password for the network, just the hex string?

Anyway, how didn't I notice this earlier:

> Invalid SECURITY setting: WEP

The security setting must be in lowercase, so wep and not WEP.

Offline

#7 2012-12-31 00:01:38

xcabal
Member
Registered: 2012-07-26
Posts: 33

Re: [Solved]netcfg wep error

Gusar wrote:

You mean you don't know the password for the network, just the hex string?

Anyway, how didn't I notice this earlier:

> Invalid SECURITY setting: WEP

The security setting must be in lowercase, so wep and not WEP.

changing from WEP to wep did it, thank you.
believe it or not the password is the hex string, i saw the router settings myself it is set to 128bit wep hex, there is no plain text password option as far as i know of beside wpa with the router my landlord has.

Offline

Board footer

Powered by FluxBB