You are not logged in.

#1 2013-01-10 23:57:10

Registered: 2013-01-10
Posts: 2

NForce4 Ethernet Controller can't connect at gigabit speed

Hi all,
    I just got a new gigabit switch after my old one was destroyed a few months ago by lightning (which I hope has nothing to do with this issue). When I hook up my Arch box to this switch, it seems to take a long time for the port lights to come on, and when they do it's only at 100baseT/Full Duplex. The machine has a nForce4 chipset that lspci -v reports as follows:

00:0a.0 Bridge: NVIDIA Corporation CK804 Ethernet Controller (rev a3)
        Subsystem: Micro-Star International Co., Ltd. Device 7185
        Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 23
        Memory at fe029000 (32-bit, non-prefetchable) [size=4K]
        I/O ports at f000 [size=8]
        Capabilities: [44] Power Management version 2
        Kernel driver in use: forcedeth

lspci for fun:

          description: Ethernet interface
          product: CK804 Ethernet Controller
          vendor: NVIDIA Corporation
          physical id: a
          bus info: pci@0000:00:0a.0
          logical name: eth0
          version: a3
          serial: 00:13:d3:c3:6d:8c
          size: 100000000
          capacity: 1000000000
          width: 32 bits
          clock: 66MHz
          capabilities: bridge pm bus_master cap_list ethernet physical mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
          configuration: autonegotiation=on broadcast=yes driver=forcedeth driverversion=0.64 duplex=full ip=123.456.789.000 latency=0 link=yes maxlatency=20 mingnt=1 multicast=yes port=MII speed=100Mbit/s
          resources: irq:23 memory:fe029000-fe029fff ioport:f000(size=8)

I tried swapping the cable with a device that does connect at 1Gbps but nothing changed so the cable isn't at fault.

I also tried to force the speed using ethtool -s eth0 speed 1000 but this simply returns: (I think this is because gigE requires the speed to be auto-negotiated.)

Cannot advertise speed 1000

It does seem to think gigE is supported, though:

# ethtool eth0
Settings for eth0:
        Supported ports: [ MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
        Advertised pause frame use: No
        Advertised auto-negotiation: Yes
        Speed: 100Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 1
        Transceiver: external
        Auto-negotiation: on
        Supports Wake-on: g
        Wake-on: d
        Link detected: yes

Thinking forcedeth might not be optimal I tried installing an old Nvidia driver from here … -0310.html. This flaked out by trying to set CFLAGS while using a kernel makefile. Here's the log: With that not working I'm out of ideas - in any case, nVidia seem to recommend forcedeth now.

I can't really rule out the switch at this point, but I can't see the reason for 100Mbps being picked. I'd appreciate any help understanding/fixing this.

Last edited by Morphit (2013-01-10 23:57:39)


#2 2013-01-11 00:02:58

From: The worse toilet in Scotland
Registered: 2008-12-01
Posts: 8,702

Re: NForce4 Ethernet Controller can't connect at gigabit speed

I didn't think nForce4 supported gigalan.  What is the model of your motherboard?

CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs


#3 2013-01-11 17:34:50

Registered: 2013-01-10
Posts: 2

Re: NForce4 Ethernet Controller can't connect at gigabit speed

MSI K8N-SLI - this one I think. … div=Detail

- IEEE 802.3 NVIDIA MAC for 1000BASE-T

It's also listed on nVidias nForce4 page:

NVIDIA Gigabit Ethernet - Yes

I also had the machine running at 1Gbps under Ubuntu at one point, though I don't have it installed any more so I can't compare.

In any case, why would ethtool report 1000baseT/Full as supported if it isn't? Is there a more reliable tool?


#4 2013-01-11 17:57:57

Registered: 2009-08-28
Posts: 3,058

Re: NForce4 Ethernet Controller can't connect at gigabit speed

Do you still have an Ubuntu (or any other Linux) Live CD to test?


Board footer

Powered by FluxBB