You are not logged in.

#1 2013-01-12 19:03:15

4ZM
Member
From: Stockholm, Sweden
Registered: 2013-01-09
Posts: 8
Website

[SOLVED] Wifi won't auto connect on boot - systemd issue?

I'm using netcfg and have a working profile for a WPA wireless network. Connecting using netcfg from the terminal works reliably.

However, I can't get automatic wifi connection at boot to work. I've followed the wiki instructions on the netcfg page, but some thing isn't quite right.

Last in the post is the output from:
$ systemctl status net-auto-wireless.service

Could this be some kind of timing / starting order issue with systemd and the network-related services?

Any ideas anyone?

net-auto-wireless.service - Provides automatic netcfg wireless connection
	  Loaded: loaded (/usr/lib/systemd/system/net-auto-wireless.service; enabled)
	  Active: active (running) since Sat, 2013-01-12 20:32:01 CET; 1min 39s ago
	 Process: 1142 ExecStart=/usr/bin/netcfg-wpa_actiond $WIRELESS_INTERFACE (code=exited, status=0/SUCCESS)
	  CGroup: name=systemd:/system/net-auto-wireless.service
		  └─1323 /usr/sbin/wpa_actiond -p /run/wpa_supplicant -i wlan...

Jan 12 20:32:00 carbon systemd[1]: Starting Provides automatic netcfg wireless connection...
Jan 12 20:32:00 carbon netcfg-wpa_actiond[1142]: catland
Jan 12 20:32:01 carbon wpa_actiond[1323]: Starting wpa_actiond session for interface 'wlan0'
Jan 12 20:32:01 carbon systemd[1]: Started Provides automatic netcfg wireless connection.
Jan 12 20:32:04 carbon wpa_actiond[1323]: Interface 'wlan0' connected to network 'CATLAND'
Jan 12 20:32:04 carbon dhcpcd[1402]: version 5.6.4 starting
Jan 12 20:32:04 carbon dhcpcd[1402]: wlan0: sending IPv6 Router Solicitation
Jan 12 20:32:04 carbon dhcpcd[1402]: wlan0: sendmsg: Cannot assign requested address
Jan 12 20:32:04 carbon dhcpcd[1402]: wlan0: broadcasting for a lease
Jan 12 20:32:08 carbon dhcpcd[1402]: wlan0: send_raw_packet: Network is down
Jan 12 20:32:08 carbon dhcpcd[1402]: wlan0: sending IPv6 Router Solicitation
Jan 12 20:32:08 carbon dhcpcd[1402]: wlan0: sendmsg: Network is unreachable
Jan 12 20:32:12 carbon dhcpcd[1402]: wlan0: sending IPv6 Router Solicitation
Jan 12 20:32:12 carbon dhcpcd[1402]: wlan0: sendmsg: Network is unreachable

Last edited by 4ZM (2013-01-14 08:16:17)

Offline

#2 2013-01-12 19:17:01

10PinkPanther
Member
From: Croatia
Registered: 2012-11-10
Posts: 333

Re: [SOLVED] Wifi won't auto connect on boot - systemd issue?

I use "systemctl enable net-auto-wireless".Works fine.I have wpa_supplicant,wpa_actiond and dialog installed.

Offline

#3 2013-01-12 20:47:13

eruditorum
Member
Registered: 2012-11-12
Posts: 130

Re: [SOLVED] Wifi won't auto connect on boot - systemd issue?

I have kind of same problem, but for me it is dhcpcd whose timeouts are too small sometimes, it should be about 30 seconds or so at minimum, I think.

Offline

#4 2013-01-12 21:51:31

4ZM
Member
From: Stockholm, Sweden
Registered: 2013-01-09
Posts: 8
Website

Re: [SOLVED] Wifi won't auto connect on boot - systemd issue?

I have default dhcp timeouts (i.e. not specified in conf file). man page for dhcp.conf says that that is 30 sec, so it should be enough.

Offline

#5 2013-01-13 00:13:54

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] Wifi won't auto connect on boot - systemd issue?

It appears that dhcpcd is not trying for a ipv4 lease.  It this intentional?  What happens if you try dhclient instead?  There should be a parameter in the conf file for your network (/etc/network.d/<your network>) that controls whether to use dhclient or dhcpcd.  I have netctl installed right now, so I cannot pull up the relevent man page, as it is not on my system.

Also, your title rather irritates me.  So many users come here posting their problem, and without a shred of evidence they automatically put "systemd problem" somewhere in the thread.  There is no indication whatsoever that this has anything to do with systemd.  WTF?

Offline

#6 2013-01-13 00:21:39

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,838
Website

Re: [SOLVED] Wifi won't auto connect on boot - systemd issue?

WonderWoofy wrote:

Also, your title rather irritates me.  So many users come here posting their problem, and without a shred of evidence they automatically put "systemd problem" somewhere in the thread.  There is no indication whatsoever that this has anything to do with systemd.  WTF?

"systemd issue?" => "PEBKAC but in denial"


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#7 2013-01-13 00:26:56

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] Wifi won't auto connect on boot - systemd issue?

@Trilby, this is why it annoys me.  It basically says, "I have an issue, for which I have no expertise necessary to fix or debug... but I'll bet it is this damn squirrely systemd thing... because I don't fully understand it..."

Offline

#8 2013-01-13 03:22:11

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: [SOLVED] Wifi won't auto connect on boot - systemd issue?

There are some other threads around about this and I thought that there was an issue with the startup order using netcfg with systemd specifically. I can't remember the details but a search should find the relevant information. I thought it only affected wired and/or static ip, though and neither of those seems to apply here.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#9 2013-01-14 08:15:43

4ZM
Member
From: Stockholm, Sweden
Registered: 2013-01-09
Posts: 8
Website

Re: [SOLVED] Wifi won't auto connect on boot - systemd issue?

For posterity: the problem seems to be that I hadn't enabled netcfg@<networkprofile>.service with systemd. I had only enabled my wired profile. I.e. doing 'systemctl enable netcfg@catland.service' fixed it.

In short this was a failure to configure netcfg startup with systemd. But hey, that makes it (drum roll...) a sysytemd issue! Like most of the problems one encounters while setting up a computer; it is a configuration issue (i.e. PEBKAC). But hey, thats what the forums are for.

@Trilby, @WonderWoofy Thank you both for your insightful, constructive and, above all, helpful comments. I hope everyone else coming to this thread for information on why their wifi won't start will find them every bit as useful as I did.

Offline

#10 2013-01-16 00:26:54

eruditorum
Member
Registered: 2012-11-12
Posts: 130

Re: [SOLVED] Wifi won't auto connect on boot - systemd issue?

4ZM wrote:

I have default dhcp timeouts (i.e. not specified in conf file). man page for dhcp.conf says that that is 30 sec, so it should be enough.

I mean this line in file "/usr/bin/netcfg-wpa_actiond-action":

dhcpcd -qL -t "${DHCP_TIMEOUT:-10}" -K $DHCP_OPTIONS "$interface"

After adding "DHCP_TIMEOUT=30" to "/etc/conf.d/netcfg" it works as it should.

Last edited by eruditorum (2013-01-20 22:17:15)

Offline

Board footer

Powered by FluxBB