You are not logged in.

#1 2013-01-13 20:35:49

From: Argentina
Registered: 2006-04-08
Posts: 98

NetworkManager, netcfg and pdnsd conflicts

I'll try to be brief and clear.
I installed Arch on a laptop which connects to a home wireless network.
I used wifi-menu to manually connect, but after enabling the netcfg@[homewireless] service, that wasn't necessary anymore.

Now, after installing Gnome Shell, I noticed no network applet, so I saw in the Arch wiki that the applet depends on NetworkManager.
The problem is that NetworkManager conflicts with netcfg in some way, because there is no way it connects when the NetworkManager service is enabled and running.

The message is always

 > WPA Authentication/Association Failed 

May it be wpa_supplicant insted of netcfg the reason of that?

Furthermore, NetworkManager seems to overwrite /etc/resolv.conf, making pdnsd useless.

I want autoconnect to the network and being able to select other networks if I'm not at home from a GUI (not wifi-menu)

Please, is there anything I'm missing?


#2 2013-01-13 20:51:44

Registered: 2010-04-27
Posts: 1,227

Re: NetworkManager, netcfg and pdnsd conflicts

You can only use one or the other (they serve the same purpose).

Both NetworkManager and netcfg manage network connections. nm-applet is a frontend for NetworkManager and thus requires NetworkManager (it will start it automatically using dbus if it isn't already running).

Steven [ web : git ]
GPG:  327B 20CE 21EA 68CF A7748675 7C92 3221 5899 410C
Do not email:


#3 2013-01-13 20:54:55

Registered: 2011-03-17
Posts: 801

Re: NetworkManager, netcfg and pdnsd conflicts

Try putting your nameserver in /etc/resolve.conf.head

$ cat /etc/resolv.conf.head 

Make sure you specify wlan0 / eth0 in your /etc/pdnsd.conf if applicable (the "interface" variable):

cat /etc/pdnsd.conf
global {
#	pid_file = /var/run/;
	server_ip =;  # Use eth0 here if you want to allow other
				# machines on your network to query pdnsd.
	status_ctl = on;
#	paranoid=on;       # This option reduces the chance of cache poisoning
	                   # but may make pdnsd less efficient, unfortunately.
        min_ttl=15m;       # Retain cached entries at least 15 minutes.
	max_ttl=1w;        # One week.
	timeout=3;        # Global timeout option (10 seconds).


# The following section is most appropriate if you have a fixed connection to
# the Internet and an ISP which provides good DNS servers.
server {
	label= "myisp";
	ip =;  # Put your ISP's DNS-server address(es) here.
#	proxy_only=on;     # Do not query any name servers beside your ISP's.
	                   # This may be necessary if you are behind some
	                   # kind of firewall and cannot receive replies
	                   # from outside name servers.
	timeout=30;         # Server timeout; this may be much shorter
			   # that the global timeout option.
	uptest=if;         # Test if the network interface is active.
	interface=eth0;    # The name of the interface to check.
	interval=10m;      # Check every 10 minutes.
	purge_cache=off;   # Keep stale cache entries in case the ISP's
			   # DNS servers go offline.

source {
#	serve_aliases=on;

include {file="/etc/pdnsd.include";}	# Read additional definitions from /etc/pdnsd.include.

rr {

You can edit / create /etc/dhclient.conf:

$ cat /etc/dhclient.conf
prepend domain-name-servers;

Also, you can define the nameserver in networkmanager under the edit connection tab for wireless and there is a networkmanager hook for pdnsd in the aur if that helps: … her-pdnsd/

Other than that do the obvious stuff like add pdnsd to your runlevel in systemd etc.. Hope any of that helps.

Edit: Don't forget to do all the permissions stuff too on the pdnsd wiki page.

Last edited by dodo3773 (2013-01-13 20:56:05)


#4 2013-01-13 21:36:59

From: Argentina
Registered: 2006-04-08
Posts: 98

Re: NetworkManager, netcfg and pdnsd conflicts

Thanks both of you. I've removed netcfg from my system, since even after disabling netcfg service there was left a netcfg@ service which I couldn't disable. I've created a resolv.conf.head file too, pointing to localhost, and NetworkManager didn't touch it smile

Now everything works as I wanted to ^^
Thanks again!


Board footer

Powered by FluxBB