You are not logged in.

#1 2013-01-15 20:01:49

jack.mitchell
Member
From: Ely, Cambridgeshire, UK
Registered: 2008-08-28
Posts: 156
Website

NFS: mount.nfs4: Cannot allocate memory

I had the following error pop up a couple of days ago. I didn't notice it after any particular upgrade but it very well could have been due to a package upgrade.

On the client:

mediaserver:/mnt/seaRaid/TV             /mnt/mediaserver/TV     nfs4    defaults,sec=sys        0       0
mediaserver:/mnt/seaRaid/Downloads              /mnt/mediaserver/Downloads      nfs4    defaults,sec=sys        0       0
mediaserver:/mnt/seaRaid/Movies         /mnt/mediaserver/Movies nfs4    defaults,sec=sys        0       0
mediaserver:/mnt/seaRaid/Music          /mnt/mediaserver/Music  nfs4    defaults,sec=sys        0       0

[xbmc@minimedia ~]$ sudo mount -a
mount.nfs4: Cannot allocate memory
mount.nfs4: Cannot allocate memory
mount.nfs4: Cannot allocate memory
mount.nfs4: Cannot allocate memory

On the server:

/mnt/seaRaid 192.168.1.0/24(rw,no_subtree_check,async,no_root_squash)
/mnt/seaRaid/TV 192.168.1.0/24(rw,no_subtree_check,async,no_root_squash)
/mnt/seaRaid/Movies 192.168.1.0/24(rw,no_subtree_check,async,no_root_squash)
/mnt/seaRaid/Downloads 192.168.1.0/24(rw,no_subtree_check,async,no_root_squash)
/mnt/seaRaid/Music 192.168.1.0/24(rw,no_subtree_check,async,no_root_squash)

I fixed it briefly by adding

Sec=sys

to the nfsconfig file but it seems not to be working anymore. Does anyone have any suggestions?

Offline

#2 2013-01-18 00:15:59

ubunchu
Member
Registered: 2012-05-01
Posts: 176

Re: NFS: mount.nfs4: Cannot allocate memory

Maybe this: https://bugs.launchpad.net/ubuntu/+sour … bug/309897  ?
And as a random newbie IT guy I must ask: did you try to reboot?
Good luck. Cheers!


Don't forget to mark as [SOLVED].

Offline

#3 2013-02-06 19:32:35

strafer
Member
Registered: 2013-02-06
Posts: 3

Re: NFS: mount.nfs4: Cannot allocate memory

I have the same problem

mount.nfs4: mount(2): Cannot allocate memory

fsid=0 is specified at /etc/exportfs.

Offline

#4 2013-02-12 12:03:08

schuschu
Member
Registered: 2009-06-06
Posts: 17

Re: NFS: mount.nfs4: Cannot allocate memory

Same problem over here too. I also have fsid=0 in my exports. Did anybody solve the problem?

Offline

#5 2013-04-24 12:23:52

lunamystry
Member
From: South Africa
Registered: 2011-04-14
Posts: 23

Re: NFS: mount.nfs4: Cannot allocate memory

I solved the problem for me and since this is the first link that came up on my google search, I thought I would share.
this link helped a lot: http://nileshgr.com/2013/01/29/nfs-cann … ory-errors

A quote from there:

Basically, in NFSv4, there is a / (root) under which all shares are exported and this must have the fsid=0 parameter specified in the configuration.
At the client, while mounting you are not supposed to specify the full path to the resource, instead it must be relative to the NFS Root.


The problem for me was that in my /etc/exports I didn't specify the nfs root.
so I just added::

      /srv/nfs4                  *(rw,fsid=0,no_root_squash,no_all_squash,no_subtree_check)
      /srv/nfs4/public        resource.ac.za(rw,fsid=0,no_root_squash,no_all_squash,no_subtree_check)

On the client:: 

      sudo mount -v -t nfs4 lunamystry.ac.za:/ /mnt/client

This solved me problem, it mounted my public folder which I mounted on my laptop with::

     sudo mount --bind /home/lunamystry/Public /srv/nfs4/public 

I will be playing with this a little later. Hope it helps someone though.

Offline

Board footer

Powered by FluxBB