You are not logged in.

#1 2011-05-12 14:43:12

jwhendy
Member
Registered: 2010-04-01
Posts: 558

wicd, bad password, seems to be related to router channel

Hi,


At work I use wicd to connect to wireless and have noticed that wicd will fail when the channel is too high, it seems. All the ESSIDs are the same and I have wicd set to use the same settings for all of them. When I go to a different building, sometimes the strongest signal will fail to connect. I've noticed that this happens when the channel is something like 52, 64, and even 16. But if I scroll down the wicd list and find a signal at channel 1 or 11, it will connect (I'm using these numbers because the higher ones all failed in a meeting this morning, but 1 and 11 worked.

Any thoughts on this?

The problem is repeatable. I'm happy to provide any further information.

Offline

#2 2013-01-15 19:28:07

sokito
Member
Registered: 2013-01-15
Posts: 6

Re: wicd, bad password, seems to be related to router channel

I am having the same issue on my linux mint laptop with wicd and wpa_supplicant.
I can connect to channel 1 w/o problem but if I try to connect to channel 36 for example. It says bad password and fails to connect.

Offline

#3 2013-01-15 19:31:54

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,816

Re: wicd, bad password, seems to be related to router channel

Is your locale set correctly?  In other words, are you configured to use the correct regulatory domain?  Channel Frequencies and permissible channels are country dependent.

Edit: BTW, this is a really old thread.  It did not have any information that may be outdated, so I will leave it open rather than ask you start a new thread.

Edit:  Oh, and welcome to Arch Linux smile

Last edited by ewaller (2013-01-15 19:33:56)


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
----
How to Ask Questions the Smart Way

Offline

#4 2013-01-15 19:36:43

sokito
Member
Registered: 2013-01-15
Posts: 6

Re: wicd, bad password, seems to be related to router channel

ewaller wrote:

Is your locale set correctly?  In other words, are you configured to use the correct regulatory domain?  Channel Frequencies and permissible channels are country dependent.

Edit: BTW, this is a really old thread.  It did not have any information that may be outdated, so I will leave it open rather than ask you start a new thread.

Edit:  Oh, and welcome to Arch Linux smile

I am not sure If I understood you correctly, but when I type 'locale' in terminal, the output is "en_US.UTF-8" for everything except "LANGUAGE" and "LC_ALL" which are empty.

Edit: Thanks. I really enjoy using Arch linux on my desktop ! except that I was having a real trouble trying to update glibc recently big_smile

Last edited by sokito (2013-01-15 19:38:30)

Offline

#5 2013-01-15 19:51:23

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,816

Re: wicd, bad password, seems to be related to router channel

What is the output of iw reg get
Do you have crda installed?
What country are you in?


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
----
How to Ask Questions the Smart Way

Offline

#6 2013-01-15 20:14:08

sokito
Member
Registered: 2013-01-15
Posts: 6

Re: wicd, bad password, seems to be related to router channel

ewaller wrote:

What is the output of iw reg get
Do you have crda installed?
What country are you in?

The output of iw reg get is:

country 00:
        (2402 - 2472 @ 40), (3, 20)
        (2457 - 2482 @ 20), (3, 20), PASSIVE-SCAN, NO-IBSS
        (2474 - 2494 @ 20), (3, 20), NO-OFDM, PASSIVE-SCAN, NO-IBSS
        (5170 - 5250 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS
        (5735 - 5835 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS

Yes I have crda installed and the output of crda is:

COUNTRY environment variable not set.

I live in USA.

Thanks.

Offline

#7 2013-01-15 20:27:00

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,816

Re: wicd, bad password, seems to be related to router channel

Well, country 00 should be okay.  You might try going into /etc/conf.d/wireless-regdom and un-comment US.  Then restart.  iw reg get should then report being US instead of 00.  The output may be a bit different.

It might look like:

 
country US:
	(2402 - 2472 @ 40), (3, 27)
	(5170 - 5250 @ 40), (3, 17)
	(5250 - 5330 @ 40), (3, 20), DFS
	(5490 - 5600 @ 40), (3, 20), DFS
	(5650 - 5710 @ 40), (3, 20), DFS
	(5735 - 5835 @ 40), (3, 30)

I am not at my wireless machine right now, so I cannot be certain.  See if this makes any difference.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
----
How to Ask Questions the Smart Way

Offline

#8 2013-01-16 05:46:38

sokito
Member
Registered: 2013-01-15
Posts: 6

Re: wicd, bad password, seems to be related to router channel

ewaller wrote:

Well, country 00 should be okay.  You might try going into /etc/conf.d/wireless-regdom and un-comment US.  Then restart.  iw reg get should then report being US instead of 00.  The output may be a bit different.

It might look like:

 
country US:
	(2402 - 2472 @ 40), (3, 27)
	(5170 - 5250 @ 40), (3, 17)
	(5250 - 5330 @ 40), (3, 20), DFS
	(5490 - 5600 @ 40), (3, 20), DFS
	(5650 - 5710 @ 40), (3, 20), DFS
	(5735 - 5835 @ 40), (3, 30)

I am not at my wireless machine right now, so I cannot be certain.  See if this makes any difference.

This is problem with my Mint linux laptop and there is no /etc/conf.d/wireless-regdom file.
I tried running iw reg set US and restarted and it's back to 00.
Then I tried running iw reg set US again and restarted wicd daemon but it still has problems with channels higher than 11.

After a bit of googling, it seems using channels higher than 11 is not allowed here?


But in my building, wicd detects channels like 36, 52 sometimes higher than 100.
And although wicd detects them and try to connect to them, it simply cannot connect.

Is there any way of preventing wicd detecting channels higher than 11?

by the way, when I run iwlist wlan0 channel, it shows 32 channels from 1 to 140.

Last edited by sokito (2013-01-16 05:50:28)

Offline

#9 2013-01-16 07:54:13

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,839

Re: wicd, bad password, seems to be related to router channel

Uhmm... why are you asking here if you're using Mint? They have their own forum, you know.

Offline

#10 2013-01-16 08:05:49

sokito
Member
Registered: 2013-01-15
Posts: 6

Re: wicd, bad password, seems to be related to router channel

tomk wrote:

Uhmm... why are you asking here if you're using Mint? They have their own forum, you know.

Sorry I didnt mean to offend anyone here.
I was first googling the problem and found this thread with no reply.
Obviously OP had same problem on Arch linux and I just wanted to report the same problem exist on mint.

Offline

#11 2013-01-16 16:27:03

jwhendy
Member
Registered: 2010-04-01
Posts: 558

Re: wicd, bad password, seems to be related to router channel

@sokito: I don't think it's a big deal and wouldn't worry about posting on Arch's forum. I post in tons of Linux forums other than Arch, though when you run into distro-specific things like file locations, perhaps you can create a new Mint Forum post asking for assistance with the location of of the wireless-regdom file.

Or, assuming you have [s/m]locate installed, you can:

# updatedb
# locate regdom

Or,

# find / -name *regdom*

I just installed crda and will see if this makes any impact. I was the original poster, and will see if this still affects me. Haven't run into it in a really long time, though!

Last edited by jwhendy (2013-01-16 16:27:30)

Offline

#12 2013-01-16 20:04:33

sokito
Member
Registered: 2013-01-15
Posts: 6

Re: wicd, bad password, seems to be related to router channel

jwhendy wrote:

@sokito: I don't think it's a big deal and wouldn't worry about posting on Arch's forum. I post in tons of Linux forums other than Arch, though when you run into distro-specific things like file locations, perhaps you can create a new Mint Forum post asking for assistance with the location of of the wireless-regdom file.

Or, assuming you have [s/m]locate installed, you can:

# updatedb
# locate regdom

Or,

# find / -name *regdom*

I just installed crda and will see if this makes any impact. I was the original poster, and will see if this still affects me. Haven't run into it in a really long time, though!

Thanks I found that in linux Mint regdom is set by /etd/default/crda file.
However setting regulatory domain didn't help.

I also tried 'options 11n_disable=1' but didn't work either.

Interestingly however, I found that unloading the ethernet driver by running 'modprobe -r e1000e' solved the problem.

Offline

#13 2013-01-16 21:38:23

jwhendy
Member
Registered: 2010-04-01
Posts: 558

Re: wicd, bad password, seems to be related to router channel

Interesting! My eth driver is provided by e1000e as well. I haven't rebooted to check if crda settings (after installing, it claimed my country code would be picked up on reboot) have an effect, but will definitely keep that module in mind! What prompted you to try that?

Offline

#14 2013-01-16 21:41:14

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 20,099
Website

Re: wicd, bad password, seems to be related to router channel

jwhendy wrote:

@sokito: I don't think it's a big deal and wouldn't worry about posting on Arch's forum. I post in tons of Linux forums other than Arch, though when you run into distro-specific things like file locations, perhaps you can create a new Mint Forum post asking for assistance with the location of of the wireless-regdom file.

You are mistaken: https://wiki.archlinux.org/index.php/Fo … pport_ONLY

Please ask on the Mint boards: they will be much better placed to assist you with the internals of Mint.

Closing.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Online

Board footer

Powered by FluxBB