You are not logged in.

#1 2013-02-01 11:17:58

kekules_dream
Member
Registered: 2009-05-19
Posts: 94

[SOLVED] wireless networking problem using dd-wrt client bridge mode

I wanted to use an old WRT300N router as a bridge so I flashed it successfully with dd-wrt mini 14929.  Since the instructions for dd-wrt say to set your computer to a static ip and since I knew how to do that already in mac I used an old mac book pro work bought me.  The flashing went perfectly and once I set my mac back to "Using DHCP" I got on my wireless network perfectly.  They way it works on the mac is:  1) you have to be on "Using DHCP" to get internet and 2) you have to be set to a static ip to log in to the router.  Can't do both on any one setting.  All this worked perfectly.

So I unhooked the router and put it upstairs near my wifes arch linux 64 (fully updated) box.  On that machine, which was working before with an old buffalo ethernet bridge, I immediately could access the router settings but can't get any internet.  It acts exactly like the macbook did when it was set to a static ip.  Yet the arch box settings were never changed and it has dhcpcd@.service enabled.

What do I need to change so that the arch machine is able to access the wireless signal rather than the router, which is now fully set up?

Last edited by kekules_dream (2013-02-02 15:02:02)

Offline

#2 2013-02-02 15:01:45

kekules_dream
Member
Registered: 2009-05-19
Posts: 94

Re: [SOLVED] wireless networking problem using dd-wrt client bridge mode

Offline

#3 2013-02-02 16:05:48

felixculpa
Member
From: Alberta, Canada
Registered: 2012-06-12
Posts: 185

Re: [SOLVED] wireless networking problem using dd-wrt client bridge mode

The problem here is that this is an Arch centric board, you won't get very much (if any) help regarding dd-wrt related things here. I know because I tried getting help once as well and got 0 replies.

Offline

#4 2013-10-02 02:16:10

nomorewindows
Member
Registered: 2010-04-03
Posts: 2,973

Re: [SOLVED] wireless networking problem using dd-wrt client bridge mode

There were some responses from the dd-wrt community that you could turn off using dhcp with dnsmasq option would cause it to work, or the dreaded static ip for you and me on linux (but not windows).


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#5 2013-11-10 03:35:24

nomorewindows
Member
Registered: 2010-04-03
Posts: 2,973

Re: [SOLVED] wireless networking problem using dd-wrt client bridge mode

Client bridge doesn't take anything to make happen.  You set for client bridge and dd-wrt practically sets the rest of the options needed to make it work. 

If perhaps, you want to use the dd-wrt as just a port switch and the internet router is actually not directly connected to the dd-wrt these are the options needed to be set in dnsmasq options (local dns and dnsmasq enabled as advised on dd-wrt): (just here for reference):

dhcp-option=6, 208.67.222.222, 208.67.220.220
dhcp-option=option:router, xxx.xxx.xxx.xxx
dhcp-boot=pxelinux.0,pxe-host, xxx.xxx.xxx.xxx

It is confusing to know exactly how to set up the dd-wrt for specific uses. 
Otherwise the dd-wrt router gives its' address for nameserver, and dns, which doesn't work and setting gateway address of another router doesn't pass on correctly to dhcp dd-wrt clients.  This overrides dd-wrt default behaviour.  This is mainly laid out on http://www.dd-wrt.com/wiki/index.php/DN … HCP_server


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

Board footer

Powered by FluxBB