You are not logged in.

#1 2013-02-04 16:31:33

koliasforever
Member
From: greece
Registered: 2009-02-06
Posts: 31

[SOLVED]ath5k channel 12 & 13

Hi. I'm using linux 3.7.5-1. I searched google to find a way to enable channel 12 and 13 (i live in greece so it's legal) and i found a way to make it work . Anyway, the only way to make it work, is by applying this patch https://dev.openwrt.org/browser/branche … ?rev=21649 to the compat-wireless project and install compat-wireless.
  The last time i tried to apply the patch, using patch -p1 <  it said something about offset but the patch succeed anyway. So here is my question. Is there an other way to make ath5k transmit to channel 12 & 13?? I dont want to patch and compile compat-wireless every time i upgrade linux.
Thnx in regard

Last edited by koliasforever (2013-02-15 13:41:24)

Offline

#2 2013-02-04 22:37:53

Strike0
Member
From: Germany
Registered: 2011-09-05
Posts: 1,277

Re: [SOLVED]ath5k channel 12 & 13

HI, Nothing wrong with your question, but I would like to foster you considering to remove the first link you posted and am sure you know why.
What's the output of

iw reg get

and

iw list |grep Frequencies -A 15

when you use the unpatched version?

Offline

#3 2013-02-04 23:44:46

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,436

Re: [SOLVED]ath5k channel 12 & 13

Have you installed crda  ??
Have you configured your /etc/conf.d/wireless-regdom file?

Also, as to Strike0's suggestion, that first link is a little grey.  I am not going to insist you remove it, but *everyone* please consider:
https://wiki.archlinux.org/index.php/Fo … e#Legality

Especially with things like wireless, abuse of the laws controlling the spectrum fuels the anti-Free software arguments.  I understand that this is legal where the OP lives.

Last edited by ewaller (2013-02-04 23:54:27)


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
----
How to Ask Questions the Smart Way

Offline

#4 2013-02-05 17:57:05

koliasforever
Member
From: greece
Registered: 2009-02-06
Posts: 31

Re: [SOLVED]ath5k channel 12 & 13

Strike0 wrote:

HI, Nothing wrong with your question, but I would like to foster you considering to remove the first link you posted and am sure you know why.
What's the output of

iw reg get

and

iw list |grep Frequencies -A 15

when you use the unpatched version?

country 00:
        (2402 - 2472 @ 40), (6, 20)
        (2457 - 2482 @ 40), (6, 20), PASSIVE-SCAN, NO-IBSS
        (2474 - 2494 @ 20), (6, 20), NO-OFDM, PASSIVE-SCAN, NO-IBSS
        (5170 - 5250 @ 40), (6, 20), PASSIVE-SCAN, NO-IBSS
        (5735 - 5835 @ 40), (6, 20), PASSIVE-SCAN, NO-IBSS
        (57240 - 63720 @ 2160), (N/A, 0)
[maria@adsl ~]$ iw list |grep Frequencies -A 15
                Frequencies:
                        * 2412 MHz [1] (20.0 dBm)
                        * 2417 MHz [2] (20.0 dBm)
                        * 2422 MHz [3] (20.0 dBm)
                        * 2427 MHz [4] (20.0 dBm)
                        * 2432 MHz [5] (20.0 dBm)
                        * 2437 MHz [6] (20.0 dBm)
                        * 2442 MHz [7] (20.0 dBm)
                        * 2447 MHz [8] (20.0 dBm)
                        * 2452 MHz [9] (20.0 dBm)
                        * 2457 MHz [10] (20.0 dBm)
                        * 2462 MHz [11] (20.0 dBm)
                        * 2467 MHz [12] (disabled)
                        * 2472 MHz [13] (disabled)
                        * 2484 MHz [14] (disabled)
                Bitrates (non-HT):
--
                Frequencies:
                        * 5040 MHz [8] (disabled)
                        * 5060 MHz [12] (disabled)
                        * 5080 MHz [16] (disabled)
                        * 5180 MHz [36] (20.0 dBm) (passive scanning, no IBSS)
                        * 5200 MHz [40] (20.0 dBm) (passive scanning, no IBSS)
                        * 5220 MHz [44] (20.0 dBm) (passive scanning, no IBSS)
                        * 5240 MHz [48] (20.0 dBm) (passive scanning, no IBSS)
                        * 5260 MHz [52] (disabled)
                        * 5280 MHz [56] (disabled)
                        * 5300 MHz [60] (disabled)
                        * 5320 MHz [64] (disabled)
                        * 5500 MHz [100] (disabled)
                        * 5520 MHz [104] (disabled)
                        * 5540 MHz [108] (disabled)                                                                                                          
                        * 5560 MHz [112] (disabled)    

Offline

#5 2013-02-05 18:17:45

koliasforever
Member
From: greece
Registered: 2009-02-06
Posts: 31

Re: [SOLVED]ath5k channel 12 & 13

ewaller wrote:

Have you installed crda  ??
Have you configured your /etc/conf.d/wireless-regdom file?

Also, as to Strike0's suggestion, that first link is a little grey.  I am not going to insist you remove it, but *everyone* please consider:
https://wiki.archlinux.org/index.php/Fo … e#Legality

Especially with things like wireless, abuse of the laws controlling the spectrum fuels the anti-Free software arguments.  I understand that this is legal where the OP lives.

Yes, i have installed crda and also configured /etc/conf.d/wireless-regdom. Although i have uncomented the GR in the /etc/conf.d/wireless-regdom crda is calling country 00. Acording to the first grey link, i have changed country 00 settings in the source code file, with this

(2402 - 2494 @ 40), (5, 35)
	(4910 - 5835 @ 40), (N/A, 35)

. But this is not enough to enable channel 12 & 13, i also have to apply the patch, then channels 12 and 13 are enabled.
I think the source code ath5k driver causes the problems. Maybe it's programed by deafault not to use channel 12 and 13, unless you patch it. By the way, i have a dual boot system with windows vista. The same problem appears in windows. Channel 12 and 13 are disabled.

Last edited by koliasforever (2013-02-05 18:45:03)

Offline

#6 2013-02-05 23:22:41

Strike0
Member
From: Germany
Registered: 2011-09-05
Posts: 1,277

Re: [SOLVED]ath5k channel 12 & 13

The settings you quote in post #5 are not legal in the EU in my understanding. That's why I asked you to reconsider the link in the first place. I'd be happy to learn that they are. Please confirm where you checked them and add a link for that, that would be great. Thanks.

In any case it seems to be a problem with either ath5k in general or (much more likely) the wifi card firmware.
What happens when you manually do a "sudo iw set reg GR" ?

Offline

#7 2013-02-06 10:22:22

koliasforever
Member
From: greece
Registered: 2009-02-06
Posts: 31

Re: [SOLVED]ath5k channel 12 & 13

Strike0 wrote:

The settings you quote in post #5 are not legal in the EU in my understanding. That's why I asked you to reconsider the link in the first place. I'd be happy to learn that they are. Please confirm where you checked them and add a link for that, that would be great. Thanks.

In any case it seems to be a problem with either ath5k in general or (much more likely) the wifi card firmware.
What happens when you manually do a "sudo iw set reg GR" ?

Yes, you are right. The frequency in post 5 is not legal, because it enables channel beyond 12 & 13. But channels 12 & 13 are legal in greece, and i know it because many network providers companies in greece have their wireless routers to channel 12 or 13 by default. I also removed the first link. The sudo iw set reg GR command doesn't work. Maybe you mean sudo iw reg set GR. This command gives me no error output, but nothing happens. Crda still calls country 00. So what should i do now?? Should i inform the developers of ath5k? Should i report it as a bug??

Offline

#8 2013-02-06 19:08:52

Strike0
Member
From: Germany
Registered: 2011-09-05
Posts: 1,277

Re: [SOLVED]ath5k channel 12 & 13

Thanks for re-consideration of the link. Also the 35 inside the brackets should be a 20 for most countries, but I don't know about Greece.
I suppose you could enquire with the ath5k.org mailinglist on the bug, yes. Maybe you find answers on it already; it looks from google like your card is not the only faulty one in that respect.

However, first a couple of more things you can try:
1. There should be an "ath" or "ath_pci" module loaded along with ath5k (I don't have a card to check which; lsmod). You can try modprobing it with your country code, e.g. "modprobe ath_pci countrycode=300" 300 is greece. That hint is from madwifi on ath5k.
2. The user docs there lists a "ar5k" utility to set the regdomain (maybe that info is outdated)
3. An option for the country code can also be tried to be passed to cfg80211 directly (info here)
Good luck.

Offline

#9 2013-02-07 18:58:28

koliasforever
Member
From: greece
Registered: 2009-02-06
Posts: 31

Re: [SOLVED]ath5k channel 12 & 13

Strike0 wrote:

Thanks for re-consideration of the link. Also the 35 inside the brackets should be a 20 for most countries, but I don't know about Greece.
I suppose you could enquire with the ath5k.org mailinglist on the bug, yes. Maybe you find answers on it already; it looks from google like your card is not the only faulty one in that respect.

However, first a couple of more things you can try:
1. There should be an "ath" or "ath_pci" module loaded along with ath5k (I don't have a card to check which; lsmod). You can try modprobing it with your country code, e.g. "modprobe ath_pci countrycode=300" 300 is greece. That hint is from madwifi on ath5k.
2. The user docs there lists a "ar5k" utility to set the regdomain (maybe that info is outdated)
3. An option for the country code can also be tried to be passed to cfg80211 directly (info here)
Good luck.

None of these tips seems to work. Anyway, thnk you all for your effort, i will tell my problem to the developers.

Offline

#10 2013-02-15 13:45:16

koliasforever
Member
From: greece
Registered: 2009-02-06
Posts: 31

Re: [SOLVED]ath5k channel 12 & 13

I solved it. I should have tried harder with ath_info. First i gave this command sudo ath_info  -g 4:0 -w  0xfebf0000 regdomain 68 and then iw reg set GR reboot and everything works without the patch.

Offline

#11 2013-02-15 19:05:39

Strike0
Member
From: Germany
Registered: 2011-09-05
Posts: 1,277

Re: [SOLVED]ath5k channel 12 & 13

Excellent, congrats for tracking that down.

Offline

#12 2013-02-15 19:20:21

koliasforever
Member
From: greece
Registered: 2009-02-06
Posts: 31

Re: [SOLVED]ath5k channel 12 & 13

Strike0 wrote:

Excellent, congrats for tracking that down.

I didn't do it all my self. One of the madwifi developers in Greece helped me.

Offline

Board footer

Powered by FluxBB