You are not logged in.

#1 2013-02-05 18:52:03

fungiscience
Member
Registered: 2013-02-05
Posts: 2

[SOLVED] Updating a Xen build (2011.08.19) and glibc errors

Hello,

I recently purchased a VPS to run some dev stuff on it. The only builds offered were Arch Linux 2011.08.19 32 bit and an older build. I came across multiple problems trying to upgrade (glibc compatibilities, /blablabla already in filesytem, conflicts, etc...) and I have been trying multiple solutions provided on the forums, the news section and the wiki. I also tried this : https://wiki.archlinux.org/index.php/Vi … ate_Server which seems to be close enough to what I was attempting. Unfortunately, came to the same problems as soon as I hit a step involving "pacman -S".

Anyway, figured I might as well not upgrade and just install what I need. Got some python script to run with python2, but as soon as I run it (after installing python2) I get a "GLIBC_2.15" not found.
Here's what I get when querying pacman:

pacman -Q glibc
glibc 2.14-4

So I guess there is no other way but to figure out how to upgrade uh? No way to just install glibc 2.15?
If not, is there a guide out there to help noobs like me upgrade a VPS Arch build to date? Information is scattered all around on forums, wiki and news section and I'm not always sure which step should be done first. Unfortunately, I just had to break and re-install my system multiple times, so any guidelines would be greatly appreciated. Thanks very much! No hate please...if I come here it means I have read/tried alot of stuff first wink

EDIT:
Ok I guess I should put in some details. Here it is step by step following this guide: https://wiki.archlinux.org/index.php/Vi … ate_Server
(after setuping the pacman mirrors)

# pacman -Syy
:: Synchronizing package databases...
 core                                                                                                               105.2K 1087.9K/s 00:00:00 [######################################################################################] 100%
 extra                                                                                                             1416.1K 1770.2K/s 00:00:01 [######################################################################################] 100%
 community                                                                                                         1917.6K 1905.0K/s 00:00:01 [######################################################################################] 100%
# wget http://busybox.net/downloads/binaries/latest/busybox-i686
--2013-02-05 11:14:24--  http://busybox.net/downloads/binaries/latest/busybox-i686
Resolving busybox.net... 140.211.167.224
Connecting to busybox.net|140.211.167.224|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 878344 (858K) [text/plain]
Saving to: `busybox-i686'

100%[=================================================================================================================================================================================================>] 878,344      978K/s   in 0.9s

2013-02-05 11:14:25 (978 KB/s) - `busybox-i686' saved [878344/878344]

# chmod +x busybox-i686
# pacman -Qo /lib/* | cut -d' ' -f 5 | egrep -v 'glibc' | uniq | xargs
error: cannot determine ownership of directory '/lib/device-mapper'
error: cannot determine ownership of directory '/lib/firmware'
error: cannot determine ownership of directory '/lib/initcpio'
error: cannot determine ownership of directory '/lib/modprobe.d'
error: cannot determine ownership of directory '/lib/modules'
error: cannot determine ownership of directory '/lib/security'
error: cannot determine ownership of directory '/lib/systemd'
error: cannot determine ownership of directory '/lib/udev'
acl attr util-linux bzip2 libcap e2fsprogs cryptsetup lvm2 device-mapper e2fsprogs libgcrypt libgpg-error udev xfsprogs readline keyutils lvm2 util-linux ncurses pam pcre popt procps readline shadow e2fsprogs sysfsutils udev util-linux
# pacman -S acl attr util-linux bzip2 libcap e2fsprogs cryptsetup lvm2 device-mapper e2fsprogs libgcrypt libgpg-error udev xfsprogs readline keyutils lvm2 util-linux ncurses pam pcre popt procps readline shadow e2fsprogs sysfsutils udev util-linux
:: The following packages should be upgraded first :
    pacman
:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n] n

warning: skipping target: e2fsprogs
warning: skipping target: lvm2
warning: skipping target: util-linux
warning: skipping target: readline
warning: skipping target: e2fsprogs
warning: skipping target: systemd
warning: skipping target: util-linux
resolving dependencies...
looking for inter-conflicts...
:: kmod and module-init-tools are in conflict. Remove module-init-tools? [y/N] y
:: systemd and udev are in conflict. Remove udev? [y/N] y
:: procps-ng and procps are in conflict. Remove procps? [y/N] y

Remove (3): module-init-tools-3.16-1  udev-173-3  procps-3.2.8-4

Total Removed Size:   3.32 MB

Targets (25): attr-2.4.46-2  acl-2.2.51-3  pambase-20130113-1  pam-1.1.6-1  shadow-4.1.5.1-4  util-linux-2.22.2-1  bzip2-1.0.6-4  libcap-2.22-3  e2fsprogs-1.42.6-1  libgpg-error-1.10-2  libgcrypt-1.5.0-3  kmod-12-1  hwids-20121203-1
              systemd-197-4  device-mapper-2.02.98-1  popt-1.16-5  cryptsetup-1.5.1-1  ncurses-5.9-4  readline-6.2.004-1  lvm2-2.02.98-1  xfsprogs-3.1.10-1  keyutils-1.5.5-3  pcre-8.32-1  procps-ng-3.3.5-1  sysfsutils-2.1.0-8

Total Download Size:    0.00 MB
Total Installed Size:   62.16 MB

Proceed with installation? [Y/n] Y
(25/25) checking package integrity                                                                                                            [######################################################################################] 100%
(25/25) checking for file conflicts                                                                                                           [######################################################################################] 100%
error: failed to commit transaction (conflicting files)
util-linux: /bin/mountpoint exists in filesystem
util-linux: /bin/su exists in filesystem
util-linux: /etc/pam.d/su exists in filesystem
util-linux: /sbin/sulogin exists in filesystem
util-linux: /usr/bin/mesg exists in filesystem
util-linux: /usr/bin/utmpdump exists in filesystem
util-linux: /usr/bin/wall exists in filesystem
util-linux: /usr/share/man/man1/mesg.1.gz exists in filesystem
util-linux: /usr/share/man/man1/mountpoint.1.gz exists in filesystem
util-linux: /usr/share/man/man1/su.1.gz exists in filesystem
util-linux: /usr/share/man/man1/utmpdump.1.gz exists in filesystem
util-linux: /usr/share/man/man1/wall.1.gz exists in filesystem
util-linux: /usr/share/man/man8/sulogin.8.gz exists in filesystem
hwids: /usr/share/hwdata/pci.ids exists in filesystem
hwids: /usr/share/hwdata/usb.ids exists in filesystem
Errors occurred, no packages were upgraded.

Searching for "util-linux: /bin/mountpoint exists in filesystem" I found this: https://bbs.archlinux.org/viewtopic.php?id=139229

# pacman -Syu sysvinit
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community                                                                                                         1917.8K    2.0M/s 00:00:01 [######################################################################################] 100%
:: The following packages should be upgraded first :
    pacman
:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n] n

:: Starting full system upgrade...
:: Replace dbus-core with core/dbus? [Y/n] y
:: Replace kernel26-lts with core/linux-lts? [Y/n] y
:: Replace kernel26-lts-headers with core/linux-lts-headers? [Y/n] y
:: Replace libusb with core/libusbx? [Y/n] y
:: Replace module-init-tools with core/kmod? [Y/n] y
:: Replace procps with core/procps-ng? [Y/n] y
:: Replace udev with core/systemd? [Y/n] y
resolving dependencies...
looking for inter-conflicts...

Remove (7): dbus-core-1.4.14-1  module-init-tools-3.16-1  udev-173-3  kernel26-lts-2.6.32.45-1  kernel26-lts-headers-2.6.32.45-1  libusb-1.0.8-1  procps-3.2.8-4

Total Removed Size:   85.18 MB

Targets (130): linux-api-headers-3.7.4-1  tzdata-2012j-1  iana-etc-2.30-3  filesystem-2013.01-3  glibc-2.17-3  ncurses-5.9-4  readline-6.2.004-1  bash-4.2.042-3  gcc-libs-4.7.2-4  db-5.3.21-1  zlib-1.2.7-1  cracklib-2.8.22-1
               libgssglue-0.4-1  libtirpc-0.2.2-4  pambase-20130113-1  pam-1.1.6-1  attr-2.4.46-2  acl-2.2.51-3  gmp-5.1.0-1  libcap-2.22-3  coreutils-8.20-1  shadow-4.1.5.1-4  util-linux-2.22.2-1  gawk-4.0.2-1  sysvinit-tools-2.88-9
               sysvinit-2.88-9  binutils-2.23.1-3  bzip2-1.0.6-4  run-parts-4.3.4-1  cronie-1.4.9-2  libgpg-error-1.10-2  libgcrypt-1.5.0-3  expat-2.1.0-1  dbus-1.6.8-6  pcre-8.32-1  libffi-3.0.11-1  glib2-2.34.3-1  kbd-1.15.5-3
               kmod-12-1  hwids-20121203-1  xz-5.0.4-1  systemd-197-4  device-mapper-2.02.98-1  popt-1.16-5  cryptsetup-1.5.1-1  dhcpcd-5.6.4-1  diffutils-3.2-1  e2fsprogs-1.42.6-1  eventlog-0.2.12-3  file-5.11-2  findutils-4.4.2-5
               gdbm-1.10-1  gettext-0.18.2-1  gpm-1.20.7-1  grep-2.14-2  perl-5.16.2-2  gzip-1.5-2  texinfo-4.13a-8  groff-1.21-2  openssl-1.0.1.c-1  libsasl-2.1.23-9  libldap-2.4.33-3  keyutils-1.5.5-3  krb5-1.11-2
               heirloom-mailx-12.5-3  inetutils-1.9.1-4  iptables-1.4.16.3-1  iproute2-3.6.0-2  sysfsutils-2.1.0-8  iputils-20121221-1  jfsutils-1.1.15-3  linux-firmware-20121118-1  mkinitcpio-busybox-1.20.2-1  libarchive-3.0.4-2
               mkinitcpio-0.13.0-1  linux-lts-3.0.61-1  linux-lts-headers-3.0.61-1  less-451-1  libedit-20120601_3.0-1  libnl-3.2.11-1  libusbx-1.0.14-1  libpcap-1.3.0-1  libpipeline-1.2.2-1  libusb-compat-0.1.4-2  licenses-20130203-1
               links-2.7-1  linux-3.7.5-1  logrotate-3.8.2-2  lvm2-2.02.98-1  man-db-2.6.3-1  man-pages-3.46-1  mdadm-3.2.6-1  mkinitcpio-nfs-utils-0.3-4  nano-2.2.6-2  netcfg-3.0-1  net-tools-1.60.20120804git-2
               dnssec-anchors-20120422-1  ldns-1.6.16-1  openssh-6.1p1-4  sed-4.2.2-2  ca-certificates-20130119-1  libssh2-1.4.3-1  curl-7.28.1-1  pth-2.0.7-4  libksba-1.2.0-3  libassuan-2.0.3-1  pinentry-0.8.2-1  dirmngr-1.1.0-4
               gnupg-2.0.19-5  gpgme-1.3.1-5  pacman-mirrorlist-20130203-1  archlinux-keyring-20130127-1  pacman-4.0.3-5  pciutils-3.1.10-1  pcmciautils-018-6  ppp-2.4.5-5  procps-ng-3.3.5-1  psmisc-22.19-1  reiserfsprogs-3.6.22-1
               sudo-1.8.6.p6-1  syslinux-4.06-1  syslog-ng-3.3.7-1  tar-1.26-2  usbutils-006-1  vi-1:050325-3  libidn-1.25-1  wget-1.14-2  which-2.20-6  wpa_supplicant-2.0-1  xfsprogs-3.1.10-1

Total Download Size:    164.71 MB
Total Installed Size:   563.50 MB

Proceed with installation? [Y/n] y
:: Retrieving packages from core...
 linux-api-headers-3.7.4-1-i686                                                                                     614.8K    2.5M/s 00:00:00 [######################################################################################] 100%
 tzdata-2012j-1-any                                                                                                 140.1K 1136.3K/s 00:00:00 [######################################################################################] 100%
 iana-etc-2.30-3-any                                                                                                319.8K 1411.2K/s 00:00:00 [######################################################################################] 100%
 filesystem-2013.01-3-i686                                                                                            5.8K  145.1K/s 00:00:00 [######################################################################################] 100%
 glibc-2.17-3-i686                                                                                                    7.6M    2.3M/s 00:00:03 [######################################################################################] 100%
 bash-4.2.042-3-i686                                                                                                774.7K 1734.5K/s 00:00:00 [######################################################################################] 100%
 gcc-libs-4.7.2-4-i686                                                                                              813.2K 1718.2K/s 00:00:00 [######################################################################################] 100%
 db-5.3.21-1-i686                                                                                                  1427.7K 1862.3K/s 00:00:01 [######################################################################################] 100%
 zlib-1.2.7-1-i686                                                                                                   91.6K  886.2K/s 00:00:00 [######################################################################################] 100%
 cracklib-2.8.22-1-i686                                                                                             238.7K 1234.8K/s 00:00:00 [######################################################################################] 100%
 libgssglue-0.4-1-i686                                                                                               33.4K  417.3K/s 00:00:00 [######################################################################################] 100%
 libtirpc-0.2.2-4-i686                                                                                              179.2K 1195.0K/s 00:00:00 [######################################################################################] 100%
 gmp-5.1.0-1-i686                                                                                                   517.2K 1583.5K/s 00:00:00 [######################################################################################] 100%
 coreutils-8.20-1-i686                                                                                                2.0M 2008.1K/s 00:00:01 [######################################################################################] 100%
 gawk-4.0.2-1-i686                                                                                                  764.8K    2.8M/s 00:00:00 [######################################################################################] 100%
 sysvinit-tools-2.88-9-i686                                                                                          25.3K  422.1K/s 00:00:00 [######################################################################################] 100%
 sysvinit-2.88-9-i686                                                                                                41.3K  619.1K/s 00:00:00 [######################################################################################] 100%
 binutils-2.23.1-3-i686                                                                                               3.5M    2.1M/s 00:00:02 [######################################################################################] 100%
 run-parts-4.3.4-1-i686                                                                                              19.0K  406.5K/s 00:00:00 [######################################################################################] 100%
 cronie-1.4.9-2-i686                                                                                                 56.6K  653.6K/s 00:00:00 [######################################################################################] 100%
 expat-2.1.0-1-i686                                                                                                 114.2K 1038.2K/s 00:00:00 [######################################################################################] 100%
 dbus-1.6.8-6-i686                                                                                                  423.5K 1568.6K/s 00:00:00 [######################################################################################] 100%
 libffi-3.0.11-1-i686                                                                                                32.5K  442.8K/s 00:00:00 [######################################################################################] 100%
 glib2-2.34.3-1-i686                                                                                               1891.9K 1984.6K/s 00:00:01 [######################################################################################] 100%
 kbd-1.15.5-3-i686                                                                                                 1020.9K 1845.2K/s 00:00:01 [######################################################################################] 100%
 xz-5.0.4-1-i686                                                                                                    246.5K 1395.3K/s 00:00:00 [######################################################################################] 100%
 dhcpcd-5.6.4-1-i686                                                                                                 73.1K  812.6K/s 00:00:00 [######################################################################################] 100%
 diffutils-3.2-1-i686                                                                                               216.4K 1248.7K/s 00:00:00 [######################################################################################] 100%
 file-5.11-2-i686                                                                                                   212.3K 1354.9K/s 00:00:00 [######################################################################################] 100%
 findutils-4.4.2-5-i686                                                                                             336.2K 1601.2K/s 00:00:00 [######################################################################################] 100%
 gdbm-1.10-1-i686                                                                                                    86.6K  927.9K/s 00:00:00 [######################################################################################] 100%
 gettext-0.18.2-1-i686                                                                                                2.1M 1944.9K/s 00:00:01 [######################################################################################] 100%
 gpm-1.20.7-1-i686                                                                                                  126.0K  900.0K/s 00:00:00 [######################################################################################] 100%
 grep-2.14-2-i686                                                                                                   191.6K 1149.7K/s 00:00:00 [######################################################################################] 100%
 perl-5.16.2-2-i686                                                                                                  12.0M    2.5M/s 00:00:05 [######################################################################################] 100%
 gzip-1.5-2-i686                                                                                                     72.2K  802.8K/s 00:00:00 [######################################################################################] 100%
 texinfo-4.13a-8-i686                                                                                               659.7K 1903.1K/s 00:00:00 [######################################################################################] 100%
 groff-1.21-2-i686                                                                                                 1615.7K    2.1M/s 00:00:01 [######################################################################################] 100%
 openssl-1.0.1.c-1-i686                                                                                               2.5M    2.1M/s 00:00:01 [######################################################################################] 100%
 libsasl-2.1.23-9-i686                                                                                              115.4K 1018.5K/s 00:00:00 [######################################################################################] 100%
 libldap-2.4.33-3-i686                                                                                              401.2K 1383.4K/s 00:00:00 [######################################################################################] 100%
 krb5-1.11-2-i686                                                                                                  1060.5K 1976.3K/s 00:00:01 [######################################################################################] 100%
 heirloom-mailx-12.5-3-i686                                                                                         197.1K 1285.6K/s 00:00:00 [######################################################################################] 100%
 inetutils-1.9.1-4-i686                                                                                             234.2K 1351.2K/s 00:00:00 [######################################################################################] 100%
 iptables-1.4.16.3-1-i686                                                                                           237.5K 1272.7K/s 00:00:00 [######################################################################################] 100%
 iproute2-3.6.0-2-i686                                                                                              424.8K 1517.2K/s 00:00:00 [######################################################################################] 100%
 iputils-20121221-1-i686                                                                                             68.2K  705.3K/s 00:00:00 [######################################################################################] 100%
 jfsutils-1.1.15-3-i686                                                                                             169.1K 1079.4K/s 00:00:00 [######################################################################################] 100%
 linux-firmware-20121118-1-any                                                                                       15.7M    2.9M/s 00:00:05 [######################################################################################] 100%
 mkinitcpio-busybox-1.20.2-1-i686                                                                                   156.5K 1145.5K/s 00:00:00 [######################################################################################] 100%
 libarchive-3.0.4-2-i686                                                                                            633.5K 1682.0K/s 00:00:00 [######################################################################################] 100%
 mkinitcpio-0.13.0-1-any                                                                                             29.6K  443.3K/s 00:00:00 [######################################################################################] 100%
 linux-lts-3.0.61-1-i686                                                                                             38.5M    4.1M/s 00:00:09 [######################################################################################] 100%
 linux-lts-headers-3.0.61-1-i686                                                                                      4.4M    2.8M/s 00:00:02 [######################################################################################] 100%
 less-451-1-i686                                                                                                     88.4K  914.2K/s 00:00:00 [######################################################################################] 100%
 libedit-20120601_3.0-1-i686                                                                                         88.8K  859.4K/s 00:00:00 [######################################################################################] 100%
 libnl-3.2.11-1-i686                                                                                                198.8K 1296.5K/s 00:00:00 [######################################################################################] 100%
 libusbx-1.0.14-1-i686                                                                                               40.4K  576.9K/s 00:00:00 [######################################################################################] 100%
 libpcap-1.3.0-1-i686                                                                                               191.4K 1511.4K/s 00:00:00 [######################################################################################] 100%
 libpipeline-1.2.2-1-i686                                                                                            32.6K  574.9K/s 00:00:00 [######################################################################################] 100%
 libusb-compat-0.1.4-2-i686                                                                                          10.4K  388.9K/s 00:00:00 [######################################################################################] 100%
 licenses-20130203-1-any                                                                                             59.4K  685.7K/s 00:00:00 [######################################################################################] 100%
 links-2.7-1-i686                                                                                                  1848.4K 1716.9K/s 00:00:01 [######################################################################################] 100%
 linux-3.7.5-1-i686                                                                                                  42.8M    3.0M/s 00:00:14 [######################################################################################] 100%
 logrotate-3.8.2-2-i686                                                                                              28.8K  411.7K/s 00:00:00 [######################################################################################] 100%
 man-db-2.6.3-1-i686                                                                                                344.7K 1590.9K/s 00:00:00 [######################################################################################] 100%
 man-pages-3.46-1-any                                                                                                 4.4M    3.7M/s 00:00:01 [######################################################################################] 100%
 mdadm-3.2.6-1-i686                                                                                                 266.5K 1332.8K/s 00:00:00 [######################################################################################] 100%
 mkinitcpio-nfs-utils-0.3-4-i686                                                                                     15.3K  218.2K/s 00:00:00 [######################################################################################] 100%
 nano-2.2.6-2-i686                                                                                                  294.8K 1228.4K/s 00:00:00 [######################################################################################] 100%
 netcfg-3.0-1-any                                                                                                    29.6K  369.4K/s 00:00:00 [######################################################################################] 100%
 net-tools-1.60.20120804git-2-i686                                                                                  113.4K  895.2K/s 00:00:00 [######################################################################################] 100%
 dnssec-anchors-20120422-1-any                                                                                        1.1K  111.7K/s 00:00:00 [######################################################################################] 100%
 ldns-1.6.16-1-i686                                                                                                 395.5K 1648.0K/s 00:00:00 [######################################################################################] 100%
 openssh-6.1p1-4-i686                                                                                               529.5K 1357.8K/s 00:00:00 [######################################################################################] 100%
 sed-4.2.2-2-i686                                                                                                   118.0K  983.1K/s 00:00:00 [######################################################################################] 100%
 ca-certificates-20130119-1-any                                                                                     133.4K 1111.4K/s 00:00:00 [######################################################################################] 100%
 libssh2-1.4.3-1-i686                                                                                               202.1K 1188.9K/s 00:00:00 [######################################################################################] 100%
 curl-7.28.1-1-i686                                                                                                 574.1K 1472.2K/s 00:00:00 [######################################################################################] 100%
 pth-2.0.7-4-i686                                                                                                    76.2K  816.1K/s 00:00:00 [######################################################################################] 100%
 libksba-1.2.0-3-i686                                                                                               111.6K  956.5K/s 00:00:00 [######################################################################################] 100%
 libassuan-2.0.3-1-i686                                                                                              77.1K  701.3K/s 00:00:00 [######################################################################################] 100%
 pinentry-0.8.2-1-i686                                                                                               93.6K  826.1K/s 00:00:00 [######################################################################################] 100%
 dirmngr-1.1.0-4-i686                                                                                               161.9K 1055.7K/s 00:00:00 [######################################################################################] 100%
 gnupg-2.0.19-5-i686                                                                                               1416.2K 1634.2K/s 00:00:01 [######################################################################################] 100%
 gpgme-1.3.1-5-i686                                                                                                 207.1K 1002.1K/s 00:00:00 [######################################################################################] 100%
 pacman-mirrorlist-20130203-1-any                                                                                     2.3K    0.0K/s 00:00:00 [######################################################################################] 100%
 archlinux-keyring-20130127-1-any                                                                                   344.4K 1259.9K/s 00:00:00 [######################################################################################] 100%
 pacman-4.0.3-5-i686                                                                                                522.9K 1318.4K/s 00:00:00 [######################################################################################] 100%
 pciutils-3.1.10-1-i686                                                                                              82.1K  849.3K/s 00:00:00 [######################################################################################] 100%
 pcmciautils-018-6-i686                                                                                              17.8K  314.0K/s 00:00:00 [######################################################################################] 100%
 ppp-2.4.5-5-i686                                                                                                   263.8K 1084.0K/s 00:00:00 [######################################################################################] 100%
 psmisc-22.19-1-i686                                                                                                 83.7K  837.4K/s 00:00:00 [######################################################################################] 100%
 reiserfsprogs-3.6.22-1-i686                                                                                        214.4K 1020.9K/s 00:00:00 [######################################################################################] 100%
 sudo-1.8.6.p6-1-i686                                                                                               567.3K 1361.6K/s 00:00:00 [######################################################################################] 100%
 syslinux-4.06-1-i686                                                                                               786.4K 1697.3K/s 00:00:00 [######################################################################################] 100%
 tar-1.26-2-i686                                                                                                    560.6K 1462.6K/s 00:00:00 [######################################################################################] 100%
 usbutils-006-1-i686                                                                                                 50.6K  523.3K/s 00:00:00 [######################################################################################] 100%
 vi-1:050325-3-i686                                                                                                 131.6K  858.3K/s 00:00:00 [######################################################################################] 100%
 which-2.20-6-i686                                                                                                   13.5K  289.1K/s 00:00:00 [######################################################################################] 100%
 wpa_supplicant-2.0-1-i686                                                                                          470.3K 1128.8K/s 00:00:00 [######################################################################################] 100%
:: Retrieving packages from extra...
 eventlog-0.2.12-3-i686                                                                                              14.1K  191.8K/s 00:00:00 [######################################################################################] 100%
 syslog-ng-3.3.7-1-i686                                                                                             349.8K 1362.8K/s 00:00:00 [######################################################################################] 100%
 libidn-1.25-1-i686                                                                                                 183.6K 1001.3K/s 00:00:00 [######################################################################################] 100%
 wget-1.14-2-i686                                                                                                   451.1K 1520.7K/s 00:00:00 [######################################################################################] 100%
(130/130) checking package integrity                                                                                                          [######################################################################################] 100%
(130/130) checking for file conflicts                                                                                                         [######################################################################################] 100%
error: failed to commit transaction (conflicting files)
filesystem: /etc/mtab exists in filesystem
filesystem: /etc/profile.d/locale.sh exists in filesystem
filesystem: /lib exists in filesystem
filesystem: /var/run exists in filesystem
Errors occurred, no packages were upgraded.

Searching for "filesystem: /etc/mtab exists in filesystem" I get this: https://bbs.archlinux.org/viewtopic.php?id=132225

# pacman -S filesystem --force
:: The following packages should be upgraded first :
    pacman
:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n] n

resolving dependencies...
looking for inter-conflicts...

Targets (1): filesystem-2013.01-3

Total Download Size:    0.00 MB
Total Installed Size:   0.31 MB

Proceed with installation? [Y/n]
(1/1) checking package integrity                                                                                                              [######################################################################################] 100%
(1/1) upgrading filesystem                                                                                                                    [######################################################################################] 100%
warning: /etc/gshadow installed as /etc/gshadow.pacnew
warning: /etc/passwd installed as /etc/passwd.pacnew
warning: /etc/group installed as /etc/group.pacnew
warning: /etc/fstab installed as /etc/fstab.pacnew
warning: /etc/shadow installed as /etc/shadow.pacnew
error: extract: not overwriting dir with file lib
warning: directory permissions differ on sys/
filesystem: 755  package: 555
error: extract: not overwriting dir with file var/run
error: problem occurred while upgrading filesystem
error: could not commit transaction
error: failed to commit transaction (transaction aborted)
Errors occurred, no packages were upgraded.

To deal with this I install vim to merge the pacnew files:

# pacman -S vim
:: The following packages should be upgraded first :
    pacman
:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n] n

resolving dependencies...
looking for inter-conflicts...

Targets (2): vim-runtime-7.3.754-1  vim-7.3.754-1

Total Download Size:    5.19 MB
Total Installed Size:   27.70 MB

Proceed with installation? [Y/n]
:: Retrieving packages from extra...
 vim-runtime-7.3.754-1-i686                                                                                           4.3M    2.4M/s 00:00:02 [######################################################################################] 100%
 vim-7.3.754-1-i686                                                                                                 919.5K 1902.5K/s 00:00:00 [######################################################################################] 100%
(2/2) checking package integrity                                                                                                              [######################################################################################] 100%
(2/2) checking for file conflicts                                                                                                             [######################################################################################] 100%
(1/2) installing vim-runtime                                                                                                                  [######################################################################################] 100%
(2/2) installing vim                                                                                                                          [######################################################################################] 100%
# vimdiff /etc/gshadow /etc/gshadow.pacnew
vimdiff: /lib/libc.so.6: version `GLIBC_2.15' not found (required by vimdiff)

Not sure where to go from here (circular dependency)...Trying full upgrade again(sorry lost part of the dump since my buffer is too small :S):

( 11/129) upgrading bzip2                                                                                                                     [######################################################################################] 100%
( 12/129) upgrading gcc-libs                                                                                                                  [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
( 13/129) upgrading db                                                                                                                        [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
( 14/129) upgrading cracklib                                                                                                                  [######################################################################################] 100%
( 15/129) upgrading libgssglue                                                                                                                [######################################################################################] 100%
( 16/129) upgrading libtirpc                                                                                                                  [######################################################################################] 100%
( 17/129) installing pambase                                                                                                                  [######################################################################################] 100%
( 18/129) upgrading pam                                                                                                                       [######################################################################################] 100%
( 19/129) upgrading gmp                                                                                                                       [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
( 20/129) upgrading libcap                                                                                                                    [######################################################################################] 100%
( 21/129) upgrading coreutils                                                                                                                 [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
( 22/129) upgrading run-parts                                                                                                                 [######################################################################################] 100%
( 23/129) upgrading cronie                                                                                                                    [######################################################################################] 100%
New optional dependencies for cronie
    pm-utils: defer anacron on battery power
    smtp-forwarder: forward job output to email server
    smtp-server: send job output via email
( 24/129) upgrading libgpg-error                                                                                                              [######################################################################################] 100%
( 25/129) upgrading libgcrypt                                                                                                                 [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
( 26/129) upgrading shadow                                                                                                                    [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
( 27/129) upgrading util-linux                                                                                                                [######################################################################################] 100%
warning: /etc/pam.d/login installed as /etc/pam.d/login.pacnew
call to execv failed (No such file or directory)
error: command failed to execute correctly
( 28/129) upgrading expat                                                                                                                     [######################################################################################] 100%
( 29/129) installing dbus                                                                                                                     [######################################################################################] 100%
Optional dependencies for dbus
    libx11: dbus-launch support
( 30/129) upgrading pcre                                                                                                                      [######################################################################################] 100%
( 31/129) installing libffi                                                                                                                   [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
( 32/129) upgrading glib2                                                                                                                     [######################################################################################] 100%
New optional dependencies for glib2
    python2: for gdbus-codegen
( 33/129) upgrading kbd                                                                                                                       [######################################################################################] 100%
( 34/129) installing kmod                                                                                                                     [######################################################################################] 100%
( 35/129) installing hwids                                                                                                                    [######################################################################################] 100%
( 36/129) upgrading xz                                                                                                                        [######################################################################################] 100%
( 37/129) installing systemd                                                                                                                  [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
Optional dependencies for systemd
    cryptsetup: required for encrypted block devices
    libmicrohttpd: systemd-journal-gatewayd
    quota-tools: kernel-level quota management
    python: systemd library bindings
    python2-cairo: systemd-analyze
    python2-gobject: systemd-analyze
    systemd-sysvcompat: symlink package to provide sysvinit binaries
( 38/129) upgrading device-mapper                                                                                                             [######################################################################################] 100%
( 39/129) upgrading popt                                                                                                                      [######################################################################################] 100%
( 40/129) upgrading cryptsetup                                                                                                                [######################################################################################] 100%
( 41/129) upgrading dhcpcd                                                                                                                    [######################################################################################] 100%
( 42/129) upgrading diffutils                                                                                                                 [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
( 43/129) upgrading e2fsprogs                                                                                                                 [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
( 44/129) upgrading eventlog                                                                                                                  [######################################################################################] 100%
( 45/129) upgrading file                                                                                                                      [######################################################################################] 100%
( 46/129) upgrading findutils                                                                                                                 [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
( 47/129) upgrading gawk                                                                                                                      [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
( 48/129) upgrading gdbm                                                                                                                      [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
( 49/129) upgrading gettext                                                                                                                   [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
( 50/129) upgrading gpm                                                                                                                       [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
( 51/129) upgrading grep                                                                                                                      [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
( 52/129) upgrading perl                                                                                                                      [######################################################################################] 100%
( 53/129) upgrading gzip                                                                                                                      [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
( 54/129) upgrading texinfo                                                                                                                   [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
( 55/129) upgrading groff                                                                                                                     [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
( 56/129) upgrading openssl                                                                                                                   [######################################################################################] 100%
( 57/129) upgrading libsasl                                                                                                                   [######################################################################################] 100%
( 58/129) upgrading libldap                                                                                                                   [######################################################################################] 100%
( 59/129) upgrading keyutils                                                                                                                  [######################################################################################] 100%
( 60/129) upgrading krb5                                                                                                                      [######################################################################################] 100%
( 61/129) upgrading heirloom-mailx                                                                                                            [######################################################################################] 100%
( 62/129) upgrading iana-etc                                                                                                                  [######################################################################################] 100%
warning: /etc/protocols installed as /etc/protocols.pacnew
warning: /etc/services installed as /etc/services.pacnew
( 63/129) upgrading inetutils                                                                                                                 [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
( 64/129) upgrading iptables                                                                                                                  [######################################################################################] 100%
( 65/129) upgrading iproute2                                                                                                                  [######################################################################################] 100%
( 66/129) upgrading sysfsutils                                                                                                                [######################################################################################] 100%
( 67/129) upgrading iputils                                                                                                                   [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
New optional dependencies for iputils
    xinetd: for tftpd
( 68/129) upgrading jfsutils                                                                                                                  [######################################################################################] 100%
( 69/129) upgrading linux-firmware                                                                                                            [######################################################################################] 100%
( 70/129) upgrading mkinitcpio-busybox                                                                                                        [######################################################################################] 100%
( 71/129) upgrading libarchive                                                                                                                [######################################################################################] 100%
( 72/129) upgrading mkinitcpio                                                                                                                [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
( 73/129) installing linux-lts                                                                                                                [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
Optional dependencies for linux-lts
    crda: to set the correct wireless channels of your country
( 74/129) installing linux-lts-headers                                                                                                        [######################################################################################] 100%
( 75/129) upgrading less                                                                                                                      [######################################################################################] 100%
( 76/129) upgrading libedit                                                                                                                   [######################################################################################] 100%
( 77/129) upgrading libnl                                                                                                                     [######################################################################################] 100%
( 78/129) installing libusbx                                                                                                                  [######################################################################################] 100%
( 79/129) upgrading libpcap                                                                                                                   [######################################################################################] 100%
( 80/129) upgrading libpipeline                                                                                                               [######################################################################################] 100%
( 81/129) upgrading libusb-compat                                                                                                             [######################################################################################] 100%
( 82/129) upgrading licenses                                                                                                                  [######################################################################################] 100%
( 83/129) upgrading links                                                                                                                     [######################################################################################] 100%
( 84/129) upgrading linux                                                                                                                     [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
( 85/129) upgrading logrotate                                                                                                                 [######################################################################################] 100%
New optional dependencies for logrotate
    cron: scheduled log rotation
( 86/129) upgrading lvm2                                                                                                                      [######################################################################################] 100%
( 87/129) upgrading man-db                                                                                                                    [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
( 88/129) upgrading man-pages                                                                                                                 [######################################################################################] 100%
( 89/129) upgrading mdadm                                                                                                                     [######################################################################################] 100%
( 90/129) upgrading mkinitcpio-nfs-utils                                                                                                      [######################################################################################] 100%
( 91/129) upgrading nano                                                                                                                      [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
( 92/129) upgrading netcfg                                                                                                                    [######################################################################################] 100%
New optional dependencies for netcfg
    bridge-utils: for bridge connections
    dialog: for the menu based profile and wifi selectors
    ifenslave: for bond connections
    ifplugd: for automatic wired connections through net-auto-wired
    wireless_tools: for interface renaming through net-rename
    wpa_actiond: for automatic wireless connections through net-auto-wireless
    wpa_supplicant: for wireless networking support
( 93/129) upgrading net-tools                                                                                                                 [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
( 94/129) installing dnssec-anchors                                                                                                           [######################################################################################] 100%
( 95/129) installing ldns                                                                                                                     [######################################################################################] 100%
Optional dependencies for ldns
    libpcap: ldns-dpa tool
( 96/129) upgrading openssh                                                                                                                   [######################################################################################] 100%
New optional dependencies for openssh
    x11-ssh-askpass: input passphrase in X
    xorg-xauth: X11 forwarding
( 97/129) upgrading sed                                                                                                                       [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
( 98/129) installing ca-certificates                                                                                                          [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
( 99/129) installing libssh2                                                                                                                  [######################################################################################] 100%
(100/129) installing curl                                                                                                                     [######################################################################################] 100%
(101/129) installing pth                                                                                                                      [######################################################################################] 100%
(102/129) installing libksba                                                                                                                  [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
(103/129) installing libassuan                                                                                                                [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
(104/129) installing pinentry                                                                                                                 [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
Optional dependencies for pinentry
    gtk2: for gtk2 backend
    qt: for qt4 backend
(105/129) installing dirmngr                                                                                                                  [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
(106/129) installing gnupg                                                                                                                    [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
Optional dependencies for gnupg
    curl: gpg2keys_curl
    libldap: gpg2keys_ldap
    libusb-compat: scdaemon
(107/129) installing gpgme                                                                                                                    [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
(108/129) upgrading pacman-mirrorlist                                                                                                         [######################################################################################] 100%
warning: /etc/pacman.d/mirrorlist installed as /etc/pacman.d/mirrorlist.pacnew
(109/129) installing archlinux-keyring                                                                                                        [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
(110/129) upgrading pacman                                                                                                                    [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
(111/129) upgrading pciutils                                                                                                                  [######################################################################################] 100%
(112/129) upgrading pcmciautils                                                                                                               [######################################################################################] 100%
(113/129) upgrading ppp                                                                                                                       [######################################################################################] 100%
(114/129) installing procps-ng                                                                                                                [######################################################################################] 100%
(115/129) upgrading psmisc                                                                                                                    [######################################################################################] 100%
(116/129) upgrading reiserfsprogs                                                                                                             [######################################################################################] 100%
(117/129) upgrading sudo                                                                                                                      [######################################################################################] 100%
(118/129) upgrading syslinux                                                                                                                  [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
New optional dependencies for syslinux
    gptfdisk: For GPT support
    mtools: For mkdiskimage and syslinux support
    perl-passwd-md5: For md5pass
    util-linux: For isohybrid
(119/129) upgrading syslog-ng                                                                                                                 [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
(120/129) installing sysvinit-tools                                                                                                           [######################################################################################] 100%
(121/129) upgrading sysvinit                                                                                                                  [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
(122/129) upgrading tar                                                                                                                       [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
(123/129) upgrading usbutils                                                                                                                  [######################################################################################] 100%
(124/129) upgrading vi                                                                                                                        [######################################################################################] 100%
New optional dependencies for vi
    heirloom-mailx: used by the preserve command for notification
(125/129) installing libidn                                                                                                                   [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
(126/129) upgrading wget                                                                                                                      [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
(127/129) upgrading which                                                                                                                     [######################################################################################] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
(128/129) upgrading wpa_supplicant                                                                                                            [######################################################################################] 100%
(129/129) upgrading xfsprogs                                                                                                                  [######################################################################################] 100%
[root@vps ~]# pacman -S filesystem --force
-bash: /usr/bin/pacman: No such file or directory

Oups! broken!

Last edited by fungiscience (2013-02-06 19:22:11)

Offline

#2 2013-02-05 22:55:44

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,361
Website

Re: [SOLVED] Updating a Xen build (2011.08.19) and glibc errors

That build is so old, it will be very difficult to update.

Offline

#3 2013-02-06 19:21:33

fungiscience
Member
Registered: 2013-02-05
Posts: 2

Re: [SOLVED] Updating a Xen build (2011.08.19) and glibc errors

So I got pretty far, with pacman4 updated and stuff...still had problems when updating glibc and filesystem which breaks it everytime.
Anyway, I figured out I could boot any iso on this VPS in rescue mode. So imma try to install from the latest build smile
Marking this as solved! Thanks!

Offline

Board footer

Powered by FluxBB