You are not logged in.

#1 2013-02-07 22:39:49

Frezeeer
Member
Registered: 2012-08-10
Posts: 22

[SOLVED] Problem with Networkmanager and two WiFi cards

I have two WiFi cards, one onboard my laptop, one USB. I use the USB one since gets a stronger signal, but the other one tries to connect.
Is there a way of stoping that.
I don't want to cancel the possibility of using it, just when I plug the USB antenna.
Thank you

Last edited by Frezeeer (2013-02-10 20:41:24)

Offline

#2 2013-02-07 22:46:33

progandy
Member
Registered: 2012-05-17
Posts: 2,152

Re: [SOLVED] Problem with Networkmanager and two WiFi cards

Is there an entry for your onboard wifi in rfkill? Then block it when pluggin in the usb stick and unblock it lateron.

Offline

#3 2013-02-09 17:05:22

Frezeeer
Member
Registered: 2012-08-10
Posts: 22

Re: [SOLVED] Problem with Networkmanager and two WiFi cards

progandy wrote:

Is there an entry for your onboard wifi in rfkill? Then block it when pluggin in the usb stick and unblock it lateron.

Thanks for the reply.
This is what I get:

$ rfkill list
0: samsung-wlan: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: samsung-bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: no
2: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
3: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
4: phy1: Wireless LAN
	Soft blocked: no
	Hard blocked: no

If I try to "block" either number 2 or number 4. The WiFi disconects. It's as if they were the same card.
Any ideas?
Once again thank you

Offline

#4 2013-02-09 17:13:58

debijan
Member
Registered: 2010-09-14
Posts: 36

Re: [SOLVED] Problem with Networkmanager and two WiFi cards

Hi,
you used 2&4 for testing rfkill block? isn't 0 the interface of your internal wlan interface?
i think 2 & 4 are maybe interfaces for your external card which supports 2.4ghz and 5ghz?

Other Options you've:
1. create a udev rule which trigger on plug in of usb pen to force ifconfig wlan0 off
2. i know in network manager of kde is an option to assign specific profiles to dedcated interfaces. so ssid test is only allowed for wlan0 and ssid test2 only allowed for wlan1

Offline

#5 2013-02-10 16:23:01

Frezeeer
Member
Registered: 2012-08-10
Posts: 22

Re: [SOLVED] Problem with Networkmanager and two WiFi cards

Debijan,

I get the same results if I block number 0.
The WiFi just disconects, Both cards.
I use Gnome3, with network-manager

Offline

#6 2013-02-10 19:08:25

rfk1ll
Member
Registered: 2013-02-01
Posts: 24

Re: [SOLVED] Problem with Networkmanager and two WiFi cards

Have you tried :

sudo ifconfig (device name ) down

Just run ifconfig from a terminal, find the name of your wireless device you want to shut off, say wlan0 , then

sudo ifconfig wlan0 down

Use the same command with up to bring it back up.

Last edited by rfk1ll (2013-02-10 19:16:06)

Offline

#7 2013-02-10 20:38:23

Frezeeer
Member
Registered: 2012-08-10
Posts: 22

Re: [SOLVED] Problem with Networkmanager and two WiFi cards

rfk1ll

That last command did the trick!

 sudo ifconfig wlan0 down

thank you

Offline

#8 2013-02-10 20:59:45

rfk1ll
Member
Registered: 2013-02-01
Posts: 24

Re: [SOLVED] Problem with Networkmanager and two WiFi cards

No problem. The ifconfig/iwconfig/iwlist commands are very helpful. They do much more, just google them for more info.

Last edited by rfk1ll (2013-02-10 21:03:56)

Offline

Board footer

Powered by FluxBB