You are not logged in.

#1 2013-02-08 09:17:25

Xi0N
Member
From: Bilbao - Spain
Registered: 2007-11-29
Posts: 780
Website

Help installing cacti

I'm trying to setup a server with nagios+cacti
I finally ended up installing icinga: Looks awesome....

Now, I'm trying to install cacti but the wiki seems to lack some steps because I followed it step by step but cacti is still not working... when I access http://my_ip/cact , I get a object not found message....

Does anyone know any other (better) guide on how to install this software?

Thanks you very much smile

Offline

#2 2013-02-08 09:47:00

Ashren
Member
From: Denmark
Registered: 2007-06-13
Posts: 1,221
Website

Re: Help installing cacti

Have you set up access to the cacti installation correctly in httpd.conf?

If you are planning to use your LAMP server for more than cacti, I'd recommend using virtual hosts. https://wiki.archlinux.org/index.php/Ap … tual_Hosts

Offline

#3 2013-02-08 09:48:35

Xi0N
Member
From: Bilbao - Spain
Registered: 2007-11-29
Posts: 780
Website

Re: Help installing cacti

Perhap's that's what's missing... I'll have a look into it... thanks for pointing me in the right direction smile


EDIT: I have been trying to figure ot how to do so, but I seem to be incapable of it... can anyone throw me a bone??
Thanks sad

Last edited by Xi0N (2013-02-08 11:26:50)

Offline

#4 2013-02-08 19:54:08

Xi0N
Member
From: Bilbao - Spain
Registered: 2007-11-29
Posts: 780
Website

Re: Help installing cacti

I took this approach instead:
/etc/httpd/conf/extra/cacti.conf

Alias /cacti /usr/share/webapps/cacti

<DirectoryMatch /usr/share/webapps/cacti>
        Options +FollowSymLinks
        AllowOverride None
        order allow,deny
        allow from all
        <IfModule mod_php4.c>
                AddType application/x-httpd-php .php

                php_flag magic_quotes_gpc Off
                php_flag short_open_tag On
                php_flag register_globals Off
                php_flag register_argc_argv On
                php_flag track_vars On
                # this setting is necessary for some locales
                php_value mbstring.func_overload 0
                php_value include_path .

                DirectoryIndex index.php
        </IfModule>
</DirectoryMatch>

Then under /etc/php/php.ini:

open_basedir=...:/usr/share/webapps/cacti

It sees to work although at first on the setup it didn't recognize any of the binaries routes, but after setting them by hand and hitting on continue, it did not complain anymore.....

What do you think about the way I did it?

Thanks!

Offline

#5 2013-02-08 19:57:58

oliver
Member
Registered: 2007-12-12
Posts: 411

Re: Help installing cacti

did you set up your cronjob to run every x minutes?  Anything in the cacti.log file?

Offline

#6 2013-02-08 20:01:16

Xi0N
Member
From: Bilbao - Spain
Registered: 2007-11-29
Posts: 780
Website

Re: Help installing cacti

I Set it to run every 1 minutes and I have some graphs being created regarding localhost...... smile
Now I suppose I will have to move the data from the old debian cacti server to this new one.... I already have a clue on how to do so...
Does the way I configured apache to handle cacti seem correct?

Cheers!

Offline

Board footer

Powered by FluxBB