You are not logged in.

#1 2013-02-08 13:31:28

Registered: 2010-09-14
Posts: 37

[SOLVED] Hostapd doesn't provide a working AP for me

Hi Community :-)
I've setup a archlinux with kernel 3.7.5 and hostapd v2.0 in a kvm vm.
Attached a 802.11n usb pen and moved into the vm. The vm see the device and also hostapd accept to use it.
I first tried with WPA2. Also my smartphone see the WLAN and on triggering it to connect it tries to authenticate and than it get an auth fault
I am struggling with this for a bunch of time now and already tried some things:

So i've tried this without any auth in hostapd now (even no WEP or sth else).
Now my smartphone and notebook (arch linux, same patchlevel) tell me that they're trying to establish the connection and then it fail again.
This is still the configuration. I think it is a good idea to get a connection before introducing support for an authentication.
I've tried the LTS Kernel 3.0.61 -> same issue
Also gave my notebook a fixed IP config: same problem
Moved the usb pen to my notebook with same config (not the lts kernel) to avoid problems with the KVM VM -> same issue.

I've no more ideas and am completly lost :-(

Could somebody help?

Hostapd conf:
hostapd log:
hostapd dump:
iw list:

i wasn't lazy and figured out that the usb pen is able to provide AP function with windows 7 without any problem.
further i've replaced the installation - only for testing purposes ;-) - by a debian stable setup with backported kernel 3.2.0 and experience the same problem as on arch.
So i've started over with the config and cloned config from arch wiki: … cess_Point
Still the same problem.

I begin to expect that it is a driver bug (rt2800usb). But i've no other hardware to verify.

Last edited by debijan (2013-02-10 22:23:02)


#2 2013-02-09 21:49:12

Registered: 2010-09-14
Posts: 37

Re: [SOLVED] Hostapd doesn't provide a working AP for me



#3 2013-02-09 22:07:46

From: Pasadena, CA
Registered: 2009-07-13
Posts: 15,809

Re: [SOLVED] Hostapd doesn't provide a working AP for me

Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
How to Ask Questions the Smart Way


#4 2013-02-09 22:08:19

Registered: 2012-05-17
Posts: 2,888

Re: [SOLVED] Hostapd doesn't provide a working AP for me

I know that this config with WPA2 works for me: … 6#p1224766
When the connection works, then you'll have to set up static ips or a dhcp server and configure your bridge or use NAT routing like me.

| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |


#5 2013-02-09 23:03:11

Registered: 2010-04-03
Posts: 3,137

Re: [SOLVED] Hostapd doesn't provide a working AP for me

Not all wireless hardware supports AP mode.

I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.


#6 2013-02-10 22:22:42

Registered: 2010-09-14
Posts: 37

Re: [SOLVED] Hostapd doesn't provide a working AP for me

it is solved. i said in beginning that i do not think it is the vm because that config isn't working on another system...
however. i've started over with an absolute minimal 3 or 4 lines config on a physical machine which was working fine.
moved that to the vm and i've same issue again :-/ and further i noticed that hostapd needs a lot of more time to initialize.

Has somebody running hostapd in vm's?

thank you all :-)

Last edited by debijan (2013-02-10 22:31:24)


Board footer

Powered by FluxBB