You are not logged in.

#1 2013-02-15 22:52:47

lasse.j5
Member
From: Aarhus, Denmark
Registered: 2009-11-30
Posts: 8

Problem with vsftpd and Windows Explorer as client (No login prompt)

Hi everyone

I have vsftpd running on Arch Linux and i'm having some problems with Windows Explorer as a client.
If enter the login name as part of the address it works fine and prompts me for at password.
Like this: ftp://ftpuser@ftp.mydomain.com

But if i do not get any login prompt if i just enter the address without username: ftp://ftp.mydomain.com
I get this error:

---------------------------
FTP Folder Error
---------------------------
Windows cannot access this folder. Make sure you typed the file name correctly and that you have permission to access the folder.

Details:

---------------------------
OK   
---------------------------

I know this is not directly Linux related. But any help is greatly appreciated.

If i use a dedicated ftp client like filezilla everything works fine.

Output from FileZilla

Status:	Resolving address of ftp.mydomain.com
Status:	Connecting to 87.104.161.163:21...
Status:	Connection established, waiting for welcome message...
Response:	220 (vsFTPd 3.0.2)
Command:	USER ftpuser
Response:	331 Please specify the password.
Command:	PASS *********
Response:	230 Login successful.
Command:	SYST
Response:	215 UNIX Type: L8
Command:	FEAT
Response:	211-Features:
Response:	 EPRT
Response:	 EPSV
Response:	 MDTM
Response:	 PASV
Response:	 REST STREAM
Response:	 SIZE
Response:	 TVFS
Response:	 UTF8
Response:	211 End
Command:	OPTS UTF8 ON
Response:	200 Always in UTF8 mode.
Status:	Connected
Status:	Retrieving directory listing...
Command:	PWD
Response:	257 "/"
Command:	TYPE I
Response:	200 Switching to Binary mode.
Command:	PASV
Response:	227 Entering Passive Mode (87,104,161,163,77,216).
Command:	LIST
Response:	150 Here comes the directory listing.
Response:	226 Directory send OK.
Status:	Directory listing successful

vsftpd.conf

# Example config file /etc/vsftpd.conf
#
# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
#
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
#
# Allow anonymous FTP? (Beware - allowed by default if you comment this out).
anonymous_enable=YES
#
# Uncomment this to allow local users to log in.
local_enable=YES
#
# Uncomment this to enable any form of FTP write command.
write_enable=YES
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
#local_umask=022
#
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
#anon_upload_enable=YES
#
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
#anon_mkdir_write_enable=YES
#
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
dirmessage_enable=YES
#
# Activate logging of uploads/downloads.
xferlog_enable=YES
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
connect_from_port_20=YES
#
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
#chown_uploads=YES
#chown_username=whoever
#
# You may override where the log file goes if you like. The default is shown
# below.
#xferlog_file=/var/log/vsftpd.log
#
# If you want, you can have your log file in standard ftpd xferlog format.
# Note that the default log file location is /var/log/xferlog in this case.
#xferlog_std_format=YES
#
# You may change the default value for timing out an idle session.
#idle_session_timeout=600
#
# You may change the default value for timing out a data connection.
#data_connection_timeout=120
#
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
#nopriv_user=ftpsecure
#
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
#async_abor_enable=YES
#
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that on some FTP servers, ASCII support allows a denial of service
# attack (DoS) via the command "SIZE /big/file" in ASCII mode. vsftpd
# predicted this attack and has always been safe, reporting the size of the
# raw file.
# ASCII mangling is a horrible feature of the protocol.
#ascii_upload_enable=YES
#ascii_download_enable=YES
#
# You may fully customise the login banner string:
#ftpd_banner=Welcome to blah FTP service.
#
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
#deny_email_enable=YES
# (default follows)
#banned_email_file=/etc/vsftpd.banned_emails
#
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
# (Warning! chroot'ing can be very dangerous. If using chroot, make sure that
# the user does not have write access to the top level directory within the
# chroot)
chroot_local_user=YES
chroot_list_enable=YES
# (default follows)
chroot_list_file=/etc/vsftpd.chroot_list
allow_writeable_chroot=YES
#
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
#ls_recurse_enable=YES
#
# When "listen" directive is enabled, vsftpd runs in standalone mode and
# listens on IPv4 sockets. This directive cannot be used in conjunction
# with the listen_ipv6 directive.
listen=YES
#
# This directive enables listening on IPv6 sockets. To listen on IPv4 and IPv6
# sockets, you must run two copies of vsftpd with two configuration files.
# Make sure, that one of the listen options is commented !!
#listen_ipv6=YES

userlist_enable=YES
userlist_file=/etc/vsftpd.user_list
userlist_deny=NO

pasv_min_port=19925
pasv_max_port=19931
pasv_address=87.104.161.163
pasv_enable=YES

Offline

#2 2013-02-15 23:13:20

nomorewindows
Member
Registered: 2010-04-03
Posts: 3,010

Re: Problem with vsftpd and Windows Explorer as client (No login prompt)

If you have SSH daemon running, you could use Filezilla and do a sftp.


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#3 2013-02-16 10:09:05

lasse.j5
Member
From: Aarhus, Denmark
Registered: 2009-11-30
Posts: 8

Re: Problem with vsftpd and Windows Explorer as client (No login prompt)

nomorewindows wrote:

If you have SSH daemon running, you could use Filezilla and do a sftp.

I'm sorry, but you have clearly have not read my post.

Filezilla is already working fine with ftp.

I would like to be able to use Windows Explorer as ftp client.

Not all of the people who are going to use the ftp server are capable of installing a ftp client.
So i would be great if they could just use Windows Explorer.

Offline

#4 2013-02-16 14:01:05

nomorewindows
Member
Registered: 2010-04-03
Posts: 3,010

Re: Problem with vsftpd and Windows Explorer as client (No login prompt)

I haven't used vsftpd, I have used pure-ftpd.  It looks like setting anonymous_enable=NO, and connect_from_port_20=NO, and possibly ascii_upload/download=YES and nopriv_user=ftpuser.
If you can't get windows explorer to work there is always command line ftp.


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#5 2014-03-05 15:06:16

jayclen
Member
Registered: 2014-03-05
Posts: 1

Re: Problem with vsftpd and Windows Explorer as client (No login prompt)

I experienced a similar issue recently. When I was using Internet Explorer 11 to access an FTP URL, such as ftp://ftp.hostname.com, it would not prompt for a username and password. If I used Firefox it worked fine. I figured out the issue in my case. Since I set the vsftpd setting userlist_deny=NO, the file user_list (/etc/vsftpd/user_list) became a file containing a list of users that are allowed to connect to the server. An entry for user "anonymous" had to exist in there for some browsers to work properly, such as Internet Explorer 11. I had to do that even though I don't allow anonymous access by setting anonymous_enable=NO.

The reason is the following. When you use a web browser to connect to an FTP URL, such as ftp://ftp.hostname.com, it will first try to automatically connect as user anonymous. If that user is not explicitly authorized to connect to the vsftpd, which is needed when using userlist_deny=NO, the browser will get a permission denied response. Some browsers don't handle this well, such as Internet Explorer 11. That browser stopped trying to connect immediately so it didn't ask me for a username and password. Once I added user anonymous to the authorized list, instead of the browser receiving a permission denied response it received a response asking for the password of user anonymous. Once the browser couldn't log on automatically as user anonymous it prompted me for a username and password.

Offline

#6 2014-03-05 15:45:03

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,152

Re: Problem with vsftpd and Windows Explorer as client (No login prompt)

Jayclen,
Welcome to Arch Linux and thank you for a good first post.  Your post is relevant, so everything is okay.  Just be careful of old threads.  After more than a year, the original participants probably are not following the thread.

Thanks.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
----
How to Ask Questions the Smart Way

Online

Board footer

Powered by FluxBB