You are not logged in.

#1 2013-02-19 00:55:05

ryan16144
Member
Registered: 2013-02-16
Posts: 17

[SOLVED]Slow Internet

[SOLVED] Disable ipv6 [SOLVED]

Hi, I installed Arch in a VM using VMWare 9 a few days ago.  Everything is going pretty smoothly but I notice that the internet / browsing on this is significantly slower than on my ubuntu VM as well as my windows host machine.  I am pretty noob about networking so I will try my best to include all pertinent information but if I leave something out just say so.

When i say slow, web pages take probably 4 or 5 seconds to load as opposed to 1 second on ubuntu / windows.
Ping MS is generally 2 or 3 times higher as well.
One more thing, when I go to ping addresses it will sometimes hang for 5 or 6 seconds before sending the pings.

Installed on VMWare 9.
using openvpn (ubuntu is also using that)
using a bridged connection via VMWare.

my network service is dhpcd@enp2s1.service

output from ifconfig:

enp2s1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.115  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::20c:29ff:fe00:9710  prefixlen 64  scopeid 0x20<link>
        ether 00:0c:29:00:97:10  txqueuelen 1000  (Ethernet)
        RX packets 141979  bytes 161859593 (154.3 MiB)
        RX errors 0  dropped 32  overruns 0  frame 0
        TX packets 91539  bytes 14644253 (13.9 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 1012  bytes 61199 (59.7 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1012  bytes 61199 (59.7 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

tun0: flags=4305<UP,POINTOPOINT,RUNNING,NOARP,MULTICAST>  mtu 1500
        inet 10.9.1.6  netmask 255.255.255.0  destination 10.9.1.6
        unspec 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  txqueuelen 100  (UNSPEC)
        RX packets 1218  bytes 584982 (571.2 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1817  bytes 118141 (115.3 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

I haven't touched any network config except I added a nameserver to resolv.conf.head

I've tried looking around on the forums but I know next to nothing so I haven't been able to make sense of, or execute any of the suggestions.

Some suggestions say to look at /etc/rc.conf but I do not have that file.

If I left out something important just let me know, thanks in advance for any help!

Last edited by ryan16144 (2013-02-19 01:59:06)

Offline

#2 2013-02-19 01:02:05

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,688
Website

Re: [SOLVED]Slow Internet

Check out the wiki for disabling IPv6 - it sounds like this would be the issue.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#3 2013-02-19 01:11:27

ryan16144
Member
Registered: 2013-02-16
Posts: 17

Re: [SOLVED]Slow Internet

I took a look at that and couldnt figure out how to do the kernel line part. As I said i am a bit of a noob, if you could give me a push in the right direction it would be greatly appreciated.

Offline

#4 2013-02-19 01:18:46

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,688
Website

Re: [SOLVED]Slow Internet

To test it temporarily, try the following in a terminal (as root or with sudo):

sysctl net.ipv6.conf.all.disable_ipv6=1

Then reopen a web browser and see if it's better.  If it is better, then we can worry about adding the kernel parameter to your boot loader to make it permanent, and I'd need to know what boot loader you use.

If this doesn't make it any better, my next suspicion would be your MTU setting which can be found in the output of `ip link`. (edit: oops, you already included this in your first post)  1500 is fairly standard AFAIK, but depending on your setup (router, etc) sometimes this needs to be changed.  But first try the ipv6 check.

(edit: fixed copy/paste error)

Last edited by Trilby (2013-02-19 01:36:20)


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#5 2013-02-19 01:31:05

ryan16144
Member
Registered: 2013-02-16
Posts: 17

Re: [SOLVED]Slow Internet

It's kind of hard to tell but I think it fixed it. (i assume u meant disable.ipv6=1 and not 0.

I use GRUB as my boot loader.

Last edited by ryan16144 (2013-02-19 01:34:50)

Offline

#6 2013-02-19 01:34:34

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,688
Website

Re: [SOLVED]Slow Internet

I've never used grub (only grub-legacy), but this seems pretty straight forward.  Take the kernel parameter from the ipv6 wiki page and put it in /etc/default/grub as described.  I presume you have to rerun the grub-mkconfig command after editing that file.

EDIT: yes, I did mean "...=1" sorry, I copy and pasted from a script of mine to toggle it on demand and I copied the wrong line.

Last edited by Trilby (2013-02-19 01:35:41)


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#7 2013-02-19 01:57:19

ryan16144
Member
Registered: 2013-02-16
Posts: 17

Re: [SOLVED]Slow Internet

Al right, thanks for your help. It seems to be all good now.

Offline

Board footer

Powered by FluxBB