You are not logged in.

#1 2013-02-11 16:27:28

Registered: 2012-10-13
Posts: 108

404 Error when trying to access ~/public_html

Following the instructions of the Arch wiki on installing LAMP, I get a "404 error Object not found" message when trying to access the public_html which it says should be accessible by default, after giving the correct permissions to the directories for the user http to reach there. I can access it after changing the document root in the /etc/httpd/conf/httpd.conf to point to the folder, but I'm wondering if this is the correct way to do it?

Some extra info:
my /etc/httpd/conf/extra/httpd-userdir.conf file:

# Settings for user home directories
# Required module: mod_userdir

# UserDir: The name of the directory that is appended onto a user's home
# directory if a ~user request is received.  Note that you must also set
# the default access control for these directories, as in the example below.
UserDir public_html

# Control access to UserDir directories.  The following is an example
# for a site where these directories are restricted to read-only.
<Directory "/home/anark10n/public_html">
    AllowOverride FileInfo AuthConfig Limit Indexes
    Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
        Order allow,deny
        Allow from all
    <LimitExcept GET POST OPTIONS>
        Order deny,allow
        Deny from all

my home directory permissions:

drwxr-x--x 84 anark10n users  4096 Feb 11 16:01 anark10n

my public_html permissions (with the user http belonging to the respective group):

drwxr-xr-x  2 anark10n users    4096 Feb 11 15:54 public_html

Last edited by anark10n (2013-02-13 05:37:44)


#2 2013-02-21 22:42:43

Registered: 2012-10-08
Posts: 59

Re: 404 Error when trying to access ~/public_html

you should be browsing to http://server/~anark10n/


Board footer

Powered by FluxBB