You are not logged in.

#1 2013-02-24 13:04:30

akshay2000
Member
From: Kanpur
Registered: 2011-08-01
Posts: 29
Website

Keyboard stopped working even in basic X environment

I have an Arch installation which was working pretty fine with proprietary NVIDIA drivers. After I updated the system recently with simple 'pacman -Syu' keyboard no longer worked with GDM! I disabled the GDM and tried to get into a basic X session with xterm, only to find that keyboard is not working at all. My Synaptics touchpad works fine. It's just the keyboard which doesn't work at all. Here is my Xorg.0.log:

[  1591.567] 
X.Org X Server 1.13.2
Release Date: 2013-01-24
[  1591.590] X Protocol Version 11, Revision 0
[  1591.598] Build Operating System: Linux 3.7.4-1-ARCH x86_64 
[  1591.618] Current Operating System: Linux zade 3.7.7-1-ARCH #1 SMP PREEMPT Mon Feb 11 20:20:58 EET 2013 x86_64
[  1591.618] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=90ebe4c8-3276-4991-b40f-d8640859ef9f ro quiet
[  1591.655] Build Date: 25 January 2013  09:33:50AM
[  1591.668]  
[  1591.681] Current version of pixman: 0.28.2
[  1591.709] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[  1591.710] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  1591.779] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Feb 24 18:16:13 2013
[  1591.834] (==) Using config file: "/etc/X11/xorg.conf"
[  1591.854] (==) Using config directory: "/etc/X11/xorg.conf.d"
[  1591.865] (==) ServerLayout "Layout0"
[  1591.865] (**) |-->Screen "Screen0" (0)
[  1591.865] (**) |   |-->Monitor "Monitor0"
[  1591.865] (**) |   |-->Device "Device0"
[  1591.865] (**) |-->Input Device "Keyboard0"
[  1591.865] (**) |-->Input Device "Mouse0"
[  1591.865] (==) Automatically adding devices
[  1591.865] (==) Automatically enabling devices
[  1591.865] (==) Automatically adding GPU devices
[  1591.906] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[  1591.906] 	Entry deleted from font path.
[  1591.911] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[  1591.911] 	Entry deleted from font path.
[  1591.911] 	(Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[  1591.911] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[  1591.912] 	Entry deleted from font path.
[  1591.912] 	(Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[  1591.912] (==) FontPath set to:
	/usr/share/fonts/misc/,
	/usr/share/fonts/TTF/,
	/usr/share/fonts/Type1/
[  1591.912] (==) ModulePath set to "/usr/lib/xorg/modules"
[  1591.912] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[  1591.912] (WW) Disabling Keyboard0
[  1591.912] (WW) Disabling Mouse0
[  1591.912] (II) Loader magic: 0x7fcc40
[  1591.912] (II) Module ABI versions:
[  1591.912] 	X.Org ANSI C Emulation: 0.4
[  1591.912] 	X.Org Video Driver: 13.1
[  1591.912] 	X.Org XInput driver : 18.0
[  1591.912] 	X.Org Server Extension : 7.0
[  1591.915] (--) PCI:*(0:2:0:0) 10de:0df0:1028:0468 rev 161, Mem @ 0xfa000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[  1591.915] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[  1591.937] Initializing built-in extension Generic Event Extension
[  1591.958] Initializing built-in extension SHAPE
[  1591.979] Initializing built-in extension MIT-SHM
[  1592.001] Initializing built-in extension XInputExtension
[  1592.023] Initializing built-in extension XTEST
[  1592.046] Initializing built-in extension BIG-REQUESTS
[  1592.068] Initializing built-in extension SYNC
[  1592.090] Initializing built-in extension XKEYBOARD
[  1592.112] Initializing built-in extension XC-MISC
[  1592.134] Initializing built-in extension SECURITY
[  1592.156] Initializing built-in extension XINERAMA
[  1592.177] Initializing built-in extension XFIXES
[  1592.198] Initializing built-in extension RENDER
[  1592.219] Initializing built-in extension RANDR
[  1592.238] Initializing built-in extension COMPOSITE
[  1592.255] Initializing built-in extension DAMAGE
[  1592.272] Initializing built-in extension MIT-SCREEN-SAVER
[  1592.288] Initializing built-in extension DOUBLE-BUFFER
[  1592.303] Initializing built-in extension RECORD
[  1592.318] Initializing built-in extension DPMS
[  1592.332] Initializing built-in extension X-Resource
[  1592.345] Initializing built-in extension XVideo
[  1592.359] Initializing built-in extension XVideo-MotionCompensation
[  1592.371] Initializing built-in extension XFree86-VidModeExtension
[  1592.383] Initializing built-in extension XFree86-DGA
[  1592.393] Initializing built-in extension XFree86-DRI
[  1592.403] Initializing built-in extension DRI2
[  1592.403] (II) LoadModule: "glx"
[  1592.419] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[  1593.266] (II) Module glx: vendor="NVIDIA Corporation"
[  1593.266] 	compiled for 4.0.2, module version = 1.0.0
[  1593.266] 	Module class: X.Org Server Extension
[  1593.266] (II) NVIDIA GLX Module  313.18  Wed Jan  9 15:34:35 PST 2013
[  1593.280] Loading extension GLX
[  1593.280] (II) LoadModule: "nvidia"
[  1593.323] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[  1593.392] (II) Module nvidia: vendor="NVIDIA Corporation"
[  1593.392] 	compiled for 4.0.2, module version = 1.0.0
[  1593.392] 	Module class: X.Org Video Driver
[  1593.412] (II) NVIDIA dlloader X Driver  313.18  Wed Jan  9 15:15:26 PST 2013
[  1593.412] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[  1593.415] (++) using VT number 1

[  1593.421] (II) Loading sub module "wfb"
[  1593.421] (II) LoadModule: "wfb"
[  1593.433] (II) Loading /usr/lib/xorg/modules/libwfb.so
[  1593.450] (II) Module wfb: vendor="X.Org Foundation"
[  1593.450] 	compiled for 1.13.2, module version = 1.0.0
[  1593.450] 	ABI class: X.Org ANSI C Emulation, version 0.4
[  1593.450] (II) Loading sub module "ramdac"
[  1593.450] (II) LoadModule: "ramdac"
[  1593.450] (II) Module "ramdac" already built-in
[  1593.457] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[  1593.457] (==) NVIDIA(0): RGB weight 888
[  1593.457] (==) NVIDIA(0): Default visual is TrueColor
[  1593.457] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[  1593.467] (**) NVIDIA(0): Enabling 2D acceleration
[  1594.160] (II) NVIDIA(GPU-0): Display (Seiko/Epson (DFP-0)) does not support NVIDIA 3D
[  1594.160] (II) NVIDIA(GPU-0):     Vision stereo.
[  1594.162] (II) NVIDIA(0): NVIDIA GPU GeForce GT 425M (GF108) at PCI:2:0:0 (GPU-0)
[  1594.162] (--) NVIDIA(0): Memory: 2097152 kBytes
[  1594.162] (--) NVIDIA(0): VideoBIOS: 70.08.19.00.10
[  1594.162] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[  1594.167] (--) NVIDIA(0): Valid display device(s) on GeForce GT 425M at PCI:2:0:0
[  1594.167] (--) NVIDIA(0):     Seiko/Epson (DFP-0) (connected)
[  1594.168] (--) NVIDIA(0):     DFP-1
[  1594.168] (--) NVIDIA(0):     DFP-2
[  1594.168] (--) NVIDIA(0):     DFP-3
[  1594.168] (--) NVIDIA(0): Seiko/Epson (DFP-0): 330.0 MHz maximum pixel clock
[  1594.168] (--) NVIDIA(0): Seiko/Epson (DFP-0): Internal Dual Link LVDS
[  1594.168] (--) NVIDIA(0): DFP-1: 165.0 MHz maximum pixel clock
[  1594.168] (--) NVIDIA(0): DFP-1: Internal Single Link TMDS
[  1594.168] (--) NVIDIA(0): DFP-2: 165.0 MHz maximum pixel clock
[  1594.168] (--) NVIDIA(0): DFP-2: Internal Single Link TMDS
[  1594.168] (--) NVIDIA(0): DFP-3: 480.0 MHz maximum pixel clock
[  1594.168] (--) NVIDIA(0): DFP-3: Internal DisplayPort
[  1594.168] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[  1594.168] (**) NVIDIA(0):     device Seiko/Epson (DFP-0) (Using EDID frequencies has
[  1594.168] (**) NVIDIA(0):     been enabled on all display devices.)
[  1594.168] (==) NVIDIA(0): 
[  1594.168] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[  1594.168] (==) NVIDIA(0):     will be used as the requested mode.
[  1594.168] (==) NVIDIA(0): 
[  1594.168] (II) NVIDIA(0): Validated MetaModes:
[  1594.168] (II) NVIDIA(0):     "DFP-0:nvidia-auto-select"
[  1594.169] (II) NVIDIA(0): Virtual screen size determined to be 1366 x 768
[  1595.354] (--) NVIDIA(0): DPI set to (115, 114); computed from "UseEdidDpi" X config
[  1595.354] (--) NVIDIA(0):     option
[  1595.354] (--) Depth 24 pixmap format is 32 bpp
[  1595.355] (II) NVIDIA: Using 3072.00 MB of virtual memory for indirect memory
[  1595.355] (II) NVIDIA:     access.
[  1595.480] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[  1595.480] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[  1595.480] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[  1595.480] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[  1595.480] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[  1595.480] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[  1595.480] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[  1595.480] (II) NVIDIA(0):     Config Options in the README.
[  1595.485] (II) NVIDIA(0): Setting mode "DFP-0:nvidia-auto-select"
[  1596.077] Loading extension NV-GLX
[  1596.140] (==) NVIDIA(0): Disabling shared memory pixmaps
[  1596.140] (==) NVIDIA(0): Backing store disabled
[  1596.140] (==) NVIDIA(0): Silken mouse enabled
[  1596.141] (**) NVIDIA(0): DPMS enabled
[  1596.141] Loading extension NV-CONTROL
[  1596.141] Loading extension XINERAMA
[  1596.141] (II) Loading sub module "dri2"
[  1596.141] (II) LoadModule: "dri2"
[  1596.141] (II) Module "dri2" already built-in
[  1596.141] (II) NVIDIA(0): [DRI2] Setup complete
[  1596.141] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[  1596.141] (--) RandR disabled
[  1596.146] (II) Initializing extension GLX
[  1596.477] (EE) Error loading keymap /tmp/server-0.xkm
[  1596.477] (EE) XKB: Failed to load keymap. Loading default keymap instead.
[  1596.504] (II) config/udev: Adding input device Power Button (/dev/input/event3)
[  1596.504] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[  1596.504] (II) LoadModule: "evdev"
[  1596.505] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[  1596.533] (II) Module evdev: vendor="X.Org Foundation"
[  1596.533] 	compiled for 1.13.0, module version = 2.7.3
[  1596.533] 	Module class: X.Org XInput Driver
[  1596.533] 	ABI class: X.Org XInput driver, version 18.0
[  1596.533] (II) Using input driver 'evdev' for 'Power Button'
[  1596.533] (**) Power Button: always reports core events
[  1596.533] (**) evdev: Power Button: Device: "/dev/input/event3"
[  1596.533] (--) evdev: Power Button: Vendor 0 Product 0x1
[  1596.534] (--) evdev: Power Button: Found keys
[  1596.534] (II) evdev: Power Button: Configuring as keyboard
[  1596.534] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input3/event3"
[  1596.534] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[  1596.534] (**) Option "xkb_rules" "evdev"
[  1596.534] (**) Option "xkb_model" "evdev"
[  1596.534] (**) Option "xkb_layout" "us"
[  1596.560] (EE) Error loading keymap /tmp/server-0.xkm
[  1596.560] (EE) XKB: Failed to load keymap. Loading default keymap instead.
[  1596.591] (II) config/udev: Adding input device Video Bus (/dev/input/event4)
[  1596.591] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[  1596.591] (II) Using input driver 'evdev' for 'Video Bus'
[  1596.591] (**) Video Bus: always reports core events
[  1596.591] (**) evdev: Video Bus: Device: "/dev/input/event4"
[  1596.591] (--) evdev: Video Bus: Vendor 0 Product 0x6
[  1596.591] (--) evdev: Video Bus: Found keys
[  1596.591] (II) evdev: Video Bus: Configuring as keyboard
[  1596.591] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:02/LNXVIDEO:00/input/input4/event4"
[  1596.591] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
[  1596.591] (**) Option "xkb_rules" "evdev"
[  1596.591] (**) Option "xkb_model" "evdev"
[  1596.591] (**) Option "xkb_layout" "us"
[  1596.592] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[  1596.592] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[  1596.592] (II) Using input driver 'evdev' for 'Power Button'
[  1596.592] (**) Power Button: always reports core events
[  1596.592] (**) evdev: Power Button: Device: "/dev/input/event1"
[  1596.592] (--) evdev: Power Button: Vendor 0 Product 0x1
[  1596.592] (--) evdev: Power Button: Found keys
[  1596.592] (II) evdev: Power Button: Configuring as keyboard
[  1596.592] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input1/event1"
[  1596.592] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 8)
[  1596.592] (**) Option "xkb_rules" "evdev"
[  1596.592] (**) Option "xkb_model" "evdev"
[  1596.592] (**) Option "xkb_layout" "us"
[  1596.593] (II) config/udev: Adding input device Lid Switch (/dev/input/event2)
[  1596.593] (II) No input driver specified, ignoring this device.
[  1596.593] (II) This device may have been added with another device file.
[  1596.594] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=9 (/dev/input/event13)
[  1596.594] (II) No input driver specified, ignoring this device.
[  1596.594] (II) This device may have been added with another device file.
[  1596.594] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=8 (/dev/input/event14)
[  1596.594] (II) No input driver specified, ignoring this device.
[  1596.594] (II) This device may have been added with another device file.
[  1596.595] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=7 (/dev/input/event15)
[  1596.595] (II) No input driver specified, ignoring this device.
[  1596.595] (II) This device may have been added with another device file.
[  1596.595] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=3 (/dev/input/event16)
[  1596.595] (II) No input driver specified, ignoring this device.
[  1596.595] (II) This device may have been added with another device file.
[  1596.596] (II) config/udev: Adding input device Laptop_Integrated_Webcam_2HDM (/dev/input/event12)
[  1596.596] (**) Laptop_Integrated_Webcam_2HDM: Applying InputClass "evdev keyboard catchall"
[  1596.596] (II) Using input driver 'evdev' for 'Laptop_Integrated_Webcam_2HDM'
[  1596.596] (**) Laptop_Integrated_Webcam_2HDM: always reports core events
[  1596.596] (**) evdev: Laptop_Integrated_Webcam_2HDM: Device: "/dev/input/event12"
[  1596.596] (--) evdev: Laptop_Integrated_Webcam_2HDM: Vendor 0x408 Product 0x2fb2
[  1596.596] (--) evdev: Laptop_Integrated_Webcam_2HDM: Found keys
[  1596.596] (II) evdev: Laptop_Integrated_Webcam_2HDM: Configuring as keyboard
[  1596.596] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.4/1-1.4:1.0/input/input12/event12"
[  1596.596] (II) XINPUT: Adding extended input device "Laptop_Integrated_Webcam_2HDM" (type: KEYBOARD, id 9)
[  1596.596] (**) Option "xkb_rules" "evdev"
[  1596.596] (**) Option "xkb_model" "evdev"
[  1596.596] (**) Option "xkb_layout" "us"
[  1596.596] (II) config/udev: Adding input device HDA Digital PCBeep (/dev/input/event7)
[  1596.596] (II) No input driver specified, ignoring this device.
[  1596.596] (II) This device may have been added with another device file.
[  1596.597] (II) config/udev: Adding input device HDA Intel MID Headphone (/dev/input/event10)
[  1596.597] (II) No input driver specified, ignoring this device.
[  1596.597] (II) This device may have been added with another device file.
[  1596.597] (II) config/udev: Adding input device HDA Intel MID Mic (/dev/input/event8)
[  1596.597] (II) No input driver specified, ignoring this device.
[  1596.597] (II) This device may have been added with another device file.
[  1596.597] (II) config/udev: Adding input device HDA Intel MID Headphone (/dev/input/event9)
[  1596.597] (II) No input driver specified, ignoring this device.
[  1596.597] (II) This device may have been added with another device file.
[  1596.597] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
[  1596.597] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[  1596.597] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[  1596.597] (**) AT Translated Set 2 keyboard: always reports core events
[  1596.597] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event0"
[  1596.597] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[  1596.597] (--) evdev: AT Translated Set 2 keyboard: Found keys
[  1596.597] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[  1596.597] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input0/event0"
[  1596.597] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 10)
[  1596.597] (**) Option "xkb_rules" "evdev"
[  1596.597] (**) Option "xkb_model" "evdev"
[  1596.597] (**) Option "xkb_layout" "us"
[  1596.597] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event11)
[  1596.597] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[  1596.598] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[  1596.598] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "Default clickpad buttons"
[  1596.598] (II) LoadModule: "synaptics"
[  1596.598] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[  1596.598] (II) Module synaptics: vendor="X.Org Foundation"
[  1596.598] 	compiled for 1.13.2, module version = 1.6.3
[  1596.598] 	Module class: X.Org XInput Driver
[  1596.599] 	ABI class: X.Org XInput driver, version 18.0
[  1596.599] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
[  1596.599] (**) SynPS/2 Synaptics TouchPad: always reports core events
[  1596.599] (**) Option "Device" "/dev/input/event11"
[  1596.603] (II) synaptics: SynPS/2 Synaptics TouchPad: ignoring touch events for semi-multitouch device
[  1596.603] (--) synaptics: SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5632
[  1596.603] (--) synaptics: SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4756
[  1596.603] (--) synaptics: SynPS/2 Synaptics TouchPad: pressure range 0 - 255
[  1596.603] (--) synaptics: SynPS/2 Synaptics TouchPad: finger width range 0 - 15
[  1596.603] (--) synaptics: SynPS/2 Synaptics TouchPad: buttons: left right double triple
[  1596.603] (--) synaptics: SynPS/2 Synaptics TouchPad: Vendor 0x2 Product 0x7
[  1596.603] (**) Option "TapButton1" "1"
[  1596.603] (**) Option "TapButton2" "2"
[  1596.603] (**) Option "TapButton3" "3"
[  1596.603] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[  1596.603] (**) SynPS/2 Synaptics TouchPad: always reports core events
[  1596.610] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio4/input/input11/event11"
[  1596.610] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD, id 11)
[  1596.610] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.5
[  1596.610] (**) synaptics: SynPS/2 Synaptics TouchPad: MaxSpeed is now 1.75
[  1596.610] (**) synaptics: SynPS/2 Synaptics TouchPad: AccelFactor is now 0.037
[  1596.611] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
[  1596.611] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
[  1596.611] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[  1596.611] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[  1596.611] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[  1596.611] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)
[  1596.612] (**) SynPS/2 Synaptics TouchPad: Ignoring device from InputClass "touchpad ignore duplicates"
[  1596.612] (II) config/udev: Adding input device PC Speaker (/dev/input/event5)
[  1596.612] (II) No input driver specified, ignoring this device.
[  1596.612] (II) This device may have been added with another device file.
[  1596.613] (II) config/udev: Adding input device Dell WMI hotkeys (/dev/input/event6)
[  1596.613] (**) Dell WMI hotkeys: Applying InputClass "evdev keyboard catchall"
[  1596.613] (II) Using input driver 'evdev' for 'Dell WMI hotkeys'
[  1596.613] (**) Dell WMI hotkeys: always reports core events
[  1596.613] (**) evdev: Dell WMI hotkeys: Device: "/dev/input/event6"
[  1596.613] (--) evdev: Dell WMI hotkeys: Vendor 0 Product 0
[  1596.613] (--) evdev: Dell WMI hotkeys: Found keys
[  1596.613] (II) evdev: Dell WMI hotkeys: Configuring as keyboard
[  1596.613] (**) Option "config_info" "udev:/sys/devices/virtual/input/input6/event6"
[  1596.613] (II) XINPUT: Adding extended input device "Dell WMI hotkeys" (type: KEYBOARD, id 12)
[  1596.613] (**) Option "xkb_rules" "evdev"
[  1596.613] (**) Option "xkb_model" "evdev"
[  1596.613] (**) Option "xkb_layout" "us"
[  1676.349] (II) evdev: Dell WMI hotkeys: Close
[  1676.349] (II) UnloadModule: "evdev"
[  1676.349] (II) UnloadModule: "synaptics"
[  1676.349] (II) evdev: AT Translated Set 2 keyboard: Close
[  1676.349] (II) UnloadModule: "evdev"
[  1676.350] (II) evdev: Laptop_Integrated_Webcam_2HDM: Close
[  1676.350] (II) UnloadModule: "evdev"
[  1676.350] (II) evdev: Power Button: Close
[  1676.350] (II) UnloadModule: "evdev"
[  1676.350] (II) evdev: Video Bus: Close
[  1676.350] (II) UnloadModule: "evdev"
[  1676.350] (II) evdev: Power Button: Close
[  1676.350] (II) UnloadModule: "evdev"

Any help is greatly appreciated.

Last edited by akshay2000 (2013-02-24 13:13:32)


Wit beyond measure is man's greatest treasure!
Windows Phone app for Linux!

Offline

#2 2013-02-25 06:51:34

akshay2000
Member
From: Kanpur
Registered: 2011-08-01
Posts: 29
Website

Re: Keyboard stopped working even in basic X environment

*BUMP*

No one? Really, no one wants to reply?


Wit beyond measure is man's greatest treasure!
Windows Phone app for Linux!

Offline

#3 2013-02-25 06:59:31

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,345
Website

Re: Keyboard stopped working even in basic X environment

Read the Etiquette entry on bumping, pay attention as to the reasons why no-one has replied...
https://wiki.archlinux.org/index.php/Fo … te#Bumping

Note the part about "the reason for posts remaining unanswered is due in large part to the sparse details in the original post itself..."


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#4 2013-02-25 07:09:11

akshay2000
Member
From: Kanpur
Registered: 2011-08-01
Posts: 29
Website

Re: Keyboard stopped working even in basic X environment

jasonwryan wrote:

Read the Etiquette entry on bumping, pay attention as to the reasons why no-one has replied...
https://wiki.archlinux.org/index.php/Fo … te#Bumping

Note the part about "the reason for posts remaining unanswered is due in large part to the sparse details in the original post itself..."

Hmm... I see. Well, as a matter of fact, I have been through the guide and I really really hate bumping. However, exactly as mentioned in the entry, I have been troubleshooting on my own (for about two days) and posting relevant results. I have already added relevant log files and provided necessary information. After all this time, I really feel stuck. Hope that someone really points me in the right direction. My sincere apologies for the 'bump' post.


Wit beyond measure is man's greatest treasure!
Windows Phone app for Linux!

Offline

#5 2013-02-25 07:32:15

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,345
Website

Re: Keyboard stopped working even in basic X environment

You said it happened after you updated; did you try downgrading any of the upgraded packages to isolate the potential cause? Failing that, posting the list of relevant packages would constitute helpful information...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#6 2013-02-25 08:17:03

akshay2000
Member
From: Kanpur
Registered: 2011-08-01
Posts: 29
Website

Re: Keyboard stopped working even in basic X environment

jasonwryan wrote:

You said it happened after you updated; did you try downgrading any of the upgraded packages to isolate the potential cause? Failing that, posting the list of relevant packages would constitute helpful information...

I have tried downgrading the Gnome and GDM packages (as those were upgraded). I also tried upgrading everything to avoid problems causing due to partial upgrades. However, problem doesn't seem to be with the GDM. Keyboard isn't working with basic X environment which only has Xterm.


Wit beyond measure is man's greatest treasure!
Windows Phone app for Linux!

Offline

#7 2013-02-25 08:46:23

brebs
Member
Registered: 2007-04-03
Posts: 3,408

Re: Keyboard stopped working even in basic X environment

(EE) Error loading keymap /tmp/server-0.xkm

I would be googling for that. E.g. see thread.

So did you update xkeyboard-config? It's tedious that you haven't had the sense yet to list which packages got updated, along with version numbers.

Offline

#8 2013-02-25 16:08:50

akshay2000
Member
From: Kanpur
Registered: 2011-08-01
Posts: 29
Website

Re: Keyboard stopped working even in basic X environment

brebs wrote:
(EE) Error loading keymap /tmp/server-0.xkm

I would be googling for that. E.g. see thread.

So did you update xkeyboard-config? It's tedious that you haven't had the sense yet to list which packages got updated, along with version numbers.

It's nice to see you enter here, brebs!
A few things have happened:

  1. I just noticed that the file '/etc/X11/xinit/xinitrc' isn't present at all! It was present when I posted the thread (I think). So X didn't even start. I had to create .xinitrc in my home directory with single like 'exec xterm'. X started fine but keyboard still didn't work.

  2. Out of nowhere, I thought of using nouveau drivers instead of Nvidia drivers. So I went ahead and switched to nouveau and bam - keyboard is working. Enabled GDM and keyboard is still working. I still would like know what went wrong with Nvidia - for educational purposes.

What more details should I provide? I'd like to have Nvidia drivers back.

Last edited by akshay2000 (2013-02-25 16:17:07)


Wit beyond measure is man's greatest treasure!
Windows Phone app for Linux!

Offline

Board footer

Powered by FluxBB