You are not logged in.

#1 2013-03-13 14:19:04

alexjj
Member
Registered: 2013-02-10
Posts: 8

[Solved] net-auto-wired and ifplugd failing to work

Having installed Arch successfully on one machine I then move to another, so I've just got a fresh install with nothing else.

Using netcfg and ifplugd to manage network interfaces (trying to, did same process and it worked okay on other computer), however systemctl status of net-wired-auto gives:

net-auto-wired.service - Provides automatic netcfg wired connection
	  Loaded: loaded (/usr/lib/systemd/system/net-auto-wired.service; enabled)
	  Active: active (running) since Wed 2013-03-13 14:00:22 GMT; 12min ago
	Main PID: 259 (ifplugd)
	  CGroup: name=systemd:/system/net-auto-wired.service
		  └─259 /usr/bin/ifplugd -i enp7s0 -r /etc/ifplugd/netcfg.action -fIns

Mar 13 14:00:22 alexpc systemd[1]: Started Provides automatic netcfg wired connection.
Mar 13 14:00:22 alexpc ifplugd[259]: ifplugd 0.28 initializing.
Mar 13 14:00:22 alexpc ifplugd[259]: Using interface enp7s0/8C:89:A5:37:9F:51 with driver <r8169> (version: 2...-NAPI)
Mar 13 14:00:22 alexpc ifplugd[259]: Using detection mode: SIOCETHTOOL
Mar 13 14:00:22 alexpc ifplugd[259]: Initialization complete, link beat not detected.
Mar 13 14:00:25 alexpc ifplugd[259]: Link beat detected.
Mar 13 14:00:26 alexpc ifplugd[259]: Executing '/etc/ifplugd/netcfg.action enp7s0 up'.
Mar 13 14:00:26 alexpc ifplugd[259]: client: up
Mar 13 14:00:26 alexpc ifplugd[259]: Program execution failed, return value is 1.

I've checked many times and interface is enp7s0 (only one anyway and no wireless)

Running

dhcpcd enp7s0

does work fine and connects me to the network. Also realtek driver (r8269) is being loaded (obv given I can connect to network)

Contents of /etc/conf.d/netcfg

# Enable these netcfg profiles at boot time.
#   - prefix an entry with a '@' to background its startup
#   - set to 'last' to restore the profiles running at the last shutdown
#   - set to 'menu' to present a menu (requires the dialog package)
# Network profiles are found in /etc/network.d
NETWORKS=(last)

# Specify the name of your wired interface for net-auto-wired
WIRED_INTERFACE="enp7s0"

# Specify the name of your wireless interface for net-auto-wireless
WIRELESS_INTERFACE="wlan0"

# Array of profiles that may be started by net-auto-wireless.
# When not specified, all wireless profiles are considered.
#AUTO_PROFILES=("profile1" "profile2")


I can use dhcpcd service and it works fine - but it would be nice to use ifplugd/netcfg.

Not really sure what else to try...

Thanks.

Last edited by alexjj (2013-03-15 12:15:46)

Offline

#2 2013-03-13 18:08:43

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 692

Re: [Solved] net-auto-wired and ifplugd failing to work

I think you may need to also put a config file into /etc/network.d/ - you can copy one of the sample files there and adapt it to your situation.

Also you have to set the correct interface in /etc/ifplugd/ifplugd.conf

You will also need:
systemctl start net-auto-wired
systemctl enable net-auto-wired

Hope this helps.

Last edited by mcloaked (2013-03-13 18:09:55)


Mike C

Offline

#3 2013-03-15 12:15:32

alexjj
Member
Registered: 2013-02-10
Posts: 8

Re: [Solved] net-auto-wired and ifplugd failing to work

I was missing the ethernet-dhcp config file in /etc/network.d/ and then it worked fine.

Seems having the interface set in /etc/ifplugd/ifplugd.conf makes no difference when using net-auto-wired (netcfg) guess if I was using the ifpludg.service it would.

Thanks.

Offline

Board footer

Powered by FluxBB