You are not logged in.

#1 2013-03-17 15:15:08

awayand
Member
Registered: 2009-09-25
Posts: 396

[SOLVED] upgrading postgresql from 9.0.4

I am trying to upgrade postgresql from 9.0.4 to 9.2.3 using the directions from the wiki (postgresql page, under "upgrading"), due to systemd causing my connections to be refused on my socket for 9.0.4...

# pacman -S postgresql-old-upgrade postgresql-libs
:: postgresql-libs is in IgnorePkg/IgnoreGroup. Install anyway? Y/n
resolving dependencies...
looking for inter-conflicts...
:: postgresql-libs and postgresql are in conflict (postgresql-client). Remove postgresql? y/N

If pacman wants to remove my old postgresql binaries, then how is pg_upgrade supposed to work when I need to feed it the location of the new binaries as well as the old ones?

Last edited by awayand (2013-03-20 04:11:30)

Offline

#2 2013-03-20 04:11:13

awayand
Member
Registered: 2009-09-25
Posts: 396

Re: [SOLVED] upgrading postgresql from 9.0.4

well I guess I have a solution now for those that have the same problem: http://blog.sleepmail.com/upgrading-pos … archlinux/

Offline

Board footer

Powered by FluxBB