You are not logged in.

#1 2013-03-17 20:20:00

dext
Member
From: Poland, Kraków
Registered: 2008-02-01
Posts: 67

Postgresql doesn't see my databases

After reboot Postgresql doesn't see my databases.
Facts:
I didn't upgrade, and I'm far behind (Pacman is synced to about 04.2012)

pacman -Qi postgresql | grep Ver
Version        : 9.1.3-1
cat /var/lib/postgres/data/PG_VERSION 
9.1
postgres=# \list      [cutted]:
   Name
-------------
postgres
template0
template1

pg_dumpall output is generally empty:

pg_dumpall > backup.sql 
cat backup.sql | grep CREATE
CREATE ROLE postgres;
ALTER ROLE postgres WITH SUPERUSER INHERIT CREATEROLE CREATEDB LOGIN REPLICATION;
CREATE EXTENSION IF NOT EXISTS plpgsql WITH SCHEMA pg_catalog;
CREATE EXTENSION IF NOT EXISTS plpgsql WITH SCHEMA pg_catalog;

/var/log/postgresql.log is OK - only info (LOG).

Something is there:

du -sh /var/lib/postgres/data/
185M	/var/lib/postgres/data/

PS. I've tried to ask for help on pgsql-admin@postgresql.org, but it looks like almost no one uses it - only couple of mails for 2 weeks. Somebody knows some good place to talk about Postgres?


English is not my first language, so please forgive me for my mistakes.

Offline

#2 2013-03-17 21:59:24

mloskot
Member
From: London, United Kingdom
Registered: 2012-06-01
Posts: 86
Website

Re: Postgresql doesn't see my databases

What you get from this command

select setting from pg_settings where name = 'data_directory';

You can try #postgresql channel on irc.freenode.net, lots of helpful folks there.

Last edited by mloskot (2013-03-17 21:59:45)


Mateusz Loskot | github | archlinux-config
Arch (x86-64) | ThinkPad T400  | Intel P8600| Intel i915
Arch (x86-64) | ThinkPad W700 | Intel T9600 | NVIDIA Quadro FX 2700M

Offline

#3 2013-03-17 23:11:55

dext
Member
From: Poland, Kraków
Registered: 2008-02-01
Posts: 67

Re: Postgresql doesn't see my databases

mloskot wrote:

What you get from this command

select setting from pg_settings where name = 'data_directory';
postgres=# select setting from pg_settings where name = 'data_directory';
        setting         
------------------------
 /var/lib/postgres/data
(1 row)

Permissions are also OK:
dirs: 700 postgres.postgres
files: 600 postgres.postgres


Thanks for info, I'll try get some help on IRC too.


English is not my first language, so please forgive me for my mistakes.

Offline

#4 2013-03-18 00:07:06

mloskot
Member
From: London, United Kingdom
Registered: 2012-06-01
Posts: 86
Website

Re: Postgresql doesn't see my databases

The values look correct. I honestly don't know what might have changed after simple reboot. Hopefully folks on IRC will help.


Mateusz Loskot | github | archlinux-config
Arch (x86-64) | ThinkPad T400  | Intel P8600| Intel i915
Arch (x86-64) | ThinkPad W700 | Intel T9600 | NVIDIA Quadro FX 2700M

Offline

Board footer

Powered by FluxBB