You are not logged in.

#1 2013-03-18 22:28:34

pareshverma91
Member
Registered: 2011-09-22
Posts: 8

Issue with systemd-coredump

Hi, I just noticed that most of my memory was hogged by coredump of a few processes that I had killed recently. I had a systemd-coredump process running for each crashed process (usually the processes were google-chrome, which I had force quit, which explains the large memory consumption).
What I would like to know is why instead of dumping the core of the crashed process to the disk, a new process that holds the entire core in the ram is being started. Is my configuration buggy? or is it supposed to this way and if so how do I change the behavior?
For now I have disabled the storing of core dump by linking /dev/null to /etc/sysctl.d/coredump.conf. Though, I do not see core dumps, but still would like to keep it enabled. Any ideas/hints would be appreciated.

Offline

#2 2013-03-19 15:31:07

jukkan
Member
Registered: 2010-09-08
Posts: 39

Re: Issue with systemd-coredump

I also had like 4 systemd-coredump processes each taking up ~100 megs of mem. What's going on?

Offline

#3 2013-03-22 01:07:55

guihkx
Member
Registered: 2013-03-22
Posts: 14

Re: Issue with systemd-coredump

I have the same problem.

f0RqlI5.png

Now the question is: why?


English is not my native language, I'm sorry!

Offline

#4 2013-03-22 01:35:27

progandy
Member
Registered: 2012-05-17
Posts: 2,151

Re: Issue with systemd-coredump

Can you find out which process the coredump belongs to? With "pstree -a" you get a tree with childprocesses and passed arguments (package psmisc).

Offline

#5 2013-03-22 05:20:11

guihkx
Member
Registered: 2013-03-22
Posts: 14

Re: Issue with systemd-coredump

progandy wrote:

Can you find out which process the coredump belongs to? With "pstree -a" you get a tree with childprocesses and passed arguments (package psmisc).

Thanks for your reply.

I couldn't find systemd-coredump with pstree, but the weird thing is that I found it in gnome-system-monitor. Anyway, here it is the dump for pstree -a:

systemd
  |-agetty --noclear tty2 38400 linux
  |-agetty --noclear tty3 38400 linux
  |-at-spi-bus-laun
  |   |-dbus-daemon --config-file=/etc/at-spi2/accessibility.conf --nofork --print-address 3
  |   `-3*[{at-spi-bus-laun}]
  |-at-spi2-registr --use-gnome-session
  |   `-{at-spi2-registr}
  |-chromium
  |   |-chromium
  |   |-(chromium)
  |   |-chromium
  |   |   `-2*[{chromium}]
  |   |-(chromium)
  |   |-(chromium)
  |   |-(chromium)
  |   |-chromium-sandbo /usr/lib/chromium/chromium --type=zygote
  |   |   `-chromium
  |   |       |-chromium
  |   |       |   |-chromium
  |   |       |   |   `-3*[{chromium}]
  |   |       |   |-chromium
  |   |       |   |   `-12*[{chromium}]
  |   |       |   |-chromium
  |   |       |   |   `-3*[{chromium}]
  |   |       |   |-chromium
  |   |       |   |   `-3*[{chromium}]
  |   |       |   |-chromium
  |   |       |   |   `-3*[{chromium}]
  |   |       |   |-chromium
  |   |       |   |   `-3*[{chromium}]
  |   |       |   `-chromium
  |   |       |       `-3*[{chromium}]
  |   |       `-nacl_helper_boo /usr/lib/chromium/nacl_helper --reserved_at_zero=0x0000000040000000--r_debug=0x000000004000
  |   `-23*[{chromium}]
  |-console-kit-dae --no-daemon
  |   `-64*[{console-kit-dae}]
  |-dbus-daemon --system --address=systemd: --nofork --nopidfile --systemd-activation
  |-dbus-daemon --fork --print-pid 5 --print-address 7 --session
  |-dbus-launch --autolaunch 26f25ce8e275912a98fb313600003f0e --binary-syntax --close-stderr
  |-dconf-service
  |   `-2*[{dconf-service}]
  |-dhcpcd -q -w eth0
  |-gconfd-2
  |-login     
  |   `-startx /usr/bin/startx
  |       `-xinit /home/guihkx/.xinitrc -- /etc/X11/xinit/xserverrc :0 -auth /tmp/serverauth.x0S8RYqmTu
  |           |-X -nolisten tcp :0 -auth /tmp/serverauth.x0S8RYqmTu vt1
  |           `-sh /home/guihkx/.xinitrc
  |               |-ck-launch-sessi awesome
  |               |   `-awesome
  |               |       `-{awesome}
  |               |-redshift -l -23 -47 -m vidmode
  |               `-xscreensaver -no-splash
  |-ntpd -g -u ntp:ntp
  |-polkitd --no-debug
  |   `-4*[{polkitd}]
  |-preload --foreground --verbose 1
  |-pulseaudio --start
  |   |-gconf-helper
  |   `-2*[{pulseaudio}]
  |-rtkit-daemon
  |   `-2*[{rtkit-daemon}]
  |-systemd-journal
  |-systemd-logind
  |-systemd-udevd
  `-xterm
      `-bash
          `-su
              `-bash
                  |-bash
                  `-pstree -a

And if it helps, here are the process properties in gnome-system-monitor:

TbaRISI.png


English is not my native language, I'm sorry!

Offline

#6 2013-03-22 05:30:18

08993
Member
Registered: 2013-02-27
Posts: 7

Re: Issue with systemd-coredump

https://bbs.archlinux.org/viewtopic.php?id=159237

It's Chromium - needs fixing badly it's leaving processes behind which dump either automatically or when you try and kill them.

Offline

#7 2013-03-22 17:35:57

pareshverma91
Member
Registered: 2011-09-22
Posts: 8

Re: Issue with systemd-coredump

For me too most of the processes were google-chorme, but I remember that a systemd-coredump for some other was also there (though I don't remember the exact process).
Anyhow, even if a process wants to leave a dump behind, what's the exact reason for storing the dump in memory? This is my main question. Even if the dump has to be logged why not save in the messages/journald or somewhere in disk. Why memory?

Offline

#8 2013-03-23 18:52:17

guihkx
Member
Registered: 2013-03-22
Posts: 14

Re: Issue with systemd-coredump

08993 wrote:

https://bbs.archlinux.org/viewtopic.php?id=159237

It's Chromium - needs fixing badly it's leaving processes behind which dump either automatically or when you try and kill them.

I see, but is there any way to disable systemd-coredump?

Last edited by guihkx (2013-03-26 20:37:18)


English is not my native language, I'm sorry!

Offline

Board footer

Powered by FluxBB