You are not logged in.

#1 2012-08-05 21:26:04

John5788
Member
From: 127.0.0.1
Registered: 2012-08-05
Posts: 17

Slow Wireless Intel 6235 (iwlwifi module)

Hello,

I just installed Arch Linux for the first time on my new Samsung Series 9. It comes with this wireless device

[john5788@john5788-ultrabook ~]$ lspci | grep Network
01:00.0 Network controller: Intel Corporation Centrino Advanced-N 6235 (rev 24)

I believe I am using iwlwifi for it with a 3.4.7.1 kernel

[john5788@john5788-ultrabook ~]$ uname -r
3.4.7-1-ARCH

[john5788@john5788-ultrabook ~]$ lsmod | grep iwlwifi
iwlwifi               311178  0 
mac80211              395680  1 iwlwifi
cfg80211              170106  2 iwlwifi,mac80211

I am having severe latency issues with this laptop that I am not seeing on my phone or my other netbook connected to the same network. I am wondering if i should be using a different module? I have tried unloading iwlwifi and replacing with iwlagn, but iwlwifi comes back anyway when I modprobe iwlagn. From within the network, it takes over 500ms for the laptop to respond to a ping whereas my phone connected to the same network replies much faster:

[/home/john5788 :: 02:24 PM :: 5]
[john5788@john5788] 
$ ping john5788-ultrabook
PING john5788-ultrabook.x5788.net (192.168.2.11) 56(84) bytes of data.
64 bytes from john5788-ultrabook.x5788.net (192.168.2.11): icmp_req=1 ttl=63 time=634 ms
64 bytes from john5788-ultrabook.x5788.net (192.168.2.11): icmp_req=2 ttl=63 time=657 ms
64 bytes from john5788-ultrabook.x5788.net (192.168.2.11): icmp_req=3 ttl=63 time=681 ms
^C
--- john5788-ultrabook.x5788.net ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2000ms
rtt min/avg/max/mdev = 634.071/657.913/681.897/19.547 ms
[/home/john5788 :: 02:24 PM :: 5]
[john5788@john5788] 
$ ping john5788-g2
PING john5788-g2.x5788.net (192.168.2.15) 56(84) bytes of data.
64 bytes from john5788-g2.x5788.net (192.168.2.15): icmp_req=1 ttl=63 time=73.5 ms
64 bytes from john5788-g2.x5788.net (192.168.2.15): icmp_req=2 ttl=63 time=96.1 ms
64 bytes from john5788-g2.x5788.net (192.168.2.15): icmp_req=3 ttl=63 time=16.5 ms
^C
--- john5788-g2.x5788.net ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2002ms
rtt min/avg/max/mdev = 16.534/62.094/96.170/33.510 ms

This is my first time using Arch Linux so I am unsure if the wireless is configured incorrectly or something.

Offline

#2 2012-08-05 22:33:11

John5788
Member
From: 127.0.0.1
Registered: 2012-08-05
Posts: 17

Re: Slow Wireless Intel 6235 (iwlwifi module)

I did some searching on Google and found this link http://aptosid.com/index.php?name=PNphp … ic&p=15128

Seems to be a bug with the 3.4 kernel and iwlwifi driver. Temporary solution seems to be loading iwlwifi with no wireless N support:

EDIT 2: rmmod iwlwifi ; modprobe iwlwifi 11n_disable=1 give me a stable data rate of 54Mbit/s on the 3.3 kernel and 24mbit/s with the 3.4 kernel. According to this, it's not a problem with the 11n mode.
With the 3.4 kernel (no 11n_disabled=1), the bitrate jumps from 150mbit/s to 1mbit/s and everything in between.

I can confirm now that my pings respond much faster:

[/home/john5788 :: 03:29 PM :: 4]
[john5788@john5788] 
$ ping john5788-ultrabook
PING john5788-ultrabook.x5788.net (192.168.2.11) 56(84) bytes of data.
64 bytes from john5788-ultrabook.x5788.net (192.168.2.11): icmp_req=1 ttl=63 time=2.27 ms
64 bytes from john5788-ultrabook.x5788.net (192.168.2.11): icmp_req=2 ttl=63 time=2.23 ms
64 bytes from john5788-ultrabook.x5788.net (192.168.2.11): icmp_req=3 ttl=63 time=2.34 ms
^C
--- john5788-ultrabook.x5788.net ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2002ms
rtt min/avg/max/mdev = 2.232/2.283/2.346/0.072 ms

How do I add this configuration to my bootup so iwlwifi loads without the wireless N support?

Offline

#3 2012-08-06 07:13:18

nexero
Member
Registered: 2012-08-06
Posts: 1

Re: Slow Wireless Intel 6235 (iwlwifi module)

This should disable 11n permanently:

echo options iwlwifi 11n_disable=1 | sudo tee /etc/modprobe.d/51-disable-6235-11n.conf 

I'm on Ubuntu with linux 3.2.0, having the same issues.

Offline

#4 2012-08-20 14:57:24

frmi
Member
Registered: 2012-02-05
Posts: 22

Re: Slow Wireless Intel 6235 (iwlwifi module)

nexero wrote:

This should disable 11n permanently:

echo options iwlwifi 11n_disable=1 | sudo tee /etc/modprobe.d/51-disable-6235-11n.conf 

I'm on Ubuntu with linux 3.2.0, having the same issues.

Seems to work, thank you very much!

Offline

#5 2013-03-22 12:41:48

dernik
Member
Registered: 2009-11-23
Posts: 13

Re: Slow Wireless Intel 6235 (iwlwifi module)

Still the same issue with this driver - very slow connection and loose connection every 10-15 mins, on Samsung Series 7 NP700ZC3H.
I'm on Ubuntu 12.10 with kernel 3.5.0-26-generic.

Guys, your solution works well. Thank you very much you save me a lot of time.

Offline

#6 2013-12-31 22:25:16

crashenx
Member
Registered: 2011-02-01
Posts: 8

Re: Slow Wireless Intel 6235 (iwlwifi module)

nexero wrote:

This should disable 11n permanently:

echo options iwlwifi 11n_disable=1 | sudo tee /etc/modprobe.d/51-disable-6235-11n.conf 

I'm on Ubuntu with linux 3.2.0, having the same issues.

I think this fixed it! Time will tell.

Thanks John5788 & nexero!

On:

Linux s9 3.11-2-amd64 #1 SMP Debian 3.11.10-1 (2013-12-04) x86_64 GNU/Linux

Offline

#7 2013-12-31 22:41:30

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,071

Re: Slow Wireless Intel 6235 (iwlwifi module)

Closing to avoid +1 posts like the 2 above.


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

Board footer

Powered by FluxBB