You are not logged in.

#1 2013-03-26 14:53:36

hachel
Member
Registered: 2011-05-03
Posts: 22

Problem setting default sounddevice with alsa

Hi there,
I have a problem setting my default sound device.
I've googled plenty of solutions, but most are outdated (as in using .asound) or don't work.
This is my aplay-output:

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: SB [HDA ATI SB], device 0: ALC269VB Analog [ALC269VB Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Alsamixer has ATI R6xx HDMI as my default device, with only S/PIDF.

Basically I want the HDA ATI SB as my default device.
As I understand, the arch wiki only explains how to do it if they use different models, but I think mine both use hda-intel.

If tried the solution here like this

$ cat /etc/modprobe.d/alsa-base.conf 
options snd-hda-intel index=0,1 id=SB,HDMI

but all that does is switching the id's:

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI SB], device 0: ALC269VB Analog [ALC269VB Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Any help?

Offline

Board footer

Powered by FluxBB