You are not logged in.

#1 2011-07-14 06:58:53

zenlord
Member
From: Belgium
Registered: 2006-05-24
Posts: 1,207
Website

bluetooth not powered, but gnome icon 'on'

Hi,

About a month ago I came here with one of my few remaining annoyances:
https://bbs.archlinux.org/viewtopic.php?id=120715

Short: no matter what I did, the gnome bluetooth icon would always be in the 'on-position' after a reboot, and most of the time I don't need it, so I have to manually disable bluetooth after logging on to my system (gnome 3).

I have listed in the other post every config-setting I could find regarding bluetooth.

Now this question takes another turn, as apparently the bluetooth adapter is not powered, and yet the icon is still in the 'on-position'. The applet lets me slide the bluetooth-mode from on to off and back and the icon in the applet changes accordingly - but that doesn't seem to affect bluetooth: in the bluetooth settings-dialog, bluetooth is not powered and I cannot slide the button to 'powered'.

I have reverted all the config-settings to the other position (starting bluetooth in rc.conf, setting 'initially powered' to 'true', disabling laptop mode etc.

Can anyone shed some light on this? Maybe someone can tell me in which logfile I could look for errors, because I cannot seem to find that one...

THX!

Offline

#2 2011-07-14 12:24:53

spark666
Member
Registered: 2011-05-23
Posts: 137

Re: bluetooth not powered, but gnome icon 'on'

i will repeat myself,if u use a laptop..make sure if u have a slider button on the laptop for bluetooth,use it.like i said i had the same problem,same as u said.on other DE ur bluetooth worked?

Offline

#3 2011-07-15 06:13:38

zenlord
Member
From: Belgium
Registered: 2006-05-24
Posts: 1,207
Website

Re: bluetooth not powered, but gnome icon 'on'

Thanks for your answer. I share your concern and have already been in the situation you describe, but unfortunately, the answer to my question is not that simple:
# rfkill list
0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

Offline

#4 2011-07-15 06:32:40

spark666
Member
Registered: 2011-05-23
Posts: 137

Re: bluetooth not powered, but gnome icon 'on'

you welcome.then,there its nothing i can do for you...i`m sorry,i wish you luck:)

Last edited by spark666 (2011-07-15 06:33:12)

Offline

#5 2013-03-30 11:45:11

axper
Member
Registered: 2013-01-25
Posts: 115

Re: bluetooth not powered, but gnome icon 'on'

This (probably) isn't the best solution but works for me (until someone finds a better way to do this)

1. install rfkill from official repositories
2. create a new script file, for example ~/.disablebluetooth.sh
3. add the following into that file:

rfkill block bluetooth

4. mark that file as executable (right click -> properties -> permissions tab -> check the "Allow executing etc....." box
5. open gnome-session-properties (press Alt+F2 and type gnome-session-properties)
6. add a new startup script, press Browse... and point to our script file created above

This way bluetooth will disabled by default, and you can turn it on whenever you want using gnome applet. The downside is: bluetooth is disabled upon login, so I don't know whether or not it will consume power while at login screen.

Last edited by axper (2013-03-30 11:51:38)

Offline

#6 2013-03-31 08:42:46

jacobopantoja
Member
From: Madrid
Registered: 2011-03-16
Posts: 44

Re: bluetooth not powered, but gnome icon 'on'

Something similar is happening me on KDE, on a laptop that I don't use very often.

The most repeatable solution that I have found is just doing

# hciconfig hci0 up

and (at least in my case) all the hooks seem to work OK (i.e. icon goes ok, system settings work, etc).

Test it and, if you find it working, you can include the above command on your system start (even followed by a "down" command to save power).

Last edited by jacobopantoja (2013-03-31 08:55:43)

Offline

Board footer

Powered by FluxBB