You are not logged in.

#1 2012-04-07 15:36:50

Kilzool
Member
From: Ireland
Registered: 2010-08-04
Posts: 228

[SOLVED] SSH questions (forward / channel 0 / socket)

> ssh -X2 192.100.5.100

connected to 192.100.5.100
X11 forwarding request failed on channel 0      <--------------- ????


> cat /var/log/errors.log | grep -i sshd

sshd[1677]: error: Failed to allocate internet-domain X11 display socket.    <-------- ????

Last edited by Kilzool (2012-04-15 11:32:54)

Offline

#2 2012-04-07 16:41:16

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,282

Re: [SOLVED] SSH questions (forward / channel 0 / socket)

Does the server allow X11 forwarding?


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

#3 2012-04-07 16:51:44

Gcool
Member
Registered: 2011-08-16
Posts: 1,456

Re: [SOLVED] SSH questions (forward / channel 0 / socket)


Burninate!

Offline

#4 2012-04-14 02:48:45

Kilzool
Member
From: Ireland
Registered: 2010-08-04
Posts: 228

Re: [SOLVED] SSH questions (forward / channel 0 / socket)

Gcool wrote:

I have followed this WIKI, and still getting the error when I connect:


X11 forwarding request failed on channel 0

Offline

#5 2012-04-14 08:19:04

Gcool
Member
Registered: 2011-08-16
Posts: 1,456

Re: [SOLVED] SSH questions (forward / channel 0 / socket)

I just tested myself with the exact settings on the wiki, and X11 forwarding works just fine here.

Maybe a long shot, but do you have ipv6 enabled? If so, try disabling it.


Burninate!

Offline

#6 2012-04-14 14:06:42

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,282

Re: [SOLVED] SSH questions (forward / channel 0 / socket)

Perhaps you could pastebin your /etc/ssh/sshd_config from the server, and the /etc/ssh/ssh_config from the client.  Then give us the links.

Also, please add the -v switch to your ssh command and post the output.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

#7 2012-04-15 11:34:29

Kilzool
Member
From: Ireland
Registered: 2010-08-04
Posts: 228

Re: [SOLVED] SSH questions (forward / channel 0 / socket)

Gcool wrote:

I just tested myself with the exact settings on the wiki, and X11 forwarding works just fine here.

Maybe a long shot, but do you have ipv6 enabled? If so, try disabling it.


UPDATE: Solved.  I just had to uncomment:  'AddressFamily all'  in sshd_config
In this case, I uncommented it, and changed it to AddressFamily inet

Offline

#8 2012-04-25 01:47:22

Ishpeck
Member
From: Earth
Registered: 2011-06-02
Posts: 48
Website

Re: [SOLVED] SSH questions (forward / channel 0 / socket)

Kilzool wrote:

UPDATE: Solved.  I just had to uncomment:  'AddressFamily all'  in sshd_config
In this case, I uncommented it, and changed it to AddressFamily inet

These exact steps worked for me as well.


If I were to ask you a hypothetical question, what would you want it to be about?

Offline

#9 2012-08-23 06:04:24

unhammer
Member
Registered: 2009-10-01
Posts: 97
Website

Re: [SOLVED] SSH questions (forward / channel 0 / socket)

Note: it should be "any", not "all" (which gives /etc/ssh/sshd_config line 14: unsupported option "all" on rc.d restart sshd)

Also, on an IPv4 Ubuntu client, setting it to "inet" fixed it here. I updated https://wiki.archlinux.org/index.php/Se … forwarding

Offline

#10 2012-11-08 23:40:25

andrej.podzimek
Member
From: Zlín, Czech Republic
Registered: 2005-04-10
Posts: 81
Website

Re: [SOLVED] SSH questions (forward / channel 0 / socket)

Limiting the address family is simply useless. The only thing to verify is whether xorg-xauth is installed on the systems. The error message will go away if xorg-xauth is present. Suggestions around xhost on the wiki do not make sense, since ssh tunnels X11 from one loopback interface to another; it doesn't connect to the X-server from remote hosts.

Offline

#11 2013-04-02 14:47:44

magiusche
Member
Registered: 2008-12-05
Posts: 16

Re: [SOLVED] SSH questions (forward / channel 0 / socket)

andrej.podzimek wrote:

Limiting the address family is simply useless. The only thing to verify is whether xorg-xauth is installed on the systems. The error message will go away if xorg-xauth is present. Suggestions around xhost on the wiki do not make sense, since ssh tunnels X11 from one loopback interface to another; it doesn't connect to the X-server from remote hosts.

Installing xorg-xauth as suggested is THE ONLY way to solve the problem for me!

THX to andrej.podzimek


Hope i help you!
and
VICE.VERSA

Offline

Board footer

Powered by FluxBB