You are not logged in.

#1 2013-04-04 03:30:38

alexbuzzbee
Member
Registered: 2013-04-04
Posts: 4

GRUB not installing

Grub is not installing due to the error "/boot/grub is not accessible to grub at boot. Installation is impossible." Please help.
(Also the anti-spambot check on this forum is VERY ANNOYING)

Offline

#2 2013-04-04 03:33:23

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,329
Website

Re: GRUB not installing

alexbuzzbee wrote:

(Also the anti-spambot check on this forum is VERY ANNOYING)

Nowhere near as annoying as the volumes of spam we used to get...


/boot/ is mounted, presumably?


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#3 2013-04-04 03:36:54

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: GRUB not installing

alexbuzzbee wrote:

... Please help.

You know most posters here are in fact coming for help.

Do you have a /boot/grub?  How is your partition table laid out?  Where does /boot/grub reside within those partitions?  Are you trying to install this on a new installation? 

As you can see, if you really want that help, you definitely need to ask in a more complete way.  We cannot guess what your situation actually is.

BTW, we sure as hell don't get a lot of spam here, so I am okay with it being annoying to you if that means we don't get spam.

Offline

#4 2013-04-04 03:42:08

alexbuzzbee
Member
Registered: 2013-04-04
Posts: 4

Re: GRUB not installing

Installing in VirtualBox. /boot/grub exists on root partition.
Partition table:

/dev/sda 8GB
-/dev/sda1 root 7GB
-/dev/sda2 home 1023MB
-/dev/sda3 grub partition 1007KB

Last edited by alexbuzzbee (2013-04-08 18:04:35)

Offline

#5 2013-04-04 03:53:46

alexbuzzbee
Member
Registered: 2013-04-04
Posts: 4

Re: GRUB not installing

jasonwryan wrote:
alexbuzzbee wrote:

(Also the anti-spambot check on this forum is VERY ANNOYING)

Nowhere near as annoying as the volumes of spam we used to get...


/boot/ is mounted, presumably?

Ah, I see why you went with such a complicated question.

Also, I was not aware that you needed to mount /boot, although it exists and it's subdirectory grub also exists if you'll kindly take a look at my response to WonderWoofy.

Offline

#6 2013-04-06 22:19:24

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,670

Re: GRUB not installing

alexbuzzbee wrote:

Installing in VirtualBox. /boot/grub exists on root partition.
Partition table:
/dev/sda 8GB
-/dev/sda1 root 7GB
-/dev/sda2 home 1023MB
-/dev/sda3 grub partition 1007KB

What's the grub partition for? Is this GPT partitioning with grub-bios? If so, show the output of

gdisk -l /dev/sda

.

Also tell us exactly what you did to install grub and exactly what errors you get.

Please use [code ][/code ] tags (without the spaces) for posting code.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#7 2013-04-08 18:37:15

alexbuzzbee
Member
Registered: 2013-04-04
Posts: 4

Re: GRUB not installing

cfr wrote:
alexbuzzbee wrote:

Installing in VirtualBox. /boot/grub exists on root partition.
Partition table:
/dev/sda 8GB
-/dev/sda1 root 7GB
-/dev/sda2 home 1023MB
-/dev/sda3 grub partition 1007KB

What's the grub partition for? Is this GPT partitioning with grub-bios? If so, show the output of

gdisk -l /dev/sda

.

Also tell us exactly what you did to install grub and exactly what errors you get.

Please use [code ][/code ] tags (without the spaces) for posting code.

Fixed the missing tags smile.
Output of gdisk -l /dev/sda:

GPT fdisk (gdisk) version 0.8.6

Partition  table can:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with protective MBR; using GPT.
Disk /dev/sda: 16777216 sectors, 8.0 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): 14229922-4E3C-4459-A225-7DFA7852119B
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 16777182
Partitions will be aligned on 2-sector boundries
Total free space is 0 sectors (0 bytes)

Number  Start (sector)    End (sector)  Size           Code  Name
   1                   2048       14682111   7.0 GiB        8300   root
   2            14682112       16777182   1023.0 MiB  8300   home
   3                      34              2047    1007.0 KiB  EF02

(Yes. I know it's a small hard disk. Installing in VirtualBox, remember?)

Exact error message from GRUB:
Um... It works now.
OK, Thread closed!

Offline

#8 2013-04-08 18:38:31

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,079

Re: GRUB not installing

alexbuzzbee wrote:

Um... It works now.
OK, Thread closed!

Mark your thread as solved then.


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

Board footer

Powered by FluxBB