You are not logged in.

#1 2013-04-04 19:25:49

Campaigner444
Member
From: Big Lick, VA
Registered: 2013-03-30
Posts: 1

lib32-libgl conflict with pacman -Su command

When I attempted sudo pacman -Su I get...

:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: google-earth: requires lib32-libgl
:: steam: requires lib32-libgl

How should I deal with this conflict? Thanks.

Offline

#2 2013-04-04 19:38:32

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 5,122

Re: lib32-libgl conflict with pacman -Su command

What video drivers are you running?

Offline

#3 2013-04-04 19:43:34

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,338
Website

Re: lib32-libgl conflict with pacman -Su command

Only ever use -Syu...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Online

#4 2013-04-04 19:45:35

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 5,122

Re: lib32-libgl conflict with pacman -Su command

jasonwryan wrote:

Only ever use -Syu...

Why? -Su should be just fine, it's -Sy that causes problems if not followed by a -Su.

Offline

#5 2013-04-04 19:57:12

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,338
Website

Re: lib32-libgl conflict with pacman -Su command

So that the OP learns to work from an up-to-date db.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Online

#6 2013-04-04 20:03:15

drrossum
Member
From: Chicago
Registered: 2009-02-24
Posts: 69

Re: lib32-libgl conflict with pacman -Su command

Same problem here.  Looks like there's a dependency cycle...

 sudo pacman -S lib32-libgl
:: There are 4 providers available for lib32-libgl:
:: Repository multilib
   1) lib32-catalyst-utils  2) lib32-mesa-libgl  3) lib32-nvidia-304xx-utils  4) lib32-nvidia-libgl

Enter a number (default=1): 4
resolving dependencies...
looking for inter-conflicts...
:: lib32-nvidia-libgl and lib32-nvidia-utils are in conflict (lib32-libgl). Remove lib32-nvidia-utils? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: lib32-nvidia-libgl: requires lib32-nvidia-utils

Offline

#7 2013-04-04 20:05:54

dag
Member
From: US
Registered: 2013-01-20
Posts: 216

Re: lib32-libgl conflict with pacman -Su command

I had this issue yesterday too I use -Syyu but its all good today it updated nvidia and libgl all in one go.


--------------------------------------
alcoves wonder creates the wonder unto the ages; never lose that.

Offline

#8 2013-04-04 20:18:54

drrossum
Member
From: Chicago
Registered: 2009-02-24
Posts: 69

Re: lib32-libgl conflict with pacman -Su command

This solved the dependency issue for me.  Explicitly install the version of the lib32-libgl that you need together with lib32-nvidia-utils:

sudo pacman -S lib32-nvidia-libgl lib32-nvidia-utils
resolving dependencies...
looking for inter-conflicts...

Targets (2): lib32-nvidia-libgl-313.30-1  lib32-nvidia-utils-313.30-1

After that, you can do a

pacman -Su

Last edited by drrossum (2013-04-04 20:31:17)

Offline

#9 2013-04-04 20:47:58

rabcor
Member
Registered: 2013-02-09
Posts: 495

Re: lib32-libgl conflict with pacman -Su command

Sorry if this is a stupid question.

# pacman -Syu
:: Synchronizing package databases...
....
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: steam: requires lib32-libgl

I read up an old (and very long) thread about the same issue but nothing i found in there solved it for me. Usually the problem was that something unnecessary (like nouveau or some video drivers from the xorg package group) was installed.

This does not seem to be the case for me.

# pacman -S lib32-libgl
.......
:: lib32-nvidia-libgl and lib32-nvidia-utils are in conflict

and as i found in the other thread

# pacman -Qs dri
local/lib32-nvidia-utils 313.26-1
    NVIDIA drivers utilities and libraries. (32-bit)
local/libirman 0.4.5-3
    Irman driver lcd library
local/libraw1394 2.1.0-1
    Provides an API to the Linux IEEE1394 (FireWire) driver
local/nvidia 313.26-2
    NVIDIA drivers for linux.
local/nvidia-utils 313.26-1
    NVIDIA drivers utilities and libraries.
local/os-prober 1.57-3
    Utility to detect other OSes on a set of drives
local/xf86-input-evdev 2.8.0-1 (xorg-drivers xorg)
    X.org evdev input driver

I don't see anything i could uninstall to fix this issue.

I thought for a moment that adding "IgnorePkg   = lib32-libgl"
to pacman.conf would do something but it didn't help (someone in the other thread talked about ignoring libgl)

What can i do?

Last edited by rabcor (2013-04-04 20:49:19)

Offline

#10 2013-04-04 20:49:15

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,338
Website

Re: lib32-libgl conflict with pacman -Su command

Merging with the thread directly below this that has the solution...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Online

#11 2013-04-04 20:49:21

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,079

Re: lib32-libgl conflict with pacman -Su command

rabcor wrote:

What can i do?

Search the forums. There are 3 solved threads on the issue.


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#12 2013-04-05 04:48:13

Svenstaro
Developer
From: Germany
Registered: 2008-11-19
Posts: 365

Re: lib32-libgl conflict with pacman -Su command

This problem only exists on old pacman 4.0. You need 4.1 for this to update fine.

Offline

#13 2013-04-09 02:56:22

krel
Member
Registered: 2012-11-04
Posts: 7

Re: lib32-libgl conflict with pacman -Su command

Inxsible wrote:
rabcor wrote:

What can i do?

Search the forums. There are 3 solved threads on the issue.

I am having this same problem without a solution. As fun as it is to be snarky, it would be helpful to link to these threads in the future.

Offline

#14 2013-04-09 14:13:03

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,079

Re: lib32-libgl conflict with pacman -Su command

krel wrote:
Inxsible wrote:
rabcor wrote:

What can i do?

Search the forums. There are 3 solved threads on the issue.

I am having this same problem without a solution. As fun as it is to be snarky, it would be helpful to link to these threads in the future.

I guess i have to teach everyone to read too. You are in a thread which has a solution. Have you bothered to try that?

Still clueless? See post #8


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

Board footer

Powered by FluxBB