You are not logged in.

#26 2013-04-04 15:20:31

ryosaeba83
Trusted User (TU)
From: Como (Italy)
Registered: 2008-07-21
Posts: 34
Website

Re: [SOLVED] libgl

You have to combine both instruction I posted like this:

pacman -Rdd nvidia-utils lib32-nvidia-utils
pacman -S nvidia-libgl lib32-nvidia-libgl
pacman -Su

Last edited by ryosaeba83 (2013-04-04 15:20:41)


TU id: mtorromeo
My packages: Community, AUR

Offline

#27 2013-04-04 16:25:50

zeroadhesion
Member
From: Sofia, Bulgaria
Registered: 2012-09-06
Posts: 8

Re: [SOLVED] libgl

If i wait, will be this fixed by the packagers, and just upgrade then?

Offline

#28 2013-04-04 16:29:43

ryosaeba83
Trusted User (TU)
From: Como (Italy)
Registered: 2008-07-21
Posts: 34
Website

Re: [SOLVED] libgl

I think Svenstaro is trying to solve this and you can try waiting if you prefer so.
The solution I proposed has no drawbacks anyway, but the choice is yours.


TU id: mtorromeo
My packages: Community, AUR

Offline

#29 2013-04-04 16:30:23

zeroadhesion
Member
From: Sofia, Bulgaria
Registered: 2012-09-06
Posts: 8

Re: [SOLVED] libgl

Thank you so much!

Offline

#30 2013-04-04 16:34:30

ryosaeba83
Trusted User (TU)
From: Como (Italy)
Registered: 2008-07-21
Posts: 34
Website

Re: [SOLVED] libgl

FWIW I don't think this is a problem in how the packages were created but more a problem in how pacman handles the dependencies.
I'm not sure there is an easy solution to this other then fixing this corner-case in pacman (and that is no easy task).
It's probably worth posting a news for the manual upgrade path.


TU id: mtorromeo
My packages: Community, AUR

Offline

#31 2013-04-04 16:40:23

zeroadhesion
Member
From: Sofia, Bulgaria
Registered: 2012-09-06
Posts: 8

Re: [SOLVED] libgl

If the problem cannot be fixed automatically, i vote for news too.

Offline

#32 2013-04-04 16:45:25

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 3,727

Re: [SOLVED] libgl

Stop using -Rdd, seriously, it is not needed.

pacman -Syu nvidia-libgl  # and lib32-nvidia-libgl if you used lib32-nvidia-utils

nvidia 313.30-2 which is currently in [testing] includes a workaround (it depends on nvidia-libgl)

Edit: It was just moved to [extra]

Last edited by Mr.Elendig (2013-04-04 17:02:22)


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

#33 2013-04-04 16:56:17

zebulon
Member
Registered: 2008-10-20
Posts: 235

Re: [SOLVED] libgl

Thanks for the update. May I suggest, this is worth a news entry?

Offline

#34 2013-04-04 17:02:19

Svenstaro
Developer
From: Germany
Registered: 2008-11-19
Posts: 365

Re: [SOLVED] libgl

I moved a fix to [extra] that should hopefully get rid of this issue at the cost of making the bumblebee package a little more ugly. It's probably worth it. Please note the the lib32-nvidia-utils->lib32-nvidia-libgl upgrade path will only be automatic in pacman 4.1 due to a limitation in pacman 4.0. pacman 4.1 will hopefully move soon.

Offline

#35 2013-04-04 17:05:02

zebulon
Member
Registered: 2008-10-20
Posts: 235

Re: [SOLVED] libgl

Svenstaro wrote:

Please note the the lib32-nvidia-utils->lib32-nvidia-libgl upgrade path will only be automatic in pacman 4.1 due to a limitation in pacman 4.0. pacman 4.1 will hopefully move soon.

That is great to hear. Thanks!

Offline

#36 2013-04-04 17:05:49

zeroadhesion
Member
From: Sofia, Bulgaria
Registered: 2012-09-06
Posts: 8

Re: [SOLVED] libgl

Thank you both Mr.Elendig and Svenstaro for the info. That's why i use Arch.

Offline

#37 2013-04-04 17:09:11

ryosaeba83
Trusted User (TU)
From: Como (Italy)
Registered: 2008-07-21
Posts: 34
Website

Re: [SOLVED] libgl

Mr.Elendig wrote:

Stop using -Rdd, seriously, it is not needed.

pacman -Syu nvidia-libgl  # and lib32-nvidia-libgl if you used lib32-nvidia-utils

I guess you are right that manually requesting nvidia-libgl fixes the upgrade issue, I did not try it, anyway I don't think -Rdd had any ill effect.

@Svenstaro: nice job with the fix, thanks!


TU id: mtorromeo
My packages: Community, AUR

Offline

#38 2013-04-04 17:18:08

denn1s
Member
From: Guatemala
Registered: 2009-03-10
Posts: 28

Re: [SOLVED] libgl

This helped me as well. +1 for the news entry.


--
Running: Arch - x86_64 - KDE
On: Intel i5 - Nvidia 9600

Offline

#39 2013-04-04 17:24:43

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,071

Re: [SOLVED] libgl

people, stop power posting with +1s. Remember it is against the forum rules.


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#40 2013-04-04 18:14:41

josefnpat
Member
Registered: 2012-11-28
Posts: 4
Website

Re: [SOLVED] libgl

ryosaeba83 wrote:

You have to combine both instruction I posted like this:

pacman -Rdd nvidia-utils lib32-nvidia-utils
pacman -S nvidia-libgl lib32-nvidia-libgl
pacman -Su

This fixed it for me, much love.

I would like to note, that I had steam installed, and it was conflicting as well.

:: lib32-cairo: requires lib32-libgl
:: lib32-glu: requires lib32-libgl
:: lib32-qt4: requires lib32-libgl
:: steam: requires lib32-libgl 

Last edited by josefnpat (2013-04-04 18:15:40)

Offline

#41 2013-04-04 19:11:02

blackout23
Member
Registered: 2011-11-16
Posts: 780

Re: [SOLVED] libgl

josefnpat wrote:
ryosaeba83 wrote:

You have to combine both instruction I posted like this:

pacman -Rdd nvidia-utils lib32-nvidia-utils
pacman -S nvidia-libgl lib32-nvidia-libgl
pacman -Su

This fixed it for me, much love.

I would like to note, that I had steam installed, and it was conflicting as well.

:: lib32-cairo: requires lib32-libgl
:: lib32-glu: requires lib32-libgl
:: lib32-qt4: requires lib32-libgl
:: steam: requires lib32-libgl 

Isn't to surprising isn't it?

Offline

#42 2013-04-04 20:52:20

highway
Member
Registered: 2012-07-28
Posts: 68

Re: [SOLVED] libgl

ryosaeba83 wrote:

You have to combine both instruction I posted like this:

pacman -Rdd nvidia-utils lib32-nvidia-utils
pacman -S nvidia-libgl lib32-nvidia-libgl
pacman -Su

thanks for this!

first trouble i've had since i switched to arch full-time . . . great community help as always!

Offline

#43 2013-04-04 20:54:53

rabcor
Member
Registered: 2013-02-09
Posts: 495

Re: [SOLVED] libgl

ryosaeba83 wrote:

Upgrade through this steps:

pacman -Rdd nvidia-utils
pacman -S nvidia-libgl
pacman -Su

Thanks a lot! I had been googling this issue for like an hour!

However it fails on the pacman -Su step on my end. it just gives me that

:: steam: requires lib32-libgl

Let me try rebooting...

Edit: that went bad.

I had to reinstall the nvidia drivers (pacman -S nvidia)

Even after running "pacman -Rdd nvidia-utils" i still get this.

# pacman -S lib32-libgl
...
   4) lib32-nvidia-libgl

Enter a number (default=1): 4
...
:: lib32-nvidia-libgl and lib32-nvidia-utils are in conflict (lib32-libgl). Remove lib32-nvidia-utils? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: lib32-nvidia-libgl: requires lib32-nvidia-utils

Edit 2(Solution):
pacman -Syu lib32-nvidia-libgl

worked for me. Thanks Mr.Elendig

Last edited by rabcor (2013-04-04 21:14:16)

Offline

#44 2013-04-04 21:10:20

Selo
Member
Registered: 2012-02-08
Posts: 36

Re: [SOLVED] libgl

Mr.Elendig wrote:

Stop using -Rdd, seriously, it is not needed.

pacman -Syu nvidia-libgl  # and lib32-nvidia-libgl if you used lib32-nvidia-utils

nvidia 313.30-2 which is currently in [testing] includes a workaround (it depends on nvidia-libgl)

Edit: It was just moved to [extra]

I tried this one and it worked just fine. BTW News was the first place i checked and there was no information about this issue. Multiple users are effected, there really should be an entry in news before forums float with "libgl" posts.

Offline

#45 2013-04-05 01:48:32

T.J.S.
Member
Registered: 2012-08-14
Posts: 83

Re: [SOLVED] libgl

Svenstaro wrote:

I moved a fix to [extra] that should hopefully get rid of this issue at the cost of making the bumblebee package a little more ugly. It's probably worth it. Please note the the lib32-nvidia-utils->lib32-nvidia-libgl upgrade path will only be automatic in pacman 4.1 due to a limitation in pacman 4.0. pacman 4.1 will hopefully move soon.

So now pacman lets you "see" only the 64-bit versions, and installs automatically the 32-bit versions of the packages?
It's not very clear to me what happens here.

Thanks though, it's been fixed for me.

edit. Nevermind, I had forgotten to enable multilib in the new pacman.conf.  You can ignore the above nonsense, sorry for that.

Last edited by T.J.S. (2013-04-05 02:19:43)

Offline

#46 2013-04-05 04:49:19

Svenstaro
Developer
From: Germany
Registered: 2008-11-19
Posts: 365

Re: [SOLVED] libgl

The upgrade should be completely smooth on pacman 4.1.

Offline

#47 2013-04-05 07:05:13

Narve
Member
Registered: 2012-07-14
Posts: 4

Re: [SOLVED] libgl

nvidia-libgl as a dependency for nvidia/nvidia-utils is broken, because "we bumblebee users" want to use it with mesa-libgl.
can you please make it depend on libgl instead?
same with the multilib-package ofc. smile

Last edited by Narve (2013-04-05 07:07:30)

Offline

#48 2013-04-05 07:08:24

Svenstaro
Developer
From: Germany
Registered: 2008-11-19
Posts: 365

Re: [SOLVED] libgl

No, bumblebee provides nvidia-libgl for this reason. As per bumblebee wiki, you are meant to install it like so: pacman -Syu bumblebee mesa-libgl nvidia

Submit any bugs to the tracker.

Offline

#49 2013-04-05 08:08:33

Narve
Member
Registered: 2012-07-14
Posts: 4

Re: [SOLVED] libgl

ah, sorry, ok.
didnt check the provide on bumblebee..
nevermind me then. smile

Offline

#50 2013-04-05 11:55:38

Thaodan
Member
From: Dortmund, Nordrein-Westfalen
Registered: 2012-04-28
Posts: 438

Re: [SOLVED] libgl

But how get the NVIDIA LibGL when its not bumblebee (see file contents of the package)?


Linux odin 3.13.1-pf #1 SMP PREEMPT Wed Mar 5 21:47:28 CET 2014 x86_64 GNU/Linux

Offline

Board footer

Powered by FluxBB