You are not logged in.

#1 2013-03-28 01:26:07

silentsnake
Member
Registered: 2012-02-23
Posts: 57

SSHD error: Received disconnect

Hi,

after installing openssh 6.2p1-1 I get a lot of error messages within my systems journal.

All errors are similar to this, IP addresses and PIDs vary of course.

sshd[83236]: error: Received disconnect from 84.xxx.xxx.xxx: 11: Normal Shutdown. Thank you!
sshd[83349]: error: Received disconnect from 10.0.1.xxx: 11: disconnected by user

Since ssh works perfectly fine and it seems not too uncommon to me that users are disconnecting from time to time, I don't see the point why they are classified as priority 3 error messages. Is it a bug or is there some problem with my system?

Thank you! smile

Last edited by silentsnake (2013-03-28 01:27:12)

Offline

#2 2013-04-06 23:17:55

Leonid.I
Member
From: Aethyr
Registered: 2009-03-22
Posts: 949

Re: SSHD error: Received disconnect

I double this. I'm also surprised that noone else noticed this issue...

So far, all I can say is that when running sshd.service with "-Dddd" the disconnect messages are recorded using the usual auth.info facility, not auth.err. However, systemd then complains that sshd exited with error code 255, so sshd.service enters 'failed' state


Arch Linux is more than just GNU/Linux -- it's an adventure

Offline

#3 2013-04-10 02:26:29

dwheeler
Member
Registered: 2010-11-12
Posts: 13

Re: SSHD error: Received disconnect

I'm surprised as well - maybe we're the only ones looking at our logs. smile

This looks like an upstream bug introduced by a new "feature"
https://bugzilla.mindrot.org/show_bug.cgi?id=2057

Offline

Board footer

Powered by FluxBB