You are not logged in.

#1 2013-04-11 16:02:59

JVD66
Member
Registered: 2013-04-11
Posts: 2

systemd-coredumpctl - broken ?

Confused :

[ root@jvdlin:/tmp 15:53:50 2542:105 ]
$ systemd-coredumpctl list 29588
TIME                                         PID   UID   GID SIG EXE
              Thu 2013-04-11 15:18:17 GMT  29588     0     0  11 /usr/libexec/ftpd
[ root@jvdlin:/tmp 15:53:55 2543:106 ]
$ systemd-coredumpctl -o core.ftpd.29588 dump 29588
TIME                                         PID   UID   GID SIG EXE
              Thu 2013-04-11 15:18:17 GMT  29588     0     0  11 /usr/libexec/ftpd
More than one entry matches, ignoring rest.
[ root@jvdlin:/tmp 15:54:03 2544:107 ]

ie. systemd-coredumpctl lists only one coredump for process 29588 . Why can't it dump this ?
Why does it think there is more than one dump ?

How do you get systemd-coredumpctl  to dump a coredump ?

Is the above behaviour a bug ?  ie. it lists only one coredump but has convinced itself that there is more
than one match ?  Should I raise a bug or am I missing something ? The above command line conforms
to that documented in man systemd-coredumpctl :
    systemd-coredumpctl [OPTIONS...] {COMMAND} [PID|COMM|EXE|MATCH...]
I've also tried:
     $ systemd-coredumpctl -o core.ftpd.29588 dump '29588|ftpd|/usr/libexec/ftpd|libexec/ftpd$'
     $ systemd-coredumpctl -o core.ftpd.29588 dump 'libexec/ftpd$'
     $ systemd-coredumpctl -o core.ftpd.29588 dump 'libexec/ftpd'
     $ systemd-coredumpctl -o core.ftpd.29588 dump '/usr/libexec/ftpd'
with same result as above.

This is on a fully up-to-date ArchLinux x86-64 multilib installation. 
$ pacman -Q systemd
warning: config file /etc/pacman.conf, line 19: directive 'SyncFirst' in section 'options' not recognized.
systemd 200-1

Offline

#2 2013-04-11 16:23:33

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,079

Re: systemd-coredumpctl - broken ?

please use code tags around snippets to make your post more readable.

Also search the forums for this

JVD66 wrote:

warning: config file /etc/pacman.conf, line 19: directive 'SyncFirst' in section 'options' not recognized.

SyncFirst is no longer supported.


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#3 2013-04-11 16:39:22

JVD66
Member
Registered: 2013-04-11
Posts: 2

Re: systemd-coredumpctl - broken ?

Of course, this issue is nothing to do with the SyncFirst option in pacman.conf, which I've commented out, or pacman.

This issue is only about systemd-coredumpctl , which appears to be unusably broken in the version installed as part of  'pacman -Su' .
I guess my question is answered : it appears not to be a known issue, so I will raise a bug about it.

I will try to use <code> </code> snippets in future - sorry if their omission made my previous post unclear.

Offline

#4 2013-04-11 16:43:17

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,079

Re: systemd-coredumpctl - broken ?

JVD66 wrote:

Of course, this issue is nothing to do with the SyncFirst option in pacman.conf, which I've commented out, or pacman.

This issue is only about systemd-coredumpctl , which appears to be unusably broken in the version installed as part of  'pacman -Su' .
I guess my question is answered : it appears not to be a known issue, so I will raise a bug about it.

I will try to use <code> </code> snippets in future - sorry if their omission made my previous post unclear.

You can still edit the post. Also its not the html tags, but BBCode tags like so [code ] [/code ] (without the spaces of course)

and why are you not doing a -Syu ?? its better to update your databases when upgrading packages.


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#5 2013-04-11 17:47:50

t0m5k1
Member
From: overthere
Registered: 2012-02-10
Posts: 310

Re: systemd-coredumpctl - broken ?

I'm having the same issue with systemd-coredumpctl & I cannot find any way to delete the core dumps held within journal

Beginning to consider a move as systemd is proving to be a bit too contrived for me & I hear it wants to control sysctl as well!!

Last edited by t0m5k1 (2013-04-11 17:48:10)


Optiplex 790, Intel Core i3-2100 CPU @ 3.10GHz 16Mb Corsair Vengeance 1333Mhz - GeForce 970 - AwesomeWM (occasionally XFCE, i3)

If everything in life was easy, we would learn nothing!
Linux User: 401820   Last FM

Offline

#6 2013-04-11 18:28:51

stqn
Member
Registered: 2010-03-19
Posts: 1,189
Website

Re: systemd-coredumpctl - broken ?

I’ve had trouble accessing my core dumps with systemd too. I have already disabled systemd’s journal after finding that it wasted 680 MB on my disk, but I’m not sure if that disables the hijacking of core dumps. I’ve just searched how to do that and found this answer:

# ln -s /dev/null /etc/sysctl.d/coredump.conf
# /lib/systemd/systemd-sysctl # or possibly a reboot

Offline

Board footer

Powered by FluxBB